Оператор CSM показывает состояние «failed», так как его состояние не вычисляется при установке драйвера в качестве автономного

Resumen: Состояние оператора модуля хранилища контейнеров (CSM) не вычисляется, если драйвер модуля хранилища контейнеров (CSI) установлен автономно.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Если драйвер CSI развернут без дополнительных модулей CSM с помощью оператора CSM, оператору CSM не удается вычислить состояние. Состояние — «Сбой», несмотря на то, что драйвер успешно развернут.

При выполнении kubectl describe на объекте CSM, связанном с драйвером, состояния контроллера и узла отображаются как успешные, но общее состояние показывает, что произошел сбой.
kubectl describe csm -n vxflexos vxflexos
Status:
  Controller Status:
    Available:  1
    Desired:    1
    Failed:     0
  Node Status:
    Available:  2
    Desired:    2
    Failed:     0
  State:        Failed

kubectl get csm -A
NAMESPACE   NAME       CREATIONTIME   CSIDRIVERTYPE   CONFIGVERSION   STATE
vxflexos    vxflexos   13m            powerflex       v2.9.0          Failed

 

После отображения исправления «Succeeded»:
NAMESPACE    NAME     CREATIONTIME CSIDRIVERTYPE CONFIGVERSION STATE
vxflexos     vxflexos 13s          powerflex     v2.9.0        Succeeded

Causa

Код состояния оператора не учитывал установку драйверов без модулей.

Resolución

Решение. Инженерный отдел устранил эту проблему в Dell Container Storage Modules (CSM) версии 1.9.2.

Операционная система «Operator» обновлена для расчета состояния развертывания драйвера без модулей.



Productos

Container Storage Modules Family, Container Storage Modules
Propiedades del artículo
Número del artículo: 000221974
Tipo de artículo: Solution
Última modificación: 03 sept 2025
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.