Data Protection Advisor (DPA) : La demande de collecte de données PPDM échoue avec la fonction interceptée InvalidStatusException

Resumen: La demande de collecte de données PPDM échoue avec la fonction de message interceptée InvalidStatusException

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

La section History de la demande de collecte de données de PPDM Job Monitor contient le message d’état suivant :
Function jobmonitor caught ProcessingException

Le même message se produit dans le dpaagent.log après avoir demandé une réponse API au serveur PPDM :
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute() : Function jobmonitor caught InvalidStatusException

Causa

La demande d’API avant l’ERR n’a pas répondu avec l’état attendu.
Le dpaagent.log bas de débogage affiche la requête API qui a généré l’exception :

DBG1 12669.12677 20210211:071704 com.emc.dpa.agent.co - get() : GET [/api/v2/assets ?pageSize=5000&page=1]
ERR 12669.12677 20210211:071804 com.emc.dpa.agent.mo - execute() : Function jobmonitor caught InvalidStatusException


À l’aide d’un client REST, la requête /api/v2/assets ?pageSize=5000 générait le message suivant à partir du serveur PPDM après 60 secondes :

{ « reason » : « Gateway Timeout Error. », « remediation » : « Réessayez l’opération plus tard. », « code » : 504, « chemin » : « /api/v2/assets », « timestamp » : 1613473517745 }

L’erreur de délai d’expiration de la passerelle provient de PPDM après 60 secondes, quels que soient les délais d’expiration définis sur la demande DPA.
La demande d’API /api/v2/assets ?pageSize=100 renvoie avec succès des informations à partir du même serveur PPDM.

Resolución

DPA fonctionne comme prévu.
Le serveur PPDM renvoie un état inattendu pour la demande d’API en raison d’un problème de performance.
Ce problème doit être étudié du côté de PPDM.

Pour plus d’informations, contactez le support technique Dell.

Productos

Data Protection Advisor
Propiedades del artículo
Número del artículo: 000184325
Tipo de artículo: Solution
Última modificación: 27 may. 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.