RHEL: Import klíče Dell z linux.dell.com do systému Red Hat Enterprise Linux 9 Chyby "Hash algorithm SHA1 is not available"

Resumen: Import klíče Dell podepsaného týmem "PG Hypervisor Engineering" do systému Red Hat Enterprise Linux 9 způsobí chybu "Signature not supported". Tento klíč se používá pouze pro účely VMware bez selhání a není nutný pro žádné jiné verze Linuxu. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Import konkrétního veřejného klíče Dell v systému Red Hat Enterprise Linux verze 9 selže v případě, že

rpm -I https://linux.dell.com/files/pgp_pubkeys/0x274E9C32857A9594.asc

warning: Signature not supported. Hash algorithm SHA1 not available.


K této chybě může dojít také v případě, že je tento klíč přidán do konfiguračního souboru yum.repos.d pro místní kopii úložiště Dell Update Package (DUP) a OpenManage Server Administrator (OMSA).

Causa

Systém Red Hat Enterprise Linux 9 ve výchozím nastavení odmítá import klíčů výhradně pomocí starších hashů SHA1.

Resolución

Tento specifický klíč s názvem souboru 0x274E9C32857A9594.asc používá společnost Dell pouze k podepisování dvou katalogů DUP, které se používají výhradně pro konfigurace VMware ESXi a vSAN. Na rozdíl od ostatních veřejně publikovaných klíčů v https://linux.dell.com/files/pgp_pubkeys/ by tento klíč neměl být používán ani importován do žádné jiné verze Linuxu. Může být také odstraněn jako klíč GNU Privacy Guard (GPG) v jakémkoliv konfiguračním souboru /etc/yum.repos.d/. Všechny ostatní klíče jsou podepsány hodnotami hash SHA2 i SHA512, které jsou přijatelné pro zásady zabezpečení systému Red Hat Enterprise Linux 9.

Productos afectados

OpenManage Server Administrator
Propiedades del artículo
Número del artículo: 000217148
Tipo de artículo: Solution
Última modificación: 21 abr. 2025
Versión:  3
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.