Isilon: La lista de servicios de LWSM no responde

Resumen: Cómo enumerar la lista de servicios de LWSM cuando no responde

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

La falta de base.uzip también puede causar problemas para iniciar otros servicios, como los servicios webui y los servicios httpd, lo que afectará el acceso a la GUI en el nodo afectado.

  • Cuando el servicio LWSM tiene problemas, dará los siguientes errores como los que se muestran a continuación cuando usamos un comando como el siguiente: -

    /usr/likewise/bin/lwsm list
    Error: ERROR_FILE_NOT_FOUND (2)

 

  • Cuando compruebe el estado de JWT:

/usr/likewise/bin/lwsm status jwt

LW_ERROR_STRING_CONV_FAILED
Failed to convert string format (wide/ansi)

 

  • O cuando intentamos iniciar el servicio mediante el comando que aparece a continuación 

    /usr/likewise/sbin/lwsmd --syslog --start-as-daemon
    Error: ERROR_GEN_FAILURE (31)
     
Isilon-1# isi auth ads list
		Unable to connect to authentication daemon: ERROR_FILE_NOT_FOUND

 

Isilon-1# /usr/likewise/bin/lwio list
		zsh: no such file or directory: /usr/likewise/bin/lwio



Cuando enumeramos el archivo /base.uzip, veremos que en uno de los nodos falta /base archivo 

Isilon-1# isi_for_array -s 'ls -lh /base.uzip'
Isilon-1: ls: /base.uzip: No such file or directory
Isilon-2: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip
Isilon-3: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip

Causa

Esto podría ocurrir debido a que la partición raíz se llena, lo que puede mostrar una salida similar a la siguiente si ejecutamos el comando df -h: -

Isilon-1# df -h
Filesystem               Size    Used   Avail Capacity  Mounted on
/dev/mirror/root0        1.9G    1.8G   -126M   107%    /
devfs                    1.0K    1.0K      0B   100%    /dev
/dev/mirror/var0         956M    147M    732M    17%    /var
/dev/mirror/var-crash    2.8G    1.7M    2.6G     0%    /var/crash
/dev/mirror/keystore      60M    4.0K     55M     0%    /keystore
/dev/md0                  60M    1.2M     54M     2%    /tmp/ufp
/dev/md1                 3.5M    422K    2.8M    13%    /tmp/ipmi
OneFS                    130T    3.7T    119T     3%    /ifs

 Por lo tanto, asegúrese de que no se escriban otros datos en la partición raíz; solo se debe utilizar /ifs para los datos del cliente.

Resolución

Compruebe qué nodo tiene el archivo /base.uzip faltante:

Isilon-1# isi_for_array -s 'ls -lh /base.uzip'
Isilon-1: ls: /base.uzip: No such file or directory
Isilon-2: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip
Isilon-3: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip

Copie el archivo base.uzip del nodo bueno que tiene el archivo ubase.uzip en el nodo defectuoso y, a continuación, reinicie el nodo.

Ejemplo:

1. Copie base.uzip del nodo existente a un directorio global como Isilon_Support:

isi_for_array -n2 'cp /base.uzip /ifs/data/Isilon_Support/'

 

2. Copie base.uzip del directorio de respaldo en un nodo afectado:

 isi_for_array -n1 'cp /ifs/data/Isilon_Support/base.uzip /'

 

3. Verifique que el valor de hash md5 coincida con otros nodos y compruebe los permisos:

isi_for_array -s 'ls -lh /base.uzip'

isi_for_array -s 'md5 /base.uzip'

NOTA: Si los permisos no coinciden y es necesario ajustarlos, utilice el siguiente comando en el nodo afectado:

chmod 755 /base.uzip

  • Verifique que los permisos coincidan:

isi_for_array -s 'ls -lh /base.uzip'

Información adicional

Asegúrese de que haya suficiente espacio en la partición raíz cuando copie el archivo, de lo contrario, puede experimentar errores como el siguiente

Isilon-1: cp: fastcopy: write() failed: /base.uzip: No space left on device

Productos afectados

PowerScale OneFS
Propiedades del artículo
Número del artículo: 000182108
Tipo de artículo: Solution
Última modificación: 08 may 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.