Avamar :多数の破損したシンボリック リンクを含むデータセットのバックアップが低速で実行される
Resumen: 多数の破損したシンボリック リンクを含むデータセットのAvamarバックアップが低速で実行される。
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
多数のシンボリック リンクを含むデータセットのAvamarバックアップが低速で実行されている。
は、シンボリック リンクをバックアップしていることを示すバックアップ ログ内の多くのエントリーです。
2014-10-21 21:26:35 avtar Info <16280>: Not traversing 'E:\folder\folder\ folder\folder\folder\folder\someotherfile.zip' since it's a 'REPARSE_USER_SYMLINK_FILE' and 'dereference' flag not specified
ログ エントリーは、シンボリック リンクが壊れている可能性があることを示します。
2014/10/21-15:50:34.96600 [avtar] GetReparsePointInfo() 'E:\folder\folder\folder\folder\folder\folder\folder\folder\folder\file.exe' does not have a resolveable target
Causa
データは、以前は別のドライブでホストされ、交換および再構成されました。
バックアップ データセットには、50万を超えるシンボリック リンクを含むディレクトリーが含まれていました。
avtarがリンクの破損を検出すると、「解決可能なターゲットがありません」と報告されます。
このシナリオでは、ドライブが最近再構成されたために動作が発生しました
シンボリック リンクをチェックして破損していることが検出されると、長時間の遅延が発生します。これらの(50万)の破損したシンボリック リンクをスキャンしようとすると、バックアップに通常よりも約9時間かかりました。
これは、バックアップが --dereference で構成されていない場合でも発生しているように見えます。
参照解除フラグは、シンボリック リンクのターゲットをバックアップするようにavtarに指示します。
バックアップ データセットには、50万を超えるシンボリック リンクを含むディレクトリーが含まれていました。
avtarがリンクの破損を検出すると、「解決可能なターゲットがありません」と報告されます。
このシナリオでは、ドライブが最近再構成されたために動作が発生しました
シンボリック リンクをチェックして破損していることが検出されると、長時間の遅延が発生します。これらの(50万)の破損したシンボリック リンクをスキャンしようとすると、バックアップに通常よりも約9時間かかりました。
これは、バックアップが --dereference で構成されていない場合でも発生しているように見えます。
参照解除フラグは、シンボリック リンクのターゲットをバックアップするようにavtarに指示します。
-dereference. 2014/10/21-15:50:15.90899 [avtar] --dereference NOT specified, not adding any Cross-Volume Symlinks to freeze volumes list.
Resolución
破損したシンボリックリンク(約060万)を含むフォルダーは、バックアップから除外されました。
完了時間が11時間から約2時間に短縮されました。
完了時間が11時間から約2時間に短縮されました。
Productos afectados
AvamarProductos
Avamar, Avamar ClientPropiedades del artículo
Número del artículo: 000041052
Tipo de artículo: Solution
Última modificación: 26 mar. 2024
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.