ECS: Kody błędów S3 z możliwymi przyczynami
Resumen: Ten artykuł zawiera informacje na temat kodów błędów S3 podczas próby odczytu, zapisu lub usunięcia obiektów S3 z zasobników ECS oraz ich możliwych przyczyn.
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Kod stanu HTTP wskazuje błąd lub wyjątek, który może wystąpić, gdy zapytanie S3 jest uruchamiane w celu odczytu, zapisu lub usunięcia danych do zasobnika ECS.
Causa
Awaria użytkownika lub systemu
Resolución
| Kod stanu HTTP | Błąd ogólny | Typ błędu | Możliwe przyczyny | Artykuł |
|---|---|---|---|---|
| 400 | InvalidBucketName, InvalidRequest, InvalidArgument, InvalidPart, InvalidNamespace | Błąd użytkownika | Zasobnik lub przestrzeń nazw określone w zapytaniu s3 są nieprawidłowe, nieprawidłowe Argument wyszukiwania metadanych. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 403 | Odmowa dostępu, brak autoryzacji, SignatureDoesNotMatch, dostęp zabroniony. | Błąd użytkownika | Nieprawidłowa nazwa użytkownika S3 lub klucz tajny, nieprawidłowy styl adresowania obiektów, odmowa uprawnień z powodu listy ACL zasobnika lub zasad. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 404 | ObjectNotFound, NoSuchBucket, NoSuchBucketPolicy, NoACLFound | Błąd użytkownika | Żądany obiekt został usunięty. Zasobnik został usunięty lub nazwa zasobnika jest błędnie wpisana. Nie można odnaleźć list ACL zasobnika, wartość jest nieprawidłowa lub nie ustawiono parametru BaseUrl na VDC ECS. | ECS: Brakujący adres BaseURL powodujący błędy 400/404 podczas operacji odczytu i zapisu |
| 405 | MetadataSearchNotEnabled, MetadataOperationNotSupported, MethodNotAllowed | Błąd użytkownika | Wyszukiwanie metadanych nie jest włączone w zasobniku, nieprawidłowe Operatory używane w zapytaniu wyszukiwania metadanych (dozwolone operatory to: ==, >, <<, =, >= ) | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 409 | BucketAlreadyExists, BucketNotEmpty, ObjectUnderRetention, AccessModeNotSupported | Błąd użytkownika | Zasobnik został już utworzony, zasobnik, który próbujesz usunąć, nie jest pusty, obiekt jest w trakcie przechowywania i nie można go usunąć ani zmodyfikować. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 411 | MissingContentLength | Błąd użytkownika | Należy podać nagłówek HTTP Content-Length. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 412 | Stan wstępnyNiepowodzenie | Błąd użytkownika | Co najmniej jeden z wymienionych warunków wstępnych nie był spełniony. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 416 | Nieprawidłowy zakres | Błąd użytkownika | Nie można spełnić żądanego zakresu. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 500 | InternalError, ServerTimeout, InvalidAddressingHeader | Awaria systemu | Limit czasu odpowiedzi po stronie ECS, osiągnięto próg 90%, brak fragmentów dostępnych do wykonania żądania zapisu, usługa ECS blobsvc jest często uruchamiana ponownie. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 501 | Nie wdrożono | Awaria systemu | Żądana funkcjonalność nie została zaimplementowana. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 503 | ServiceUnavailable, SlowDown | Awaria systemu | Wysłano dużą liczbę zapytań, którą należy zmniejszyć. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
| 507 | Niewystarczająca ilość miejsca do przechowywania | Awaria systemu | Serwer nie może przetworzyć żądania, ponieważ na dysku nie ma wystarczającej ilości miejsca. | Więcej informacji na temat rozwiązywania problemów z S3 można znaleźć w sekcji Uwagi. |
Información adicional
Aby uzyskać więcej informacji na temat rozwiązywania problemów z tymi błędami, zapoznaj się z następującym artykułem: ECS: Rozwiązywanie problemów z
odczytem/zapisem/usuwaniem S3Łącze dla kodów stanu HTTP S3 w podręczniku dostępu do danych ECS 3.8.x. (Aby wyświetlić ten dokument, może być wymagane zalogowanie się jako zarejestrowany użytkownik).
odczytem/zapisem/usuwaniem S3Łącze dla kodów stanu HTTP S3 w podręczniku dostępu do danych ECS 3.8.x. (Aby wyświetlić ten dokument, może być wymagane zalogowanie się jako zarejestrowany użytkownik).
Productos afectados
ECS Appliance Software with EncryptionProductos
ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Software without EncryptionPropiedades del artículo
Número del artículo: 000120328
Tipo de artículo: Solution
Última modificación: 01 dic. 2025
Versión: 5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.