ECS: S3-felkoder med möjliga orsaker

Resumen: Använd den här artikeln för referens till S3-felkoder när du försöker läsa, skriva eller ta bort S3-objekt från ECS-bucketarna och deras möjliga orsaker.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

HTTP-statuskoden anger ett fel eller undantag som kan inträffa när en S3-fråga körs för att läsa, skriva eller ta bort data till en ECS-bucket.

Causa

Användar- eller systemfel

Resolución

 

HTTP-statuskod Allmänt fel Typ av fel  Möjlig(a) orsak(er) Artikel
400 InvalidBucketName, InvalidRequest, InvalidArgument, InvalidPart, InvalidNamespace Användarfel Bucket eller namnområde som anges i s3-frågan är ogiltiga, ogiltiga metadatasökningsargument. Mer information om felsökning av S3-problem finns i Anteckningar.
403 AccessDenied, Unauthorized, SignatureDoesNotMatch, Forbidden. Användarfel Fel S3-användarnamn eller hemlig nyckel, felaktigt objektadresseringsformat, behörighet nekad på grund av bucket-ACL eller policy. Mer information om felsökning av S3-problem finns i Anteckningar.
404 ObjectNotFound, NoSuchBucket, NoSuchBucketPolicy, NoACLFound Användarfel Det begärda objektet har tagits bort. Bucket har tagits bort eller så finns det en felstavning i bucketnamnet. Det går inte att hitta bucket-ACL:er, eller så är ingen BaseUrl inställd på ECS VDC. ECS: BaseURL saknas och orsakar 400/404-fel vid skrivåtgärder
405 MetadataSearchNotEnabled, MetadataOperationNotSupported, MethodNotAllowed Användarfel Metadatasökning är inte aktiverat i bucketen, ogiltiga Operatorer som används i metadatasökfråga (tillåtna operatorer är: ==, >, <<, =, >= ) Mer information om felsökning av S3-problem finns i Anteckningar.
409 BucketAlreadyExists, BucketNotEmpty, ObjectUnderRetention, AccessModeNotSupported Användarfel En bucket har redan skapats, bucketen som du försökte ta bort är inte tom, objektet kvarhålls och kan inte tas bort eller ändras. Mer information om felsökning av S3-problem finns i Anteckningar. 
411 MissingContentLength (på engelska) Användarfel HTTP-huvudet Content-Length måste anges. Mer information om felsökning av S3-problem finns i Anteckningar.
412 PreconditionFailed Användarfel Åtminstone ett av de villkor som du angav uppfyllde inte. Mer information om felsökning av S3-problem finns i Anteckningar.
416 Ogiltigt intervall Användarfel Det begärda intervallet kan inte uppfyllas. Mer information om felsökning av S3-problem finns i Anteckningar. 
500 InternalError, ServerTimeout, InvalidAddressingHeader Systemfel Tidsgräns för svar från ECS-sidan, kapaciteten nådde tröskelvärdet 90 %, inga segment är tillgängliga för att utföra skrivbegäran, ECS blobsvc-tjänsten startas om ofta. Mer information om felsökning av S3-problem finns i Anteckningar. 
501 Inte implementerad Systemfel Den begärda funktionen har inte implementerats. Mer information om felsökning av S3-problem finns i Anteckningar.
503 ServiceOtillgänglig, SlowDown Systemfel En hög förfrågningsfrekvens skickades som måste minskas. Mer information om felsökning av S3-problem finns i Anteckningar.
507 Otillräcklig lagring Systemfel Servern kan inte bearbeta begäran eftersom det inte finns tillräckligt med utrymme på disken. Mer information om felsökning av S3-problem finns i Anteckningar. 

Información adicional

Mer information om hur du felsöker dessa fel finns i följande artikel: ECS: Felsökning av S3-problem

med läsning/skrivning/borttagningLänk för S3 HTTP-statuskoder i ECS 3.8.x Data Access Guide. (Logga in som registrerad användare kan krävas för att visa det här dokumentet.)

Productos afectados

ECS Appliance Software with Encryption

Productos

ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Software without Encryption
Propiedades del artículo
Número del artículo: 000120328
Tipo de artículo: Solution
Última modificación: 01 dic. 2025
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.