NetWorker: Windows 클라이언트 백업 pseudo_saveset - VSS 오류

Resumen: VSS(Volume Shadow Copy Service)에 문제가 있는 pseudo_saveset NetWorker Client가 실패합니다.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

  • 백업은 NetWorker 클라이언트 소프트웨어를 사용하여 Windows 시스템에 대해 수행됩니다.
  • pseudo_saveset 백업이 실패합니다.
  • 백업 로그가 Microsoft VSS(Volume Shadow Copy Service) 오류를 보고합니다. 예:
181407:save: Step (1 of 5) for PID-8600: Save has been started on the client ''.
174412:save: Step (2 of 5) for PID-8600: Running the backup on the client '' for the save set 'pseudo_saveset'.
174424:save: Step (3 of 5) for PID-8600: Creating the snapshot for the selected save sets.
VSS OTHER: ERROR: VSS failed to process snapshot: Unable to create the VSS snapshot.
197048:save: Unable to save the SYSTEM STATE save sets and create the snapshot: Unable to create the VSS snapshot.
참고: 이는 관찰될 수 있는 VSS 오류의 한 예입니다. 정확한 VSS 오류가 아닌 경우에도 이 문서를 계속 따를 수 있습니다.
  • VSS 스냅샷을 생성할 수 없습니다.

Causa

VSS는 NetWorker 백업에서 사용하는 Microsoft 기술입니다. VSS 문제는 일반적으로 운영 체제 또는 VSS에 영향을 미치는 새 패치 설치와 관련하여 클라이언트에서 발생합니다.

Resolución

클라이언트에서 다음을 수행합니다. 
  1. 관리자 명령 프롬프트를 엽니다.
  2. NetWorker 클라이언트를 중지합니다.
net stop nsrexecd /y
  1. 중지되지 않은 NetWorker 서비스를 중지합니다.
taskkil /F /IM nsr*
  1. 중지되지 않은 NetWorker 백업 프로세스를 중지합니다.
taskkill /F /IM save* 
  1. C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw 이름 변경
  2. C:\Program Files\EMC NetWorker\nsr\tmp를 제거합니다(이름이 변경된 /tmp 디렉토리도 해당).
  3. SERVICES(또는 services.msc)를 엽니다. 
  4. VOLUME SHADOW COPY 서비스 STOP을 찾은 다음 이 서비스를 시작합니다.
  5. 시작 NetWorker 클라이언트 서비스를 다시 수행합니다.
net start nsrexecd
  • 문제가 지속되면 소규모 파일 또는 디렉토리를 테스트하여 백업하고 VSS를 제외합니다.
  1. 클라이언트에서 관리자 명령 프롬프트를 엽니다.
  2. 다음 명령을 실행하여 선택한 디렉토리 또는 파일의 소규모 백업을 테스트합니다.
save -vv -D5 -s  -b  -o VSS:*=off 
  • 백업에 성공하면 클라이언트 구성에서 VSS를 비활성화합니다. 
참고: 백업에서 VSS를 비활성화하는 것은 해결 방법으로만 수행해야 합니다. VSS가 활성화된 상태에서 Windows 백업을 수행할 수 있도록 VSS 문제의 근본 원인을 확인하고 해결해야 합니다.
  1. 특정 클라이언트에 대한 VSS를 비활성화하려면 NMC(NetWorker Management Console)에서 클라이언트 속성을 엽니다.
  2. APPS&MODULES 탭 > Backup 명령을 입력합니다.
save -o VSS:*=off
VSS 문제의 근본 원인을 파악하려면 Microsoft 관리 팀 또는 Microsoft 지원 부서에 문의하여 VSS 장애의 원인을 검토하는 것이 좋습니다.

다음 vssadmin 명령은 vssadmin Writer 상태 또는 VSS 스냅샷이 여전히 시스템에 상주하는 경우에 대한 추가 정보를 제공할 수 있습니다.
vssadmin list writers 

vssadmin list shadows

Productos afectados

NetWorker Family
Propiedades del artículo
Número del artículo: 000217007
Tipo de artículo: Solution
Última modificación: 29 nov. 2023
Versión:  10
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.