NMDA: Los respaldos de instantáneas de IBM DB2 no responden

Resumen: Módulo de NetWorker para bases de datos y aplicaciones (NMDA) Los respaldos de instantáneas de IBM DB2 no responden.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Los respaldos de instantáneas de IBM DB2 de NMDA no responden.
La base de datos DB2 está en modo de suspensión de escritura.
Error en db2diag.log

Warning:
----------------------------------------
2016-05-20-15.05.16.771114+000 E7423877A808       LEVEL: Warning
PID     : 7733668              TID  : 47390       PROC : db2sysc 0
INSTANCE: <instance_name>      NODE : 000         DB   :
APPHDL  : 0-57647              APPID: <app_id>
AUTHID  :  
EDUID   : 47390                EDUNAME: db2agent (instance) 0
FUNCTION: DB2 UDB, database monitor, sqm___sqlmonssagnt, probe:1234
DATA #1 : <preformatted>
 
This occurs when any snapshot other than list applications is attempted
on a database that is write suspended. This is necessary due to latching
conflicts. This database is skipped in the snapshot, but other databases
should still be processed. Skipping database '<db_name>'.
For more information on write suspend, please see the
'db2 set write suspend for database' command.
------------------------------------------

Causa

El flujo de trabajo de DB2 funciona como:

llamadas de DB2 db2ACSPrepare() en la biblioteca DB2 de NMDA a fin de realizar la preparación inicial para la instantánea de hardware. Una vez hecho esto, el administrador de bases de datos DB2 suspende la base de datos y llama a la función DB2 de NMDA db2ACSSnapshot(). En este caso, DB2 no llama a db2ACSSnapshot(). El flujo de trabajo deja de responder para que el motor DB2 continúe con el respaldo. PMR de soporte de IBM: Se abre 29538.004.000. El equipo de ingeniería de IBM DB2 necesita más depuración para determinar la causa raíz de este bloqueo.

Resolución

Solución alternativa:
 

  1. Cancelar respaldo actual
  2. Saque la base de datos del modo de suspensión de escritura

Con el fin de descubrir la causa raíz, el soporte de IBM DB2 solicita la siguiente información para una mayor investigación,
 

  1. Suprima o reubique las pilas o volcados en el directorio db2dump. Crea nuevas pilas o volcados sin mezclar los antiguos. (ruta de UNIX/Linux: /$INSTHOME/sqllib/db2dump).
  2. Seguimiento de DB2 durante un breve periodo de tiempo:
    db2trc on -f trace.dmp
    wait about 30 seconds
    db2trc off
    db2trc fmt trace.dmp trace.fmt
    db2trc flw trace.dmp trace.flw
  3. Reunir pilas:
    db2pd -stack all -rep 5 5
  4. Una vez completado el paso anterior, ejecute,
    procstack <PID> > db2vend.pstack.out
    El <PID> es el ID de proceso del db2vend para la base de datos.
  5. A continuación, obtenga la sesión de copia de seguridad de instantáneas,
    db2 get snapshot for applications on <dbname> > db2snap.out
  6. Ahora puede configurar la reanudación de escritura y, a continuación, volver a intentar el respaldo de instantáneas y ver si finaliza.
  7. Recopile una db2support.zip de la siguiente manera:
    db2support . -d <dbname> -c -s
  8. Comprima y envíe a IBM PMR:
  • trace.dmp
  • trace.fmt
  • trace.flw
  • db2vend.pstack.out
  • db2snap.out
  • db2support.zip

Productos afectados

NetWorker Module for Databases and Applications

Productos

NetWorker Family, NetWorker, NetWorker Module
Propiedades del artículo
Número del artículo: 000056670
Tipo de artículo: Solution
Última modificación: 27 may 2026
Versión:  6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.