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Come risolvere i problemi delle reti senza fili in Ubuntu Linux su un notebook o un desktop Dell

Resumen: L'articolo seguente fornisce informazioni su come identificare e risolvere un problema della rete senza fili su un notebook o un desktop Dell in cui è installato Ubuntu Linux.

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Sommario:

  1. Risoluzione dei problemi delle reti wireless
  2. Identificazione di eventuali problemi al di fuori del notebook o del desktop
  3. Risoluzione dei problemi di hardware
  4. Risoluzione dei problemi di software
  5. Risoluzione

 

Risoluzione dei problemi delle reti wireless

 

Questa guida alla risoluzione dei problemi consente di risolvere i problemi della rete senza fili (Wi-Fi) per notebook e desktop con il sistema operativo Ubuntu Linux.

Se sul notebook o sul desktop è installato un sistema operativo Windows, consultare il seguente articolo:


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Causa

Identificazione di eventuali problemi al di fuori del notebook o del desktop

 

  1. Il notebook o il desktop è in grado di rilevare le reti Wi-Fi locali, ma non è in grado di connettersi ad esse?

    1. Se il computer rileva le reti e riesce a connettersi a tutte tranne che alla propria, rivolgersi al proprio provider di servizi Internet (ISP). La rete stessa o le impostazioni di connessione potrebbero presentare problemi.

    2. Se il computer rileva le reti ma non riesce a connettersi a nessuna di esse e la potenza del segnale Wi-Fi è bassa, procedere al passaggio 2.

    3. Se il sistema non rileva alcuna rete anche quando è posizionato fisicamente accanto al router, procedere al passaggio 2.

    4. Se il computer riesce in modo intermittente a rilevare le reti wireless disponibili e a connettersi ad esse, andare alla sezione Risoluzione dei problemi di hardware.

    5. Se il computer non rileva la scheda Wi-Fi installata, andare al passaggio 3.

  2. È possibile connettere altri dispositivi alla rete Wi-Fi?

    1. Se è possibile, procedere seguendo questa guida.

    2. In caso contrario, contattare il proprio ISP poiché potrebbe trattarsi di un problema generale della rete.

  3. Se si avvia il notebook o il desktop nel BIOS (Basic Input Output Setup), è possibile visualizzare la scheda Wi-Fi installata?

    1. Se viene rilevata, procedere seguendo questa guida.

    2. Se non viene rilevata, andare alla sezione Risoluzione dei problemi di hardware.

Nota: quando viene visualizzata la schermata iniziale Dell, premere il tasto F2 e passare alla sezione Onboard Devices.

Schermata iniziale Dell

  1. Nel BIOS verificare che la connessione senza fili sia abilitata e disabilitare lo switch Wi-Fi se installato sul notebook o sul desktop. Avviare il sistema operativo e verificare se il problema persiste.

    1. Se persiste, proseguire la risoluzione dei problemi.

    2. Se il problema non si verifica, tornare al BIOS e abilitare nuovamente lo switch Wi-Fi. Se l'errore si ripresenta, contattare il supporto tecnico per risolvere il problema. Se l'errore non si ripresenta, il problema dovrebbe essere risolto.

    3. Se il sistema non dispone di uno switch, andare al passaggio successivo.


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Risoluzione dei problemi di hardware

 

  1. Eseguire l'avvio dal supporto di Ubuntu Linux (da CD o dispositivo USB) e verificare se il problema si presenta con quel sistema operativo.

    1. Se tutto funziona, è necessario eseguire un'installazione pulita e reinstallare i driver.

    2. In caso negativo, procedere al passaggio successivo.

Nota: quando viene visualizzata la schermata iniziale Dell, premere il tasto F12 e selezionare l'avvio da CD o da dispositivo USB dal menu delle opzioni visualizzato. Selezionare quindi Prova Ubuntu per eseguire l'avvio dal supporto anziché dal disco rigido.

Menu di avvio

  1. Il modo migliore per escludere un problema hardware consiste nello scambiare la scheda Wi-Fi con un altro notebook o desktop compatibile.

    1. È stato possibile scambiare la scheda Wi-Fi e:

      1. L'errore si è seguito dalla scheda originale al notebook o desktop funzionante e la scheda del prodotto funzionante funziona sul notebook o sul desktop. Contattare il supporto tecnico per risolvere il problema di hardware.

      2. Il problema persiste con la scheda di lavoro del notebook o del desktop e la scheda funziona correttamente nel computer funzionante. Andare alla seguente guida.

      3. L'errore scompare su entrambi i dispositivi. Si trattava di un collegamento allentato e il problema dovrebbe essere risolto.

    2. Se non è possibile eseguire lo scambio, ricollocare la scheda Wi-Fi e i cavi dell'antenna:

      1. Se la situazione cambia e il Wi-Fi inizia a funzionare, si tratta di una connessione allentata e il problema dovrebbe essere risolto.

      2. Se il problema persiste, procedere al punto successivo.

Nota: È possibile trovare il manuale del notebook o del desktop sul sito del supporto dell'utente, purché si disponga del codice di matricola o del tipo di modello.


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Risoluzione dei problemi di software

 

Nota: scollegare qualsiasi supporto di rete cablato e continuare con i seguenti passaggi per la risoluzione dei problemi.
 
Nota: Nel menu devices (Dispositivi) verificare che la modalità aereo non sia abilitata nelle impostazioni Wi-Fi.
 
  1. Utilizzare la seguente procedura di risoluzione dei problemi sulla scheda di rete wireless per verificare che la scheda sia riconosciuta:

    1. Aprire il Terminale con CTRL+ALT+T.

    2. Ottenere i dettagli della scheda e lo stato di connessione utilizzando il seguente comando:

      sudo nmcli device

      Verificare se l'output dello stato contiene connected. In caso affermativo, la scheda è collegata.

    3. In caso contrario, è possibile ottenere ulteriori dettagli dalla scheda utilizzando i seguenti comandi:

      sudo lshw -businfo
      sudo lshw -c network

    4. Il risultato dovrebbe essere simile al seguente:

      product: Intel8720A Wireless Network Adapter

    5. Il dispositivo di rete wireless è elencato?

      1. Se il dispositivo di rete wireless è elencato correttamente, reinstallare i driver del dispositivo.

      2. Se il dispositivo di rete wireless non è elencato correttamente, andare al passaggio successivo.

  2. Seguire la procedura per il tipo di connessione del dispositivo:

    1. Se il dispositivo di rete wireless è un dispositivo PCI (Peripheral Component Interconnect) interno, digitare il seguente comando:

      lspci

    2. Se il dispositivo senza fili è un dispositivo dongle USB, digitare il seguente comando:

      lsusb

  3. È possibile identificare il dispositivo negli elenchi generati?

    1. Se il dispositivo di rete wireless è ora elencato correttamente in PCI o USB, reinstallare i driver del dispositivo.

    2. Se il dispositivo di rete wireless non è elencato correttamente, contattare il supporto tecnico.

  4. Eseguire una ricerca delle reti mediante NetworkManager. Cliccare su NetworkManager nella barra dei menu.

  5. Viene visualizzato un menu a discesa con un elenco di reti wireless presenti nel campo di copertura. Selezionare la rete a cui connettersi dall'elenco.

    1. Viene mostrato l'elenco delle reti disponibili, ma il computer non si connette ad alcuna di esse. Procedere al passaggio successivo.

    2. Non viene mostrata alcuna rete. Contattare il supporto tecnico per risolvere il problema.

  6. Un'altra opzione consiste nell'eseguire una scansione dalla riga di comando. Cliccare sull'icona Home della Dash > Cerca > Terminale. Il programma Terminale si avvia e apre una finestra con un prompt.

  7. Immettere il seguente comando nel terminale:

    sudo iwconfig

terminale ubuntu

  1. Il notebook o il desktop visualizza un elenco di schede di rete:

    eth0

    No wireless extensions

    lo

    No wireless extensions

    wlan0

    IEEE 802.11bgn ESSID: off/any mode: Managed Access Point: Not-Associated Tx-Power: 16 dBm Sensitivity=0/3 Retry long limit: Seven RTS thr: off Fragment thr: off Power Management: off

    wlan0

    È la voce relativa alla scheda di rete wireless

  2. Immettere il seguente comando nel terminale: (dove <ethX> è il nome della scheda di rete wireless ottenuto con il comando precedente):

    sudo iwlist <ethX> scan

  3. Il notebook o il desktop esegue la scansione dei punti di accesso e restituisce un elenco di quelli trovati. L'output della scansione contiene alcune informazioni utili. Cercare le informazioni seguenti che potrebbero essere di aiuto per la risoluzione dei problemi.

    ESSID

    Si tratta del nome della rete wireless, ovvero l'SSID.

    modalità alternativa DisplayPort

    Indica la modalità di accesso alla rete wireless, ovvero Managed (Gestita) = modalità del punto di accesso.

    Quality (Qualità)

    Questo numero indica la qualità del segnale con un valore compreso tra 1 e 5.

    Encryption Key (Chiave di crittografia)

    Indica se la rete richiede una chiave di crittografia.

  4. Immettere il seguente comando nel terminale: (dove "-c 4" significa quattro richieste echo e "127.0.01" è l'indirizzo di loopback):

    sudo ping -c 4 127.0.0.1

    Se il loopback non funziona, allora potrebbe trattarsi di un problema con lo stack TCP/IP.

    È inoltre possibile eseguire il ping dell'indirizzo IP del router o di un sito esterno utilizzando il relativo indirizzo IP o il nome comune. Se si connette a un indirizzo, ma non a un nome comune, potrebbe trattarsi di un problema DNS.


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Resolución

  1. I risultati indicano un problema di hardware o software?

    1. In caso di un guasto hardware, contattare il supporto tecnico indicando la procedura di risoluzione dei problemi eseguita.

    2. Se dalla verifica risulta che l'hardware funziona correttamente, ma il problema persiste, il passaggio successivo dovrebbe essere quello di contattare Canonical, la società che fornisce Ubuntu Linux e i driver integrati, per eseguire procedure approfondite di risoluzione dei problemi relativi a software e driver. Tutte le informazioni sono disponibili nella pagina di supporto della community di Ubuntu Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.. È disponibile anche un gruppo di supporto della community che tenta di risolvere eventuali problemi software rimanenti.

Se in qualsiasi momento ciò che risulta differisce da quanto descritto, contattare il supporto tecnico per ulteriore assistenza nella risoluzione del problema.


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Información adicional

 

Nota:
Il supporto per il software viene fornito da Canonical nei seguenti modi:
Dell fornisce supporto tecnico:


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Productos afectados

Inspiron, Latitude, Vostro, XPS, Fixed Workstations
Propiedades del artículo
Número del artículo: 000130686
Tipo de artículo: Solution
Última modificación: 25 ene 2024
Versión:  8
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