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ECS: Solución de problemas de rendimiento de ECS

Resumen: Solución de problemas de rendimiento de ECS.

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Contenido del artículo


Síntomas

Cómo solucionar problemas de rendimiento de ECS.
 

Problemas relacionados con el rendimiento:

  • Uno o más tipos de operaciones son lentas. Este es el problema más común, ya que el problema se observa desde las aplicaciones finales.
  • Uno o más nodos son lentos o tienen una alta utilización de recursos. Esta podría ser una pregunta que plantea el monitoreo de ECS o que se encuentra como parte del uso normal.

Causa

Múltiples factores, como problemas relacionados con la red, alta carga y patrones de uso, etc.

Resolución

    Preguntas que se deben tener en cuenta cuando se experimenta una degradación del rendimiento. (Espere que el soporte técnico solicite respuestas a las siguientes consultas)

    • ¿Qué comportamiento o síntomas se están experimentando que indican un problema de rendimiento?

    • ¿Cuál es el impacto del problema?

    • ¿Cuándo se notó por primera vez el problema de rendimiento?

    ¿Algo cambió recientemente en el entorno?

    • ¿Software o hardware?
    • ¿Carga?
    • ¿Red?
    • ¿Firewall?
    • ¿Balanceador de carga?
    • ¿Se puede expresar el problema en términos de latencia o tiempo de ejecución?
    • ¿Qué es el entorno? ¿Se utiliza software y hardware? ¿Versiones? ¿Configuración? ¿Aplicación del cliente?
    • ¿Cuál es el tamaño promedio de archivo (archivos grandes y pequeños)?
    • ¿Se ven afectadas las lecturas, escrituras, eliminaciones o actualizaciones? ¿O todos los métodos afectados?
    • ¿Capacidad de lectura o escritura mediante otros métodos de acceso? ¿Se ve afectada una aplicación específica o se ven afectadas todas las aplicaciones?

    ¿Qué método de acceso se está utilizando?
    • S3
    • Veloz
    • Centera SDK (CAS) ¿Hay una transformación/ECSsync u otra migración en curso?
    • Acceso al sistema de archivos:
    • Windows con CIFS (geodrive)
    • Linux con NFS
    ¿Cuál es el patrón de acceso a las aplicaciones?
    POST crea o cambia el nombre de los objetos.
    GET recupera datos de objetos.
    PUT actualiza los atributos
    de objetos DELETE elimina objetos y metadatos del sistema.
    HEAD corresponde a cada método GET. HEAD se parece exactamente a una solicitud GET, excepto que el nombre del método es HEAD en lugar de GET.
    La respuesta para una solicitud HEAD incluye solo encabezados; no incluye un cuerpo de respuesta.
    • ¿Su aplicación se conecta a todos o a algunos nodos individuales? ¿Está configurado un balanceador de carga?

    • ¿Se puede proporcionar el espacio de nombres, la seña secreta de depósito y el UID de la aplicación afectada para que podamos usar pruebas similares en ECS?

     

    Información para recopilar en ECS si se abre una SR con el soporte técnico para ayudar a reducir la resolución de problemas

    • Los registros de aplicaciones de aplicaciones afectadas específicas de una solicitud fallida o retrasada son más beneficiosos aquí.
    • Cualquier observación de la interfaz del usuario de ECS como en un nodo offline u otras fallas críticas observadas en el menú del tablero
    • Respuestas a preguntas de la sección anterior
    • Xdoctor se ejecuta si el sistema afectado no tiene la funcionalidad dialhome.

    Propiedades del artículo


    Producto comprometido

    Elastic Cloud Storage

    Producto

    ECS Appliance, Elastic Cloud Storage

    Fecha de la última publicación

    17 feb 2023

    Versión

    3

    Tipo de artículo

    Solution