NetWorker: Cómo utilizar nsrclientfix, error "No se puede encontrar el atributo 'client id'"

Resumen: Cómo usar nsrclientfix para identificar y corregir problemas de clientid en un servidor NetWorker Server.

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Síntomas

El comando nsrclientfix se utiliza para el análisis de la base de datos de medios a fin de buscar daños en el ID del cliente.
También puede combinar clientes en la base de datos de recursos y la base de datos de medios.

Uno o más clientes tienen más de un clientid.
98519:save: Unable to setup direct save with server <nw_server>: Cannot find attribute 'client id'..
90018:save: Cannot open a save session with NetWorker server '<nw_server>': Cannot find attribute 'client id'.
<nw_client>:/etc: retried 2 times.

Causa

  • La causa general es un cliente que se identifica en la base de datos de medios durante un respaldo con un nombre que NetWorker Server no reconoce que es un alias.
  • Esto también se puede deber a la creación de un recurso de cliente con un nombre distinto del nombre elegido (nombre de cliente) para representar al cliente.
  • Un alias incorrecto en el archivo de hosts del sistema puede causar este tipo de problema. Se deben realizar correcciones en el archivo de hosts antes de realizar cualquier otra acción. 
 

Resolución

Requisitos previos

Realice los siguientes pasos antes de cambiar los índices de archivos de cliente de NetWorker.

1. Realice un "respaldo de protección del servidor" para respaldar los índices existentes, la base de datos de medios (mm) y la base de datos de recursos de NetWorker (nsrdb)
 
NOTA: El comando nsrclientfix cambia las bases de datos de medios y de configuración. En caso de que haya algún problema o error, se recomienda tener una copia de seguridad de ambas bases de datos.

Recopile la información del saveset de bootstrap con: mminfo -B

2. Apague los demonios de NetWorker en el servidor de NetWorker:
Linux: systemctl stop networker(o nsr_shutdown)
Windows: net stop nsrexecd /y
 
3. Confirme que todos los demonios de NetWorker estén inactivos:
Linux: ps -ef | grep nsr
Windows:tasklist | findstr nsr

4. Además del respaldo de protección del servidor, se pueden realizar copias de las carpetas mm y nsrdb en NetWorker Server.
A. mm: Linux: /nsr/mm Windows: .\Program Files\EMC NetWorker\nsr\mm
B. nsrdb: Linux: /nsr/res/nsrdb Windows: .\Program Files\EMC NetWorker\nsr\res\nsrdb
C. nsrladb: Linux: /nsr/res/nsrladb Windows: .\Program Files\EMC NetWorker\nsr\res\nsrladb
D. Según el tamaño del índice y el espacio disponible en el servidor, el índice también se puede copiar: Linux: /nsr/index Windows: .\Program Files\EMC NetWorker\nsr\index
 
5. Inicie los servicios de NetWorker:
Linux: systemctl start networker
Windows: net start nsrd 
 

Proceso
 

1. Identifique qué clientes tienen problemas de clientid. El siguiente comando solo comprueba posibles problemas, pero no realiza ninguna acción correctiva. 


Sintaxis:
nsrclientfix -a - -p

Ejemplo:
nsrclientfix -a - -p
alenka, alenka.emc.com <-- Uno o más clientes
temporal <: un cliente
localhost <-- Un cliente
 
La lectura y la salida del archivo tienen el mismo formato. El archivo consta de una lista separada por comas de clientes separados por líneas nuevas. El número de clientes en la línea representa las acciones realizadas.
 
3. Cree un archivo de texto con la lista de clientes que se corregirán mediante nsrclientfix
 
Nomenclatura:
nsrclientfix -aarchivo-p
Este comando no realiza ninguna acción correctiva. Crea el archivo de texto que utiliza nsrclientfix para corregir los problemas.
 
Ejemplo:
nsrclientfix -atext1-p
Alenka, alenka.emc.com
temporal
Host local

4. Revise la lista de clientes que se fusionarán.
Abra el archivo de texto creado en el paso anterior y revise cada línea:
 
Un cliente
Cuando solo hay un cliente en la línea, significa que está marcado para ser depurado. Esto no aparece durante el paso de análisis, a menos que se utilice la marca -p . Por lo general, se informa de la purga de los clientes (cuando se solicita) cuando existe un cliente antiguo sin entradas de base de datos de medios o recursos. Esto se debe a clientes antiguos retirados de servicio o a la fusión de un cliente con otro.
 
Más de un cliente
Más de un cliente significa que los clientes enumerados se fusionarán juntos. El primer nombre de la lista es el nombre principal cuyo nombre e ID de cliente se conservan (si ya existe). Los siguientes nombres (nombres secundarios) se combinan en el nombre principal. Todos los recursos de cliente de los nombres secundarios se renombran al nombre principal y se combinarán las listas de alias de todos los clientes. Las entradas de la base de datos de medios también tendrán sus ID de cliente y nombres fusionados en el nombre principal.
 
NOTA: Si los alias que desea combinar, por ejemplo, "nombre antiguo" y "nombre nuevo", no aparecen en la misma línea, debe agregar el "nombre antiguo" como alias de NetWorker del "nuevo nombre". Por ejemplo: Agregue nwclientold o nwclientdummy como alias para nwclient.
 
PRECAUCIÓN: Es importante confirmar que todos los alias enumerados en la misma línea pertenezcan al mismo host. Si hay un alias que pertenece a un host diferente, nsrclientfix combina sus savesets con el primer alias de la lista. Si los savesets deben dividirse más adelante, esto requiere una solución alternativa complicada y lenta (en resumen, elimine los savesets de la base de datos de medios y analícelos nuevamente).
.
5. Utilice nsrclientfix con el archivo de texto para corregir los problemas de clientid en los clientes que aparecen en la lista.
 
Sintaxis:
nsrclientfix -uarchivo

Ejemplo:
nsrclientfix -utext1

Fusión de los siguientes clientes en 'alenka': alenka.emc.com

Fusión de la base de datos de recursos para el cliente 'alenka'.

Fusión de la base de datos de medios para el cliente 'alenka'.

La fusión se ha completado para el cliente 'alenka'.

Purgar el cliente 'temporal'.

Depuración de la base de datos de recursos del cliente "temporal".

Depuración de la base de datos de medios del cliente "temporal".

Eliminar los respaldos de índices relacionados con el cliente "temporal" en la base de datos de medios.

Se purgó correctamente el cliente "temporal".

Depurando el cliente 'localhost'.

Depurando la base de datos de recursos del cliente "localhost".

Depurando la base de datos de medios del cliente 'localhost'.

Eliminación de respaldos de índices relacionados con el cliente "localhost" en la base de datos de medios.

Se purgó correctamente el cliente "localhost".

NOTA: Los clientes fusionados no se eliminarán. El comando nsrclientfix se debe ejecutar nuevamente para eliminar los alias que se fusionaron y no se quitaron.
 
6. Depura los clientes que se fusionaron anteriormente y ahora no tienen savesets adjuntos.
Los clientes fusionados no se eliminaron. Para eliminarlos, se debe volver a ejecutar nsrclientfix:
 
nsrclientfix -atext2-p
alenka.emc.com
 
nsrclientfix -u text2

Depurando el cliente 'alenka.emc.com'.

Depurando la base de datos de recursos del cliente 'alenka.emc.com'.

Depurando la base de datos de medios del cliente "alenka.emc.com".

Eliminar los respaldos de índice relacionados con el cliente "alenka.emc.com" en la base de datos de medios.

Se purgó correctamente el cliente "alenka.emc.com".

Información adicional

Para ver la página de los manuales de nsrclientfix, consulte el archivo adjunto "nsrclientfix man page.pdf"

Productos afectados

NetWorker

Productos

NetWorker
Propiedades del artículo
Número del artículo: 000015252
Tipo de artículo: Solution
Última modificación: 14 ene. 2026
Versión:  5
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