VPLEX: Evaluación del estado: informes completos Estado de "error" de Call Home después de la NDU

Resumen: En este artículo, se aborda el problema en el que se informa un error en el comando "health-check --full" después de una NDU, pero Call Home funciona correctamente. La solución alternativa proporcionada en este artículo ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Se informa un error en el comando "health-check --full" después de la actualización, pero la función Call Home funciona correctamente.

  • "Health-check --full" previo a NDU no informa un error.
  • Después de la NDU, en "Health-check --full" se informa "Checking Call Home Status" como error
  • ConnectEMC_config.xml archivo tiene el mismo aspecto que antes de la NDU y después de la NDU.
  • No se observan problemas en los registros relacionados con connectemc
  • Se puede acceder al servicio SMTP y no está bloqueado.
  • Call-Home funciona correctamente para cada prueba activada de Call Home.
  • El sistema CLM determina que las alertas de Call Home se reciben correctamente. Por lo tanto, confirmando que se están recibiendo las alertas de Connecthome.

Comparación de la actualización no disruptiva (NDU) PRE y POST

ANTES DE NDU:

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home............................................. OK <<<<
Checking Connectivity.......................................... OK

DESPUÉS DE LA NDU:

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... Error <<<<

Comprobación del scan.log:

service@ManagementServer:/var/log/VPlex/cli> more  health_check_full_scan.log

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... Error <<<<

Email Server under Notification type: 'onSuccess/onFailure' is either
Not reachable or invalid.
Check if Email Server IP address: '10.1.111.100' is reachable and valid.
Email Server under Notification type: 'Primary' and 'Failover' are either
Not reachable or invalid.
Check if Email Server IP address: '10.1.111.100' and '10.1.111.100' are
Reachable and valid.

Comprobación del archivo de configuración de ConnectEMC:

service@ManagementServer:/opt/emc/connectemc> cat ConnectEMC_config.xml

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>

<ConnectEMCConfig SchemaVersion="1.1.0">  
  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>Primary</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>emailalert@EMC.com</EmailAddress>
    <EmailSender>VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>

  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>Failover</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>emailalert@EMC.com</EmailAddress>
    <EmailSender> VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>

  <ConnectConfig Type="Email">
    <Retries>7</Retries>
    <Notification>onSuccess/onFailure</Notification>
    <Timeout>700</Timeout>
    <Description></Description>
    <BsafeEncrypt>no</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer>10.1.111.100</EmailServer>
    <EmailAddress>customer@genericemailaddress.com</EmailAddress>
    <EmailSender>VPlex_CKM00000000999@EMC.com</EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Call Home</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>yes</IncludeCallHomeData>
    <InsertBefore></InsertBefore>
    <PreProcess></PreProcess>
    <PostProcess></PostProcess>
    <HeloParameter></HeloParameter>
  </ConnectConfig>
</ConnectEMCConfig>

Prueba de ping de la IP del servidor de correo electrónico:

service@vplexMM:/var/log/ConnectEMC/logs> ping 10.1.111.100

PING 10.1.111.100 (10.1.111.100) 56(84) bytes of data.
--- 10.1.111.100 ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5010ms <<< packet loss 100%

Prueba de que se puede acceder al servidor de correo electrónico a través de Telnet:

service@vplexMM:~> telnet 10.1.111.100 25

Trying 10.1.111.100...
Connected to 10.1.111.100
Escape character is '^]'.
220 emc.com
helo localhost
250 emc.com
mail from: VPlex_CKM00000000999@EMC.com
250 2.1.0 Ok
rcpt to:customer@genericemailaddress.com
250 2.1.0 Ok

Ejecución de la "prueba" Call Home para ver si se informa como exitosa:
anote la hora en que envió el dial de prueba y convierta la hora local a UTC.

VPlexcli:/notifications/call-home> test

call-home test was successful.

Según la información anterior de las comprobaciones de ping y telnet, esto nos indica que el cliente permite el servicio SMTP solo en el puerto "25" y no en el "ping" de ICMP.

Este error es esperado y se puede ignorar una vez que verifique que la Call Home de prueba funcione y aparezca en /opt/emc/connectemc/archive. Después de anotar la hora en que se envió la prueba de connecthome, revise la carpeta de archivo para buscar un archivo con la misma fecha y hora, en UTC. Si ve este archivo, esto indica que VPLEX envió la Call Home de prueba.

service@ManagementServer:/opt/emc/connectemc/archive> ll
-rw-r----- 1 service users 2814 Jun 25 13:17 RSC_CKM00000000999_062518_011656000.xml
-rw-r----- 1 service users 2814 Jun 25 10:54 RSC_CKM00000000999_062518_105401000.xml
-rw-r----- 1 service users 2814 Jun 25 11:11 RSC_CKM00000000999_062518_111102000.xml
-rw-r----- 1 service users 2814 Jun 25 11:48 RSC_CKM00000000999_062518_114834000.xml

Para comprobar si CLM recibió el mensaje de Call Home de prueba, debe comunicarse con el soporte de Dell VPLEX o con un ingeniero de campo acreditado por Dell para verificarlo. Menciona este artículo.

 

Causa

La comprobación del estado de Call Home es parte del script de evaluación del estado completo , que realiza lo siguiente:

  1. Compruebe el servidor de correo electrónico para cada tipo de notificación en la carpeta /opt/emc/connectemc/ConnectEMC_config.xml
  2. Haga ping al servidor de correo electrónico. Si no se puede hacer ping al servidor por algún motivo (no se puede acceder a través de la red, el servidor está apagado, el servicio ICMP está bloqueado a través del firewall, EmailServer <> es un nombre DNS* en lugar de la dirección IP en el archivo ConnectEMC_config.xml).
NOTA: La característica DNS no es compatible con VPLEX; solo puede utilizar direcciones IP.

Como resultado, el script "health-check --full" falla y muestra el siguiente error:

Checking Call Home Status...................................... Error

El script de evaluación del estado actual comprueba si Call Home está habilitado y genera un estado de "Advertencia" si está deshabilitado.

El script de evaluación del estado también comprueba si Call Home funcionó correctamente con varias verificaciones, como las siguientes:

  • Se han generado cheques de call homes;
  • Los mensajes de correo electrónico de Call Home se enviaron correctamente;
    O
  • Si el ping del servidor SMTP está activo.

Si alguna de estas verificaciones falla, el resultado del script se marca con un error, como se muestra a continuación:

Checking Call Home Status...................................... Error

 

Resolución

Después de habilitar el protocolo ICMP en el firewall entre VPLEX y el servidor de correo electrónico seleccionado del cliente utilizado (SCG, el servidor de correo electrónico del cliente), el estado "Error" de Call Home ahora no debería informar el error.

VPlexcli:/> health-check --full

Configuration (CONF):
Checking VPlexCli connectivity to directors.................... OK
Checking Directors Commission.................................. OK
Checking Directors Communication Status........................ OK
Checking Directors Operation Status............................ OK
Checking Inter-director management connectivity................ OK
Checking ports status.......................................... OK
Checking Call Home Status...................................... OK <<<<
Checking Connectivity.......................................... OK
Checking COM Port Power Level.................................. OK
Checking Meta Data Backup...................................... OK
Checking Meta Data Slot Usage.................................. OK

 

Productos afectados

VPLEX Series

Productos

VPLEX GeoSynchrony, VPLEX VS2, VPLEX VS6
Propiedades del artículo
Número del artículo: 000050121
Tipo de artículo: Solution
Última modificación: 17 abr. 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.