El reemplazo del sistema operativo PowerFlex 4.x de CentOS con CloudLink a SUSE falla

Resumen: Mientras se realiza la migración del SO de CentOS a SLES, cuando CloudLink (clc-agent) está instalado, se produce un error y no será posible volver a intentarlo, ya que la pestaña Replace estará deshabilitada. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Como se muestra en la interfaz de usuario de la plataforma PowerFlex Manager (PFMP), el trabajo de migración falló: 

 

El trabajo de migración falló

Como se muestra en la interfaz de usuario de CloudLink, el dispositivo se encuentra en el estado desconectado:

El dispositivo se encuentra en estado desconectado:  

 

deployment.log

DEBUG [2025-03-31T07:39:59.703290] 2345512: provider/elementmanager/scaleio.rb:3934:in `update_device_original_path': scaleio-block-legacy-gateway: Updating the original path of device /dev/mapper/svm_nvme15n1
legacy-gateway: Endpoint: /api/instances/Device::df7d8fba000f0004/action/updateDeviceOriginalPathname Payload: {}
INFO  [2025-03-31T07:40:24.967795] 2345512: provider/elementmanager/scaleio.rb:1197:in `post_request': scaleio-block-legacy-gateway: VXOS REST API error encountered in post_request: {"message"=>"Device has an unhandled error that cannot yet be cleared", "httpStatusCode"=>500, "errorCode"=>564}
DEBUG [2025-03-31T07:40:24.968923] 2345512: provider/configuration/centos_sles_migration.rb:469:in `restore_disk_configuration': rackserver-6jcqj93: Failed to update disk configuration. {"message"=>"Device has an unhandled error that cannot yet be cleared", "httpStatusCode"=>500, "errorCode"=>564}:ASM::Provider::Elementmanager::Scaleio::WrappedRestClientException:/opt/asm-deployer/lib/asm/provider/elementmanager/scaleio.rb:1198:in `post_request'
/opt/asm-deployer/lib/asm/provider/elementmanager/scaleio.rb:3935:in `update_device_original_path'
DEBUG [2025-03-31T07:47:18.696164] 2345512: type/server.rb:3832:in `block in linux_ready?': rackserver-6jcqj93: OS is not yet ready: Net::SSH::ConnectionTimeout
deployer/rules/service/configuration_lane_provision_rule.rb> failed to run: VXFM332::Failed to perform OS Replacement for node stpfx3mea009np.
ERROR [2025-03-31T08:17:45.344924] 2345388: service_deployment.rb:672:in `process': VXFM332::Failed to perform OS Replacement for node stpfx3mea009np.
ERROR [2025-03-31T08:17:45.393236] 2345388: service_deployment.rb:675:in `process': VXFM332::Failed to perform OS Replacement for node stpfx3mea009np.
ERROR [2025-03-31T08:17:45.393600] 2345388: service_deployment.rb:676:in `process': ["/opt/asm-deployer/lib/asm/provider/configuration/centos_sles_migration.rb:864:in `process!'", "/opt/jruby/jruby-9.4.6.0/lib/ruby/stdlib/forwardable.rb:238:in `process!'", "/opt/asm-deployer/rules/configuration/common_configuration_rule.rb:16:in `block in (eval)'", "/opt/asm-deployer/lib/asm/rule_engine/rule.rb:204:in `run'", "/opt/asm-deployer/lib/asm/rule_engine/rule.rb:235:in `process_state'", "/opt/asm-deployer/lib/asm/rule_engine.rb:88:in `block in process_rules'", "/opt/asm-deployer/lib/asm/rule_engine/rules.rb:75:in `block in by_priority'", "org/jruby/RubyArray.java:1983:in `each'", "/opt/asm-deployer/lib/asm/rule_engine/rules.rb:74:in `by_priority'", "/opt/asm-deployer/lib/asm/rule_engine.rb:76:in `rules_by_priority'", "/opt/asm-deployer/lib/asm/rule_engine.rb:86:in `process_rules'", "/opt/asm-deployer/lib/asm/service/processor.rb:45:in `process_state'", "/opt/asm-deployer/lib/asm/service/processor.rb:52:in `block in process_state_threaded'"] 
INFO  [2025-03-31T08:17:45.394190] 2345388: service_deployment.rb:678:in `process': Status: Error  
exception.log y os-migration.log
#<ASM::UserException: VXFM332::Failed to perform OS Replacement for node stpfx3mea009np.>
/opt/asm-deployer/lib/asm/provider/configuration/centos_sles_migration.rb:864:in `process!'
/opt/jruby/jruby-9.4.6.0/lib/ruby/stdlib/forwardable.rb:238:in `process!'
/opt/asm-deployer/rules/configuration/common_configuration_rule.rb:16:in `block in (eval)'
/opt/asm-deployer/lib/asm/rule_engine/rule.rb:204:in `run'
/opt/asm-deployer/lib/asm/rule_engine/rule.rb:235:in `process_state'
/opt/asm-deployer/lib/asm/rule_engine.rb:88:in `block in process_rules'
/opt/asm-deployer/lib/asm/rule_engine/rules.rb:75:in `block in by_priority'
org/jruby/RubyArray.java:1983:in `each'

 

Impacto

Se produce un error en la migración del SO de CentOS a SLES en un sistema que tiene CloudLink instalado con todos los discos cifrados.

 

Causa

Para reemplazar correctamente el sistema operativo en un sistema que utiliza CloudLink, PFMP requiere que CloudLink cumpla con las normas. Una vez que se confirma el cumplimiento, PFMP desconecta el agente clc de CentOS y lo instala en SLES. Después de conectarse al servidor de CloudLink e intercambiar claves, los dispositivos pueden desbloquear unidades correctamente, lo que garantiza una migración sin inconvenientes con CloudLink.

Cuando se realiza un reemplazo de sistema operativo mientras CloudLink se encuentra en un estado no compatible, se ignora la migración de CloudLink, de manera similar a un reemplazo estándar del sistema operativo en un sistema sin CloudLink.  La PFMP no desconectará el agente clc en CentOS y no se instalará en SLES, lo que hará que los dispositivos entren en un estado de error.

Resolución

Para instalar CloudLink en los nodos SLES recién instalados, realice los siguientes pasos:

  1. Descargue la versión de CloudLink que cumple con RCM/IC.
  2. Acceda mediante SSH a CloudLink

Cambie la IP antes de ejecutar el comando. 

curl -o clagent.sh https://clc_address/cloudlink/agent
 
  1. Instale el agente de CloudLink:
./clagent.sh -S <clc_ip_address> -G 329d-f255
 
Nota: -G denota ID de grupo. 

"ID de grupo" es el código de registro del grupo en el enlace de la nube, según la captura de pantalla.
Si no se proporciona ningún ID de grupo, la máquina se agrega al grupo predeterminado.

agregado al grupo Predeterminado 

 
  1. Después de la instalación correcta, elimine el nodo desconectado de la interfaz de usuario de CloudLink.
  2. El dispositivo>>de bloqueo >> de la interfaz de usuario >> de PFMP selecciona los dispositivos que están en estado de error y haga clic en Borrar errores (estará activo solo para los dispositivos en estado de error) 

 Borrar errores (estará activo solo para dispositivos en estado de error)

Si los dispositivos se eliminaron manualmente, vuelva a agregarlos. 

 

Versiones afectadas

4.x

 

Productos

PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625 , PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Propiedades del artículo
Número del artículo: 000314988
Tipo de artículo: Solution
Última modificación: 11 ago. 2025
Versión:  2
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.