Data Protection Advisor (DPA): Data Collection Request continues to timeout after increasing the command timeout value

Résumé: Data Protection Advisor (DPA): Data Collection Request keeps timing out though timeout values were already increased

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Symptômes



Data Collection Requests continue to fail with timeout errors after increasing the command timeout value for the request

Cause

The Command Timeout value adjustable in the GUI controls how long the request will wait for each individual command issued by the request to complete before triggering a timeout error.  There is an additional Request Timeout setting which controls how long the request will wait for all the commands run by the request to complete and this value needs to be increased as well.  The Request Timeout value is one hour by default and can not be adjusted within the GUI.

Résolution

The Request Timeout value can be increased by updating the dpaagent_config.xml which has the following default location:

Linux : <Install Directory>/agent/etc/dpaagent_config.xml
Windows : <Install Directory>\agent\etc\dpaagent_config.xml

Before editing the dpaagent_config.xml ensure to make a copy of the file in case there is a need to revert.

Below is an example of dpaagent_config.xml file:

<AGENTCONFIG>
    <VERSION>600</VERSION>
    <AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
    <SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
    <SERVERPORT>9002</SERVERPORT>
    <SERVERSSL>true</SERVERSSL>
    <LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
    <LOGLEVEL>Info</LOGLEVEL>
</AGENTCONFIG>

The following tag will need to be added the dpaagent_config.xml to increase the Request Timeout value:

<REQUESTTIMEOUT>Value</REQUESTTIMEOUT>

Note that the timeout value is set in seconds.  The Request Timeout will need to be set to a value which allows the request to complete successfully.  Below is an example of a dpaagent_config.xml with the Request Timeout value set to 24 hours:

<AGENTCONFIG>
    <VERSION>600</VERSION>
    <AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
    <SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
    <SERVERPORT>9002</SERVERPORT>
    <SERVERSSL>true</SERVERSSL>
    <LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
    <LOGLEVEL>Info</LOGLEVEL>
    <REQUESTTIMEOUT>86400</REQUESTTIMEOUT>
</AGENTCONFIG>

Once the dpaagent_config.xml has been updated, restart the DPA Agent services so the new Request Timeout value is enabled.

Please contact Dell EMC Technical Support for further details or information.

Produits concernés

Data Protection Advisor

Produits

Data Protection Advisor
Propriétés de l’article
Numéro d’article: 000069191
Type d’article: Solution
Dernière modification: 18 Apr 2026
Version:  4
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