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ECS : Dépannage des problèmes de performances ECS

Sommaire: Dépannage des problèmes de performances ECS.

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Contenu de l’article


Symptômes

Comment résoudre les problèmes de performances ECS.
 

Problèmes liés aux performances :

  • Un ou plusieurs types d’opérations sont lents. Il s’agit du problème le plus courant, car le problème est détecté par les applications.
  • Un ou plusieurs nœuds sont lents ou ont un taux d’utilisation élevé des ressources. Il peut s’agir d’une question posée par la surveillance d’ECS, ou trouvée dans le cadre d’une utilisation normale.

Cause

Plusieurs facteurs tels que les problèmes liés au réseau, la charge élevée, les schémas d’utilisation, etc.

Résolution

    Questions à prendre en compte lors de la dégradation des performances. (Demandez au support technique de demander des réponses aux questions ci-dessous)

    • Quels sont les comportements ou symptômes rencontrés qui indiquent un problème de performances ?

    • Quel est l’impact du problème ?

    • Quand le problème de performances a-t-il été remarqué pour la première fois ?

    Quelque chose a changé récemment dans l’environnement ?

    • Logiciel ou matériel ?
    • Charge?
    • Réseau?
    • Pare-feu?
    • Répartiteur de charge ?
    • Le problème peut-il être exprimé en termes de latence ou de temps d’exécution ?
    • Qu’est-ce que l’environnement ? Logiciels et matériel utilisés ? Versions? Configuration? Application client ?
    • Quelle est la taille moyenne des fichiers (fichiers volumineux et petits) ?
    • Les lectures, écritures, suppressions ou mises à jour sont-elles affectées ? Ou toutes les méthodes concernées ?
    • Possibilité de lire ou d’écrire à l’aide d’autres méthodes d’accès ? Une application spécifique est-elle affectée ou toutes les applications sont-elles concernées ?

    Quelle méthode d’accès est utilisée :
    • S3
    • Swift
    • Centera SDK (CAS) Existe-t-il une transformation/ECSSync ou une autre migration en cours ?
    • Accès au système de fichiers :
    • Windows à l’aide de CIFS (geodrive)
    • Linux utilisant NFS
    Quel est le modèle d’accès aux applications ?
    POST crée et/ou renomme des objets.
    GET récupère les données d’objet.
    PUT met à jour les attributs d’objet
    DELETE supprime les objets et les métadonnées du système.
    HEAD correspond à chaque méthode GET. HEAD ressemble exactement à une demande GET, sauf que le nom de la méthode est HEAD au lieu de GET.
    La réponse à une demande HEAD inclut uniquement les en-têtes ; il n’inclut pas de corps de réponse.
    • Votre application se connecte-t-elle à tous ou à certains nœuds individuels ? Un répartiteur de charge est-il configuré ?

    • L’espace de nommage peut-il être fourni, le code secret de bucket et l’UID de l’application concernée afin que nous puissions utiliser des tests similaires sur ECS ?

     

    Informations à collecter sur ECS en cas d’ouverture d’une demande de service auprès du support technique pour faciliter la résolution des problèmes

    • Les logs d’application de l’application concernée spécifiques à une demande en échec ou à une demande retardée sont les plus avantageux ici.
    • Toutes les observations à partir de l’interface utilisateur ECS comme dans un nœud hors ligne ou d’autres défaillances critiques observées à partir du menu du tableau de bord
    • Réponses aux questions de la section précédente
    • Xdoctor s’exécute si le système concerné ne dispose pas de la fonctionnalité dialhome.

    Propriétés de l’article


    Produit touché

    Elastic Cloud Storage

    Produit

    ECS Appliance, Elastic Cloud Storage

    Dernière date de publication

    17 févr. 2023

    Version

    3

    Type d’article

    Solution