Kód události Openshift: 1030NODE0005 řekl:
Résumé: Zbývá méně než 3 % místa.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Zaplnění souborového systému uzlu může mít dalekosáhlý negativní dopad. Tento problém může způsobit, že u některé nebo všech aplikací naplánovaných na daný uzel dojde ke snížení výkonu až po úplnou nefunkčnost.
V závislosti na zapojeném uzlu a systému souborů může tento problém představovat kritickou hrozbu pro stabilitu clusteru.
V závislosti na zapojeném uzlu a systému souborů může tento problém představovat kritickou hrozbu pro stabilitu clusteru.
Cause
Výstraha NodeFilesystemAlmostOfSpace se podobá výstraze NodeFilesystemSpaceFillingUp, ale místo toho, aby byla založena na předpovědi, že systém souborů bude v určitém čase plný, používá jednoduché statické prahové hodnoty.
Tato výstraha se aktivuje na úrovni upozornění, když v systému souborů zbývá 5 % místa, a na kritické úrovni, když zbývají 3 % místa.
Tato výstraha se aktivuje na úrovni upozornění, když v systému souborů zbývá 5 % místa, a na kritické úrovni, když zbývají 3 % místa.
Résolution
Diagnostika:
Prostudujte si nejnovější trendy využití souborového systému na řídicím panelu. V některých případech může pravidelný vzor zápisu a čištění v systému souborů způsobit, že algoritmus lineární předpovědi spustí falešnou výstrahu.
Pomocí nástrojů a utilit operačního systému Linux můžete prozkoumat, které adresáře využívají nejvíce místa v systému souborů. Jedná se o nepravidelný stav, například proces, který se za sebou nedokáže uklidit a zabírá velké množství místa? Nebo se zdá, že problém souvisí s organickým růstem?
Pokud chcete pomoct s diagnostikou, sledujte následující metriku v PromQL (spusťte dotaz ve webové konzole OCP: Sledujte → metriky → spouštění dotazů):
node_filesystem_free_bytes
Pak zkontrolujte
$ NODE_NAME=<název instance z alert>
$ oc -n default debug node/$NODE_NAME
$ chroot /host
2.Odstraňte visící obrázky:
$ podman images -q -f dangling=true | xargs --no-run-if-empty podman rmi
3.Odstraňte nepoužívané obrázky:
$ podman images | grep -v -e registry.redhat.io -e "quay.io/openshift" -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null
4.Ukončete ladění:
$ exit
$exit
Prostudujte si nejnovější trendy využití souborového systému na řídicím panelu. V některých případech může pravidelný vzor zápisu a čištění v systému souborů způsobit, že algoritmus lineární předpovědi spustí falešnou výstrahu.
Pomocí nástrojů a utilit operačního systému Linux můžete prozkoumat, které adresáře využívají nejvíce místa v systému souborů. Jedná se o nepravidelný stav, například proces, který se za sebou nedokáže uklidit a zabírá velké množství místa? Nebo se zdá, že problém souvisí s organickým růstem?
Pokud chcete pomoct s diagnostikou, sledujte následující metriku v PromQL (spusťte dotaz ve webové konzole OCP: Sledujte → metriky → spouštění dotazů):
node_filesystem_free_bytes
Pak zkontrolujte
mountpoint popisek výstrahy.
Zmírnění problému:
V případě, že mountpoint Štítek je /, /sysroot nebo /var, odstraňte nepoužívané obrázky, abyste problém vyřešili:
$ NODE_NAME=<název instance z alert>
$ oc -n default debug node/$NODE_NAME
$ chroot /host
2.Odstraňte visící obrázky:
$ podman images -q -f dangling=true | xargs --no-run-if-empty podman rmi
3.Odstraňte nepoužívané obrázky:
$ podman images | grep -v -e registry.redhat.io -e "quay.io/openshift" -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null
4.Ukončete ladění:
$ exit
$exit
Podpora:
Pokud ani jeden z výše uvedených kroků problém nevyřeší, obraťte se na technickou podporu společnosti Dell EMC s žádostí o další šetření.
Produits concernés
APEX Cloud Platform for Red Hat OpenShiftPropriétés de l’article
Numéro d’article: 000217410
Type d’article: Solution
Dernière modification: 19 févr. 2026
Version: 3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.