Kod zdarzenia Openshift: 1038WĘZEŁ0006
Résumé: Przewiduje się, że w systemie plików w ciągu najbliższych 4 godzin skończą się i-węzły.
Symptômes
Zapełnienie systemu plików węzła może mieć szeroki negatywny wpływ. Problem może spowodować, że niektóre lub wszystkie aplikacje zaplanowane w tym węźle doświadczają pogorszenia wydajności do całkowitej niesprawności.
W zależności od węzła i systemu plików problem ten może stanowić krytyczne zagrożenie dla stabilności klastra.
Cause
Pakiet NodeFilesystemFilesFillingUp alert jest podobny do alertu NodeFilesystemSpaceFillingUp, ale przewiduje, że w systemie plików zabraknie i-węzłów, a nie bajtów miejsca do magazynowania.
Alert jest wyzwalany o critical poziom, gdy przewiduje się, że w systemie plików skończą się dostępne i-węzły w ciągu czterech godzin.
Résolution
Diagnoza
Zwróć uwagę na instance i mountpoint etykiety z alertu. Historię użycia tego systemu plików można wykreślić przy użyciu następującego zapytania w konsoli sieci Web OpenShift (Obserwowanie metryk → → Uruchamianie zapytań):
node_filesystem_files_free{
instance="<wartość etykiety instancji z alertu>",
mountpoint="<wartość etykiety punktu montowania z alertu>"
} |
Możesz również otworzyć sesję debugowania w węźle i użyć standardowych narzędzi systemu Linux, aby zlokalizować źródło użycia:
$ MOUNT_POINT='<wartość etykiety punktu montowania z alertu>' $ NODE_NAME='<wartość etykiety instancji z alertu>' $ oc debug "NAZWA_WĘZŁA/$NODE" $ df -hi "/host/$MOUNT_PUNKT" |
Zauważ, że w wielu przypadkach system plików, w którym zabraknie i-węzłów, nadal będzie miał dostępną pamięć. Wyczerpanie i-węzłów jest często spowodowane, gdy aplikacja tworzy wiele małych plików.
Łagodzenia
Liczba i-węzłów przydzielonych do systemu plików jest zwykle oparta na rozmiarze pamięci masowej. Możesz rozwiązać problem lub przynajmniej opóźnić jego negatywny wpływ, zwiększając rozmiar woluminu pamięci masowej. W przeciwnym razie określ aplikację, która tworzy dużą liczbę małych plików, a następnie dostosuj jej konfigurację lub zapewnij jej dedykowaną pamięć masową.
Wsparcie
Jeśli wszystkie powyższe czynności nie rozwiążą problemu, skontaktuj się z działem pomocy technicznej firmy Dell EMC w celu dokładniejszego zbadania problemu.