Openshift Olay Kodu: 1038DÜĞÜM0006

Résumé: Filesystem in inode'larının önümüzdeki 4 saat içinde tükeneceği tahmin ediliyor.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Bir düğümün dosya sisteminin dolu hale gelmesi yaygın bir olumsuz etkiye sahip olabilir. Bu sorun, söz konusu düğüm için planlanan uygulamaların herhangi birinin veya tümünün düşük performanstan tamamen çalışmaz hale gelmeye kadar her şeyle karşılaşmasına neden olabilir.

İlgili düğüme ve dosya sistemine bağlı olarak bu sorun, bir kümenin kararlılığı için kritik bir tehdit oluşturabilir.

Cause

Komutta NodeFilesystemFilesFillingUp uyarı, NodeFilesystemSpaceFillingUp uyarısına benzer, ancak dosya sisteminde baytlarca depolama alanı yerine inode'ların tükeneceğini tahmin eder.

Uyarı bir anda tetiklenir critical Dosya sisteminin kullanılabilir inode'lerin dört saat içinde tükeneceği tahmin edildiğinde seviye.

Résolution

Tanılama

Not instance ve mountpoint etiketleri arasına yapıştırın. OpenShift web konsolunda aşağıdaki sorguyu kullanarak bu dosya sisteminin kullanım geçmişinin grafiğini oluşturabilirsiniz (→ Ölçümlerini Gözlemleyin → Sorguları çalıştırın):

node_filesystem_files_free{
  instance="<uyarıdan örnek etiketinin> değeri",
  mountpoint="<uyarıdaki bağlama noktası etiketinin> değeri"
}

Ayrıca düğümde bir hata ayıklama oturumu açabilir ve kullanımın kaynağını bulmak için standart Linux yardımcı programlarını kullanabilirsiniz:

$ MOUNT_POINT='uyarıdaki< bağlama noktası etiketinin> değeri'
$ NODE_NAME='<uyarıdaki> örnek etiketinin değeri'

$ oc debug "node/$NODE_NAME
$ df -merhaba "/host/$MOUNT_POINT
 

Çoğu durumda, inode'leri tükenen bir dosya sisteminin hala kullanılabilir depolama alanına sahip olacağını unutmayın. Düğümlerin bitmesi genellikle bir uygulama çok sayıda küçük dosya oluşturduğunda ortaya çıkar.

Azaltma

Bir dosya sistemine ayrılan inode sayısı genellikle depolama boyutuna bağlıdır. Depolama biriminin boyutunu artırarak sorunu çözebilir veya en azından sorunun olumsuz etkisini geciktirebilirsiniz. Aksi takdirde, çok sayıda küçük dosya oluşturan uygulamayı belirleyin ve ardından yapılandırmasını ayarlayın veya ona özel depolama alanı sağlayın.

Destek

Yukarıdaki adımların tümü sorunu çözemezse daha ayrıntılı araştırma için Dell EMC teknik destek ekibiyle iletişime geçin.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217421
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.