Kód události Openshift: 1038NODE0006 řekl:

Résumé: Předpokládá se, že systém souborů vyčerpá inody během následujících 4 hodin.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Zaplnění souborového systému uzlu může mít dalekosáhlý negativní dopad. Problém může způsobit, že u některé nebo všech aplikací naplánovaných na tento uzel dojde k čemukoli, od snížení výkonu až po úplnou nefunkčnost.

V závislosti na uzlu a systému souborů může tento problém představovat kritickou hrozbu pro stabilitu clusteru.

Cause

Skript NodeFilesystemFilesFillingUp výstraha se podobá výstraze NodeFilesystemSpaceFillingUp, ale předpovídá, že systému souborů dojdou uzly, nikoli bajty úložného prostoru.

Výstraha se aktivuje v critical úroveň, kdy se předpokládá, že souborový systém vyčerpá dostupné inody do čtyř hodin.

Résolution

Diagnóza

Všimněte si instance a mountpoint popisky z výstrahy. Historii využití tohoto systému souborů můžete zobrazit pomocí následujícího dotazu ve webové konzole OpenShift (sledujte → metriky → spouštění dotazů):

node_filesystem_files_free{
  Instance=<Hodnota popisku instance z výstrahy>",
  MOUNTPOINT="<Hodnota popisku přípojného bodu z výstrahy>"
}

Na uzlu můžete také otevřít ladicí relaci a pomocí standardních nástrojů pro Linux vyhledat zdroj využití:

$ MOUNT_POINT='<hodnota štítku přípojného bodu z výstrahy>'
$ NODE_NAME='<hodnota popisku instance z výstrahy>'

$ oc debug "node/$NODE_NAME"
$ df -hi "/host/$MOUNT_BOD"
 

Všimněte si, že v mnoha případech bude mít souborový systém, kterému docházejí inody, stále dostupné úložiště. Nedostatek inodů je často způsoben tím, že aplikace vytvoří mnoho malých souborů.

Zmírnění

Počet inodů přidělených souborovému systému je obvykle založen na velikosti úložiště. Zvětšením velikosti úložného svazku můžete problém vyřešit, nebo alespoň oddálit negativní dopad problému. V opačném případě určete aplikaci, která vytváří velké množství malých souborů, a poté upravte její konfiguraci nebo jí poskytněte vyhrazené úložiště.

Podpora

Pokud ani jeden z výše uvedených kroků nevyřeší problém, obraťte se na technickou podporu společnosti Dell EMC s žádostí o další šetření.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217421
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.