Openshift Event Code: 1038NODE0007

Résumé: Filesystemet er spådd å gå tom for plass i løpet av de neste 4 timene.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Når et filsystem begynner å få lite plass, forringes systemytelsen vanligvis gradvis.

Hvis et filsystem fylles opp og går tom for plass, kan prosesser som må skrive til filsystemet, ikke lenger gjøre det, noe som kan føre til tapte data og ustabilitet i systemet.

Cause

Informasjonen i NodeFilesystemSpaceFillingUp Varselutløsere når to betingelser er oppfylt:

  • Den nåværende filsystembruken overskrider en viss terskel.
  • En ekstrapoleringsalgoritme forutsier at filsystemet vil gå tom for plass innen en viss tid. Hvis tidsperioden er mindre enn 24 timer, er dette en Warning Varsel. Hvis tiden er mindre enn 4 timer, er dette en Critical Varsel.

Résolution

Diagnose

  • Studer de nyeste trendene for bruk av filsystemer på et instrumentbord. Noen ganger kan et periodisk mønster for skriving og opprydding i filsystemet føre til at den lineære prediksjonsalgoritmen utløser et falskt varsel.

  • Bruk Linux-operativsystemverktøyene og verktøyene til å undersøke hvilke kataloger som bruker mest plass i filsystemet. Er problemet en uregelmessig tilstand, for eksempel en prosess som ikke klarer å rydde opp bak seg selv og bruker mye plass? Eller ser problemet ut til å være relatert til organisk vekst?

Hvis du vil ha hjelp til diagnosen, kan du se følgende beregning i PromQL (utfør spørringen på OCP-nettkonsollen: Vær oppmerksom på → Metrics → Run-spørringer):

node_filesystem_free_bytes

Kontroller deretter mountpoint etikett for varselet.

Klimatiltak

Hvis mountpoint etiketten er //sysroot eller /var, fjern ubrukte bilder for å løse problemet:

  1. Feilsøk noden ved å få tilgang til nodefilsystemet:

    $ NODE_NAME=<forekomstetikett fra varsel>
    $ oc -n default debug node/$NODE_NAME
    $ chroot / vert

     

  2. Fjern dinglende bilder:

    $ podman bilder-q-f dingling = sant | xargs --no-run-if-empty podman rmi

     

  3. Fjern ubrukte bilder:

    $ Podman bilder | grep -v -e registry.redhat.io -e "quay.io/openshift" -e registry.access.redhat.com -e docker-registry.usersys.redhat.com -e docker-registry.ops.rhcloud.com -e rhmap | xargs --no-run-if-empty podman rmi 2>/dev/null
     
  4. Avslutt feilsøking:

    $ avslutt
    $ avslutt

     

Support

Hvis alle trinnene ovenfor ikke kan løse problemet, kontakter du teknisk støtte hos Dell EMC for videre undersøkelser.

Produits concernés

APEX Cloud Platform for Red Hat OpenShift
Propriétés de l’article
Numéro d’article: 000217422
Type d’article: Solution
Dernière modification: 20 févr. 2026
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.