PowerStore : PowerStore Manager affiche « La configuration du cluster a échoué » lors de la tentative de configuration de vos appliances PowerStore.

Résumé: Cet article détaille le problème « La configuration du cluster a échoué » lors du processus de configuration.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Lors de l’installation initiale, PowerStore Manager affiche le message d’erreur suivant : « La configuration du cluster a échoué. »

  • Les étapes de configuration initiales requises pour qu’une ou plusieurs appliances créent un cluster échouent.
  • Le processus de configuration des appliances PowerStore est interrompu et ne peut pas être terminé.

Cause

La cause première de ce problème est généralement due à un formatage d’adresse IP incorrect. La présence de zéros non significatifs dans l’adresse IP peut entraîner l’échec du processus de création du cluster.

  • Accédez au système et exécutez une collecte de données dès que possible après la défaillance, afin de vous assurer que les conditions de la panne sont capturées pour l’analyse des causes premières.
  • Un problème matériel ou un problème de configuration peut entraîner l’échec du processus de création du cluster.
  • Tous les échecs de création de cluster nécessitent que l’appliance soit réinitialisée à l’état d’usine avant de réessayer de créer un cluster ou de l’ajouter à un cluster existant.

Résolution

Détails de l’échec dans l’interface utilisateur de PowerStore Manager

La configuration de cluster a échoué. Pour réessayer le clustering, une ou plusieurs appliances doivent être restaurées à leur mode d’usine par défaut d’origine. Contactez votre prestataire de services ou le support PowerStore pour obtenir de l’aide.

Voir PowerStore : Réinitialisation d’un système PowerStore à l’état d’usine à l’aide de la commande svc_factory_reset pour obtenir des conseils sur la réinitialisation de PowerStore à l’état d’usine.  
Voir PowerStore : Échec de la création du cluster en raison de zéro de début dans l’adresse IP si vous voyez un zéro dans l’adresse IP du cluster.

Pour faciliter le diagnostic du problème, il est vivement recommandé de rassembler des ressources de support à partir des appliances dès que possible. Consultez le site Web de support en ligne pour obtenir des instructions sur la collecte des ressources de support.

Étapes de dépannage

  1. Vérifiez le formatage de l’adresse IP : Assurez-vous que les adresses IP utilisées dans la configuration ne contiennent pas de zéros non significatifs. Par exemple, utilisez 192.168.1.1 au lieu de 192.168.001.001.
  2. Reconfigurez les paramètres réseau : Accédez aux paramètres réseau dans PowerStore Manager et corrigez toutes les adresses IP avec des zéros non significatifs.
  3. Redémarrer le processus de configuration : Après avoir corrigé les adresses IP, redémarrez le processus de configuration du cluster dans PowerStore Manager.
  4. Configuration de l’écran : Assurez-vous que le processus de configuration s’est terminé avec succès sans afficher le message d’erreur.

Remarques relatives au déploiement

  • Du point de vue du déploiement, un dépannage minimal peut être effectué à ce stade. L’appliance doit être réinitialisée avant de pouvoir être mise en service.
  • Suivez les étapes ci-dessous pour obtenir un accès physique à l’environnement d’exploitation de l’appliance, collecter des données et faire remonter le problème à votre prestataire de service pour obtenir de l’aide.


Accès à la baie PowerStore à l’aide du port LAN de service

Chaque nœud dispose d’une adresse IP permanente résidant sur le port LAN de service 1 GbE, situé à l’arrière de l’appliance PowerStore et vérifié à l’aide d’un symbole de clé jaune.
L’adresse IP du réseau LAN de service du nœud A est 128.221.1.250
L’adresse IP du réseau LAN de service du nœud B est 128.221.1.251


. Pour accéder directement à un nœud, les utilisateurs doivent définir la connexion LAN de leur ordinateur portable/station de travail sur le masque réseau 128.221.1.249, 255.255.255.0, sans adresse de passerelle. Utilisez ensuite un câble LAN reliant l’ordinateur portable au port LAN de service du nœud.  Une fois la connexion physique établie, il est recommandé de vérifier la connectivité réseau à l’adresse IP du nœud à l’aide de ping.

Une fois la connectivité établie, vous pouvez vous connecter à l’adresse IP du nœud à l’aide de SSH (autrement dit, à l’aide de Putty). Connectez-vous avec les informations d’identification de service configurées lors des étapes de configuration initiales.

Une fois connecté en tant qu’utilisateur de service, vous constatez que le shell est restreint par RBash, mais que des scripts de maintenance sont disponibles. 
Utilisez svc_help pour afficher la liste des scripts disponibles. 

Pour les problèmes de défaillance du cluster, il est recommandé d’utiliser svc_cluster_diag Pour générer des informations pertinentes, capturez et enregistrez la sortie de la console, effectuez l’étape de collecte de données recommandée et notez le chemin complet qui s’affiche pour l’emplacement de la collecte de données. Vous devez contacter votre prestataire de services pour obtenir de l’aide pour dépanner l’échec de la création de cluster et pour remettre le système dans un état prêt à l’emploi. 

 

Exemple de résultat (résumé pour l’affichage ) :

$ svc_cluster_diag

OUTIL
DE DIAGNOSTIC DES DÉFAILLANCES DE CONFIGURATION DE CLUSTER Ce script est destiné à être exécuté afin de vous aider à résoudre les problèmes qui peuvent
se produire lors de la création du cluster, de l’ajout ou de la suppression d’une appliance.
Ce script effectue les opérations suivantes :
 1) Rechercher la vérification matérielle dans le journal.
  Cette étape recherche les pannes matérielles qui ont pu se produire avant l’exécution de la création
du cluster.
 2) Effectuez une vérification du matériel actuel sur ce système à l’aide svc_diag liste
--icw_hardware.
  Cela indique s’il existe des problèmes matériels dans le système. Cela est
utile si l’exécution de la création du cluster a échoué avec le système
« UNCONFIGURED_FAULTED ».
Cela est dû au fait que la création du cluster ne peut pas être exécutée en cas de panne matérielle. Si une
panne est détectée, l’état passe à « UNCONFIGURED_FAULTED » et
la création du cluster échoue. Cette vérification permet d’identifier la panne matérielle.
3) Demandez à l’utilisateur s’il souhaite effectuer une collecte de données.
  Il est essentiel de le faire juste après l’échec de la création de cluster. Cela permet de collecter les données avant la
rotation des logs.
Cette étape permet également à l’utilisateur de définir une adresse IP pour le système. De cette façon, l’utilisateur
peut utiliser le chemin direct vers la collecte de données et l’adresse IP pour copier
les données collectées à partir du système.

============Scanning Hardware Failures============
----scanning for previous hardware failures-------
Instructions de journal nécessaires pour collecter des informations pour la commande :
         'journalctl --utc | egrep "IcwHwCheck|Unconfigured_Faulted » ' ne sont plus disponibles
----recherche des pannes matérielles actuelles--------
Running svc_diag list --icw_hardware from svc_cluster_diag hw_type Warnado-EX
Running on Node
A
Local Node - no Expansion Enclosures detected
Local Node - no Expansion Enclosures detected
----------abridged-------------
OVERALL STATUS : True, return_code 0
IOM Consistency Check : Success
Node Consistency Check : Réussite de la
vérification de la batterie :
OK Fault Status Register A : Success
Fault Status Register B : Success
Node A accessible : True
Node B accessible : True
Drive Check : Success
Node Drives Compare Check : Réussite
de la vérification du boîtier : Réussite
de la vérification de comparaison des modules d’E/S : Réussite

======Analyse des messages d’erreur de clustering======
-- Les journaux commencent le mardi 2020-01-21 00:47:04 UTC et se terminent le jeudi 2020-01-23 18:33:15 UTC. --
-- Aucune entrée --

Pour collecter les ressources de support, la collecte des données est exécutée. May take up to 60 minutes. Would you like to continue? [o/N] : y
La collecte de données essentielles est en cours d’exécution - Cela peut prendre un certain temps
=============La collecte des données est terminée=============
La collecte des données se trouve à l’emplacement suivant :
/cyc_var/cyc_service/data_collection/258247cc-ce43-437a-9360-93558ab08134/powerstore_PSf794395d3ca0_FNM00185100262_2020-01-23_18-33-48_service-data.tgz


Vous pouvez copier les données collectées hors du système à l’aide de scp et/ou pscp.
Exemple SCP :
scp user@10.180.180.120:/cyc_var/cyc_service/data_collection/258247cc-ce43-437a-9360-93558ab08134/powerstore_PSf794395d3ca0_FNM00185100262_2020-01-23_18-33-48_service-data.tgz

Exemple avec PSCP :
pscp -scp user@10.180.180.120:/cyc_var/cyc_service/data_collection/258247cc-ce43-437a-9360-93558ab08134/powerstore_PSf794395d3ca0_FNM00185100262_2020-01-23_18-33-48_service-data.tgz


 


Informations supplémentaires

Produits concernés

PowerStore
Propriétés de l’article
Numéro d’article: 000126446
Type d’article: Solution
Dernière modification: 06 Mar 2026
Version:  7
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