PowerEdge : Préparation de l’hôte VMware ESXi activé TPM pour la modification matérielle afin d’éviter l’écran violet

Résumé: Si les hôtes ESXi utilisent le module TPM (Trusted Platform Module), cet article fournit des instructions pour déterminer si l’hôte ESXi est toujours accessible via SSH avant toute modification matérielle. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Instructions

Symptômes:
Après avoir effectué la maintenance matérielle, y compris le remplacement de composants (par exemple, la batterie CMOS, le processeur, etc.), vous pouvez rencontrer des erreurs d’écran violet lors du démarrage de la sauvegarde de l’hôte.

Exemple de message de diagnostic d’écran violet

Cause:
À partir de la version 7.0u2, ESXi utilise le module TPM 2.0 pour protéger les configurations système via le « scellement TPM ». La configuration n’est accessible qu’avec la même puce TPM que celle utilisée initialement.

Pour éviter cela, il est nécessaire de collecter la clé de récupération auprès des hôtes sécurisés TPM avant d’effectuer le remplacement.

Instructions:

  1. Ouvrez une session SSH sur l’hôte ESXi
  2. Vérifiez si le module TPM est installé et si « TPM Security » est activé dans le BIOS :
[root@host1:~] esxcli hardware trustedboot get
   Drtm Enabled: true
   Tpm Present: true
  1. Obtenez la clé de récupération en exécutant la commande ci-dessous :
esxcli system settings encryption recovery list

Sortie de la touche Commande


Remarque : La clé de récupération correspond au deuxième ensemble de chiffres affiché : 16 groupes, contenant chacun six chiffres, comme indiqué ci-dessus

 

  1. Veillez à enregistrer la clé de récupération dans un endroit sûr en vue d’une utilisation ultérieure.

Remarque : Si la clé de récupération n’est pas disponible, la seule option consiste à réinstaller ESXi.

 

À ce stade, remplacez la pièce en toute sécurité. Si l’écran violet s’affichait auparavant, suivez les étapes ci-dessous pour résoudre le problème.

Étapes:

  1. Redémarrez ESXi, puis appuyez sur MAJ+O lorsque vous y êtes invité :

Écran de redémarrage

  1. Ajoutez à la configuration de démarrage les éléments suivants issus de la clé de récupération récupérée à partir des conditions préalables : 
encryptionRecoveryKey=######-######-######-######-######-######-######-######-######-######-######-######-######

 

Remarque : Ne supprimez pas les informations qui sont déjà présentes au début de l’invite.
 
À la fin de l’UUID de démarrage existant, ajoutez un espace suivi des informations encryptionRecoveryKey , comme illustré dans la capture d’écran ci-dessus.
  1. Appuyez sur Entrée pour poursuivre le processus de démarrage de l’hôte.
  2. Établissez une connexion SSH avec l’hôte et exécutez la commande ci-dessous pour écrire les modifications sur le disque :
[root@host1:~] /sbin/auto-backup.sh

Produits concernés

VMware ESXi 7.x, VMware ESXi 8.x, VMware ESXi 9.x

Produits

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Propriétés de l’article
Numéro d’article: 000318876
Type d’article: How To
Dernière modification: 17 Mar 2026
Version:  4
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