NetWorker : Dépannage des problèmes de chargement de bibliothèque de bandes dans NetWorker

Résumé: Cet article a pour but d’aider les partisans et les administrateurs à résoudre les problèmes de chargement de bibliothèque au niveau de la bibliothèque ou de l’application. Pour déterminer si le problème est logique ou physique, et s’il s’agit d’un problème avec le robot, le lecteur ou la cartouche de bande multimédia. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

  • Erreurs sporadiques ou constantes lors du chargement des cartouches de bande dans la bibliothèque
  • Impossible d’effectuer des sauvegardes ou des restaurations à partir d’un support de bibliothèque  
  • La bibliothèque est détectable, a confirmé qu’elle était fonctionnelle et prête
  • Impossible d’effectuer des opérations de chargement ou d’étiquetage
  • Bandes marquées « sans étiquette »
  • Erreurs ou messages ASC/ASCQ/SCSI SENSE possibles dans les logs du système ou de l’application
  • Erreurs sporadiques ou cohérentes lors de l’exécution d’opérations de bibliothèque spécifiques ou aléatoires

Cause

Si la configuration de la bibliothèque fonctionnait auparavant et rencontre soudainement un problème, envisagez les modifications possibles qui peuvent entraver la détection et la configuration :

  • Modification du firmware, du pilote ou de la configuration du robot, du commutateur ou de l’adaptateur
  • Ajout, remplacement ou retrait de lecteurs, de cartouches de bande ou d’autres composants de bibliothèque
  • Modification de la version du logiciel NetWorker, correctifs du système d’exploitation
  • Tout événement matériel, tel qu’une perte d’alimentation ou le redémarrage d’un composant du chemin d’accès des données.
  • Divergences entre la configuration et la bibliothèque NetWorker (par exemple, cartouches de bande déplacées hors du contrôle de NetWorker)

Si la bibliothèque n’a jamais fonctionné, vérifiez que le matériel est pris en charge dans le Guide de compatibilité matérielle NetWorker (nécessite une connexion au compte de support Dell). N’oubliez pas qu’il est possible qu’une bibliothèque soit partiellement fonctionnelle ; La découverte seule ne garantit pas la facilité d’utilisation ou la prise en charge.

Résolution

Pour résoudre les problèmes de chargement de la bibliothèque, après avoir pris en compte les dernières modifications connues, effectuez le dépannage en déléguant le processus à ses constituants primitifs et en les testant individuellement.

Les données requises sont collectées NSRGet lorsqu’il est exécuté avec la commande -o:d un paramètre switch. NetWorker : Comment utiliser l’outil de collecte de données NSRGet de NetWorker (en anglais)

Les éléments qui ne le sont pas sont limités aux opérations qui pourraient être considérées comme dangereuses si elles étaient tentées manuellement.
 

AVERTISSEMENT : Certaines de ces commandes peuvent entraîner des réinitialisations SCSI pouvant entraîner le rembobinage des unités de bande. Ne pas utiliser s’il existe des bandes actives accessibles à l’hôte.

Library Load : Communications


Library Load : Fonctionnement physique

  • Assurez-vous que les opérations de la bibliothèque sont physiquement possibles à un niveau de base. Assurez-vous que le test est effectué lorsque la bibliothèque n’est pas active et que les cartouches de bande sont replacées à leur emplacement d’origine.
Commencez par déterminer le déplacement de la cartouche de bande :
sjirdtag <changer address>

Ensuite, déplacez les cartouches de bande entre les éléments et inversement :

sjimm <changer address> <drive|slot|inlt|mt> <element_number> <drive|slot|inlt|mt> <element_number>
  • Il y a certaines situations où des erreurs peuvent être attendues ; Par exemple, les bibliothèques pour lesquelles l’éjection automatique n’est pas activée au niveau de la bibliothèque obtiennent une erreur lors de la tentative de déplacement du lecteur vers n’importe quel autre élément (la cartouche de bande doit être éjectée séparément sur un mt -f <device_handle> offline avant de sortir de l’élément).
  • Si des erreurs sont renvoyées de manière sporadique ou cohérente lors de tentatives d’opérations de robot, d’erreurs de code SCSI ASC/ASCQ, envisagez de les faire remonter au fournisseur de la bibliothèque pour examen.

Library Load : Opération logique

Une fois que nous avons établi que les opérations physiques sont exemptes d’erreurs (au moins superficiellement), nous pouvons tenter de retracer le problème dans NetWorker.

  • Déterminez la disposition de la bibliothèque et assurez-vous qu’elle est prête, en comparant les informations d’état du NSR Jukebox aux informations de la cartouche de bande du robot :
nsrjb [<-j library_name>] -C
sjirdtag <changer address>
  • Essayez de charger une bande concernée dans un lecteur concerné avec un niveau de commentaires élevé :
nsrjb [<-j library_name>] -lvvvvv -f <device_handle> -S <slot_number>

Si la bibliothèque se charge à plusieurs reprises sans problème, le problème de charge peut résulter de facteurs situationnels spécifiques plutôt que d’une panne persistante. Tous les efforts doivent être faits pour isoler la condition qui conduit à la défaillance de la charge, et le débogage de la condition doit suivre (voir ci-dessous).

  • Si les opérations de chargement habituelles échouent, en particulier si les volumes sont marqués comme « sans libellé », la lecture de l’étiquette a échoué pendant la tentative de chargement (ce qui entraîne l’échec du montage ). Essayez de recharger la même bande dans le même lecteur avec des commentaires élevés, sans monter :
nsrjb [<-j library_name>] -lnvvvvv -f <device_handle> -S <slot_number>
  • Effectuez une vérification autonome de l’étiquette pour voir si l’échec de lecture de l’étiquette était transitoire ou s’il est cohérent :
nsrmm -pvvvvv -f <device_handle>
  • Si l’étiquette est lue avec succès, le problème peut se résoudre si des tentatives de lecture d’étiquettes ont lieu avant que le lecteur de bande ne soit prêt après son chargement physique. Dans ce cas, vous pouvez essayer de définir la variable dans l’environnement système ou le script de démarrage :
MAX_LOAD_RETRIES=10

Si l’opération de chargement semble toujours échouer lors d’une opération de chargement/montage composée (lecture d’étiquette) après avoir défini la variable, accédez à la section Débogage.

    Library Load : Débogage

    Si tout le reste échoue, collectez les données appropriées pour aider à déboguer le problème avant de consulter des experts spécialisés (SME) :

    • Avant de reproduire le problème dans NetWorker, modifiez le niveau de suivi de débogage sur 5 dans la ressource NSR Jukebox
    • Utilisez également dbgcommand afin d’augmenter le niveau de débogage de l’application nsrd et nsrmmgd processus à 5
    • Considérer truss/tusc/strace, pstack, gcore/gencore sur le compte approprié nsrlcpd Avant et pendant l’événement problématique
    • Définissez les variables de débogage dans l’environnement système (Windows) ou le script de démarrage (UNIX) afin d’obtenir des données de débogage plus riches :
    SJI_DEBUG=9
    LUS_DEBUG=9
    CDI_DEBUG=9
    SCSI_DEBUG=9
    JBDEBUG=9

     

    ATTENTION : la journalisation du débogage peut être excessive à moins que le problème ne soit reproduit rapidement après le démarrage. Les services s’arrêtent afin de supprimer les variables d’environnement du jeu.

    Si aucune des suggestions ci-dessus ne vous aide, contactez le support de votre fournisseur de bibliothèque si les preuves recueillies lors du débogage suggèrent des anomalies internes, comme indiqué dans les sections Troubleshooting Tape Library Detection Problems in NetWorkeret Troubleshooting Tape Library Access Problems in NetWorker; Sinon, assurez-vous que la sortie de débogage est escaladée au sein du support NetWorker pour poursuivre la possibilité d’un défaut de code.

    Informations supplémentaires

    kA2j0000000R37vCAC_4_0
    Cet article fait partie d’une série de la section Dépannage des bibliothèques de bandes avec NetWorker.

    Produits concernés

    NetWorker

    Produits

    NetWorker Series
    Propriétés de l’article
    Numéro d’article: 000079463
    Type d’article: Solution
    Dernière modification: 30 Mar 2026
    Version:  4
    Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
    Services de support
    Vérifiez si votre appareil est couvert par les services de support.