PowerEdge:在 SRM UI 中新增陣列配對時發生 SRDF SRA 錯誤,無法連線至陣列管理主機

Résumé: SRA 命令「discoverArrays」失敗。無法連線至陣列管理主機。請查看 EmcSrdfSra 記錄,以取得錯誤的詳細資訊。

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

在 SRM UI 中使用 SRDF 複寫配接卡 (SRA) 新增陣列配對時,收到錯誤:

"SRA command ‘discoverArrays’ failed. Failed to connect to the array management host. Please check EmcSrdfSra logs for more information on the error."


儆 

出現此問題的安裝程式的其他資訊:
vCenter 版本:6.7
SRM 版本:8.1
SRA 版本:9.2.0
SE 版本:安裝在 SRM
SYMAPI 伺服器上的 9.2.1 用戶端:具備 SE 9.2.1 的嵌入式管理陣列

Cause

可使用 symapi 由於以下錯誤,無法從 SRM 用戶端初始化工作階段至 SYMAPI 伺服器:

"The trusted host file disallowed a client server connection"



這代表 SYMAPI 伺服器的「nethost檔案設定不正確或完全未設定。受信任的主機檔也稱為”nethost“的檔。

在 EmcSrdfSra.log 中找到錯誤:

[07/26 09:50:59.104  8768   155 SymapiSession::Init             ] [ERROR]: Failed to perform SymInit(). 
[ERROR]: [SYMAPI_C_HOST_FILE_REJECTION : The trusted host file disallowed a client server connection]
.
[07/26 09:50:59.104  8768    33 SymapiSession::SymapiSession    ] [ERROR]: Failed to initialize Symapi session


在 SYMAPI 伺服器的storsrvd.log中找到錯誤:

<Error> [7564             SESS 0125] Jul-25 14:09:46.372 : ANR0018E Rejecting session 125 for dell_user@dellemc123.abc.def.com (::ffff:111.222.333.444): The trusted host file disallowed a client server connection


從 SRM 用戶端到 SYMAPI 伺服器的工作階段因使用者身分遭拒 dell_user 和/或主機 FQDN dellemc123.abc.def.com 無權存取 SYMAPI 伺服器。存取權應透過以下方式提供: nethost 檔。當 SYMAPI 伺服器為虛擬裝置或嵌入式管理時,大多會發生此錯誤。

Résolution

檢閱記錄並確認此問題,然後繼續執行下列解決方案:
新增/設定 nethost 檔案,其中包含主機 FQDN/IP 和使用者,格式如下:

<Host FDQN> <user>
<IP> <user>


例如:

dellemc123.abc.def.com dell_user
111.222.333.444 dell_user

Produits concernés

SRDF Adapter for VMware Site Recovery Manager, VMware vCenter Site Recovery Manager
Propriétés de l’article
Numéro d’article: 000190090
Type d’article: Solution
Dernière modification: 22 avr. 2025
Version:  3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.