NVP-vProxy : Erreurs de connexion continues à partir de vProxy
Résumé: Le compte vCenter Server utilisé par NetWorker est verrouillé en permanence. Le problème est suivi jusqu’aux tentatives de connexion à partir d’une appliance vProxy NetWorker VMware Protection (NVP). ...
Symptômes
Des erreurs de connexion continues d’un vProxy à un vCenter sont visibles dans le /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-engine.log Lorsque le débogage est activé. L’erreur se produit toutes les 5 minutes.
NetWorker VMware Protection-vProxy : Activation de la journalisation de débogage
2024-07-18T14:02:54Z INFO: Request #83: Deleted resource: vCenter.com:vm-xxxxxx - xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx. 2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: establish connection 2024-07-18T14:02:54Z DEBUG: backupEngine Consumer: get channel 0 2024-07-18T14:02:54Z TRACE: Request #83: Reply sent successfully for 'DeleteSession'. 2024-07-18T14:02:54Z TRACE: Purged 0 aged files in '/opt/emc/vproxy/runtime/logs/recycle/daemon'. 2024-07-18T14:02:56Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 2024-07-18T14:06:18Z DEBUG: Session keepalive on vCenter 'vCenter.com' 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sending 1 requests to scrubber ... 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Sent requests to scrubber. 2024-07-18T14:07:52Z DEBUG: CleanupMgr: vCenter.com: Scrubber: Received 1 requests to scrub. 2024-07-18T14:07:52Z TRACE: CleanupMgr: vCenter.com: Scrubber: Logging into vCenter 'vCenter.com' 2024-07-18T14:07:55Z ERROR: CleanupMgr: vCenter.com: Scrubber: Unable to log in to vCenter 'vCenter.com': ServerFaultCode: Cannot complete login due to an incorrect user name or password. 2024-07-18T14:11:18Z DEBUG: Session keepalive on vCenter 'vCenter.com'
Cause
Le vProxy InventorySessions.gob sont utilisés pour stocker les informations de session pour le serveur NetWorker nsrvisd . La commande .gob suggère que ces fichiers sont au format Go Binary qui peut contenir des informations de session liées à la gestion de l’inventaire. Dans certains cas, ce fichier peut ne pas avoir été nettoyé et mettre en cache des informations obsolètes sur les informations d’identification de vCenter. Dans certains cas, l’option InventorySessions.gob La suppression du fichier peut échouer lors du nettoyage, entraînant l’échec des tentatives de connexion.
Résolution
Renommage du dossier /data01/runtime/state/vbackupd/ ou en supprimant le dossier .gob file est la solution de contournement suggérée.
1. Ouvrez une session SSH sur l’appliance vProxy et connectez-vous en tant qu’administrateur.
2. Une fois connecté, passez à l’utilisateur root :
sudo su -
3. Arrêtez le vbackupd du serveur NMC :
systemctl stop vbackupd
4. Renommez le fichier binaire /data01/runtime/state/vbackupd/ Répertoire:
mv /data01/runtime/state/vbackupd/ /data01/runtime/state/vbackupd_`date -I`.bak
5. Rechargez les processus vProxy :
systemctl daemon-reload
6. Commencer vbackupd:
systemctl start vbackupd
Un nouveau /data01/runtime/state/vbackupd/ Le répertoire est créé.
Informations supplémentaires
NVP vProxy : Comment mettre à niveau l’appliance NVP vProxy à l’aide de nsrvproxy_mgmt.