NetWorker: unable to create client in NMC "unable to determine the name of address 'null'"

Résumé: Unable to create a client using the New Client Wizard in NMC.

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Symptômes

The following message appears while trying to create a new client in the NetWorker Management Console (NMC):

Connecting to host client_name failed:
The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.

Cause

nsrexecd_nsrfa provides Remote File Access functionality used by the NetWorker server when it needs to communicate with a client for operations involving files and metadata retrieval across RPC.

Unable to create the channel for the Remote file access using nsrexecd service.

Possible reasons:

  • Wrong DNS/reverse lookup
  • Client's nsrexecd service is not running
  • Port-range mismatch

Also if the servers file in the res have wrong entry:

  • Corrupted,
  • Contains an old server name,
  • Contains duplicate entries,
  • Has wrong hostname/DNS entries in the servers file.
  • The servers file format is damaged

Résolution

To troubleshoot this error, the following checks and actions should be performed:
 

  1. Verify Name Resolution and Communication
    1. Ensure that name resolution works correctly in both directions:  Server → Client and Client → Server using `nslookup`, and confirm that each hostname resolves properly
    2.  Validate Required Ports: Confirm that mandatory NetWorker service ports 7937 and 7938 are accessible between the server and client.  

From both the NetWorker server and NetWorker client use the nsrports command to validate name resolution and port 7937 and 7938 communication:

nsrports -t HOSTNAME -p PORT

Example output:

[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937
Forward lookup for rhel-client01.amer.lan
Query time:              0.001 sec
Canonical name (CNAME):  rhel-client01.amer.lan
Address (A):             192.168.9.121
Connect to port 7937:    Succeeded (0.001 sec)

Reverse lookup for 192.168.9.121
Query time:              0.001 sec
Name:                    rhel-client01.amer.lan

For more information, see: NetWorker: How to use the nsrports command

WARNING: Any name resolution or port connection failures must be resolved by the system administrator or network security team.

 

  1. Validate that the NetWorker server can see nsrexecd_nsrfa on the NetWorker client:
nsrrpcinfo -p CLIENT_NAME
Example:
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan
PROGRAM VERSION PROTOCOL PORT SERVICE
100000  2       tcp      7938 nsrportmapper  Port Mapper
100000  2       udp      7938 nsrportmapper  Port Mapper
390436  1       tcp      8359 nsrexecd       GSS Authentication
390435  1       tcp      9613 nsrexecd       Resource Mirror
390113  1       tcp      7937 nsrexecd       Remote Execution
390440  1       tcp      8942 nsrexecd_nsrfa Remote File Access
NOTE: If nsrexecd and nsrexecd_nsrfa are listed, it means the NetWorker server can see these processes and ports on the client, go to step four. If the server cannot see these processes, go to step three.
  1. If the server cannot see nsrexecd or nsrexecd_nsrfa on the client, perform the following actions on the client system:
    1. Validate that the client service is running:
  • Linux: ps -ef | grep nsr
  • Windows: sc query nsrexecd
  1. If the client is not running, attempt to start services:
  • Linux: systemctl start networker
  • Windows: net start nsrexecd
Monitor the daemon.raw for errors in case the service fails to start:
  1. If the client services are running, check if the nsrexecd_nsrfa is running.
  • If the client has the "extended client" software installed, you can check with nsrrpcinfo -p localhost. This command should show both nsrexecd and nsrexecd_nsrfa running. The nsrrpcinfo command is not available on systems that only have the standard client package installed.
  • If the client does not have the extended client software installed, you will only see nsrexecd running with OS commands, you will not see nsrexecd_nsrfa. You must validate from the NetWorker server if you can see nsrexecd_nsrfa listening on the client (see step 2).
    1. Check the NetWorker port range used on the client using the nsrports command. The default port range is 7937-9936. See: NetWorker: How to Use "nsrports -S" to Change the NetWorker Service Port Range

 

  1. Check if the client has a "servers" file in its "res" folder:
    • Linux: /nsr/res
    • Windows (Default): C:\Program Files\EMC NetWorker\nsr\res
NOTE: The servers file acts as an "access policy"; meaning: "only NetWorker servers defined in this file are allowed to back me up."
    1. If a servers file exists, one of the following must be trued:
    • It should either be empty (all servers allowed)
    • If servers are defined in the file, the NetWorker server you tried to add this client from must be defined in the file.
    1. If there are no obvious issues with the file, it may have become corrupted. Rename the file and restart services:
    • Linux: systemctl restart networker
    • Windows: net stop nsrexecd && net start nsrexecd

After performing all the above validation steps, attempt to add the client to the NetWorker server.

Informations supplémentaires

Produits concernés

NetWorker
Propriétés de l’article
Numéro d’article: 000437991
Type d’article: Solution
Dernière modification: 14 mars 2026
Version:  1
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