NetWorker: unable to create client in NMC "unable to determine the name of address 'null'"
Résumé: Unable to create a client using the New Client Wizard in NMC.
Symptômes
The following message appears while trying to create a new client in the NetWorker Management Console (NMC):
Connecting to host client_name failed: The host reports: Unable to create a session channel with nsrexecd on host client_name to execute the command ‘nsrfsra’: Unable to determine the name of address ‘null’ — Hostname.
Cause
nsrexecd_nsrfa provides Remote File Access functionality used by the NetWorker server when it needs to communicate with a client for operations involving files and metadata retrieval across RPC.
Unable to create the channel for the Remote file access using nsrexecd service.
Possible reasons:
- Wrong DNS/reverse lookup
- Client's nsrexecd service is not running
- Port-range mismatch
Also if the servers file in the res have wrong entry:
- Corrupted,
- Contains an old server name,
- Contains duplicate entries,
- Has wrong hostname/DNS entries in the servers file.
- The servers file format is damaged
Résolution
To troubleshoot this error, the following checks and actions should be performed:
- Verify Name Resolution and Communication
- Ensure that name resolution works correctly in both directions: Server → Client and Client → Server using `
nslookup`, and confirm that each hostname resolves properly - Validate Required Ports: Confirm that mandatory NetWorker service ports 7937 and 7938 are accessible between the server and client.
- Ensure that name resolution works correctly in both directions: Server → Client and Client → Server using `
From both the NetWorker server and NetWorker client use the nsrports command to validate name resolution and port 7937 and 7938 communication:
nsrports -t HOSTNAME -p PORT
Example output:
[root@nsr ~]# nsrports -t rhel-client01.amer.lan -p 7937 Forward lookup for rhel-client01.amer.lan Query time: 0.001 sec Canonical name (CNAME): rhel-client01.amer.lan Address (A): 192.168.9.121 Connect to port 7937: Succeeded (0.001 sec) Reverse lookup for 192.168.9.121 Query time: 0.001 sec Name: rhel-client01.amer.lan
For more information, see: NetWorker: How to use the nsrports command
- Validate that the NetWorker server can see
nsrexecd_nsrfaon the NetWorker client:
nsrrpcinfo -p CLIENT_NAME
[root@nsr ~]# nsrrpcinfo -p rhel-client01.amer.lan PROGRAM VERSION PROTOCOL PORT SERVICE 100000 2 tcp 7938 nsrportmapper Port Mapper 100000 2 udp 7938 nsrportmapper Port Mapper 390436 1 tcp 8359 nsrexecd GSS Authentication 390435 1 tcp 9613 nsrexecd Resource Mirror 390113 1 tcp 7937 nsrexecd Remote Execution 390440 1 tcp 8942 nsrexecd_nsrfa Remote File Access
- If the server cannot see nsrexecd or nsrexecd_nsrfa on the client, perform the following actions on the client system:
- Validate that the client service is running:
- Linux:
ps -ef | grep nsr - Windows:
sc query nsrexecd
- If the client is not running, attempt to start services:
- Linux:
systemctl start networker - Windows:
net start nsrexecd
daemon.raw for errors in case the service fails to start:
- Linux:
/nsr/logs/daemon.raw - Windows (default):
C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw - NetWorker: How to use nsr_render_log to render .raw log files
- If the client services are running, check if the
nsrexecd_nsrfais running.
- If the client has the "extended client" software installed, you can check with
nsrrpcinfo -p localhost. This command should show bothnsrexecdandnsrexecd_nsrfarunning. Thensrrpcinfocommand is not available on systems that only have the standard client package installed. - If the client does not have the extended client software installed, you will only see
nsrexecdrunning with OS commands, you will not seensrexecd_nsrfa. You must validate from the NetWorker server if you can seensrexecd_nsrfalistening on the client (see step 2).
-
- Check the NetWorker port range used on the client using the
nsrportscommand. The default port range is 7937-9936. See: NetWorker: How to Use "nsrports -S" to Change the NetWorker Service Port Range
- Check the NetWorker port range used on the client using the
- Check if the client has a "servers" file in its "res" folder:
-
- Linux:
/nsr/res - Windows (Default):
C:\Program Files\EMC NetWorker\nsr\res
- Linux:
-
- If a servers file exists, one of the following must be trued:
-
- It should either be empty (all servers allowed)
- If servers are defined in the file, the NetWorker server you tried to add this client from must be defined in the file.
-
- If there are no obvious issues with the file, it may have become corrupted. Rename the file and restart services:
-
- Linux:
systemctl restart networker - Windows:
net stop nsrexecd && net start nsrexecd
- Linux:
After performing all the above validation steps, attempt to add the client to the NetWorker server.