Passer au contenu principal
  • Passer des commandes rapidement et facilement
  • Afficher les commandes et suivre l’état de votre expédition
  • Profitez de récompenses et de remises réservées aux membres
  • Créez et accédez à une liste de vos produits
  • Gérer vos sites, vos produits et vos contacts au niveau des produits Dell EMC à l’aide de la rubrique Gestion des informations de l’entreprise.
Certains numéros d’article ont peut-être changé. Si ce n’est pas ce que vous recherchez, essayez de faire une recherche sur tous les articles. Rechercher des articles

Resolving High Hard Disk Drive and CPU Usage During Scans by Windows Defender

Résumé: The following article deals with resolving an issue where the computer locks up. Because the Windows Defender scan forces up to 100% usage of the computer's Hard Disk Drive (hard drive) and Central Processing Unit (CPU). ...

Cet article a peut-être été traduit automatiquement. Si vous avez des commentaires concernant sa qualité, veuillez nous en informer en utilisant le formulaire au bas de cette page.

Contenu de l’article


Symptômes

Cause

Is your computer locking up during Windows Defender scans?

 

Does your computer lock up during Windows Defender Scans?

When you check the system performance on an application such as the Process Explorer, is MsMpEng.exe showing excessive usage of the computers resources?

Does this take from 80% to 100% of the computers resources, causing the computer to grind to a slow crawl or lock up?

If any of the above statements are true, then you should read through the following section of this article.

Résolution

Why is this happening?

 

The following sections are the methods that Microsoft recommends stopping the MxMpEng.exe file from causing high hard drive and CPU usage on your computer.

  • MsMpEng.exe is the core process of the Windows Defender Anti-malware Application.
  • Windows Defender comes pre-installed on Windows 11 and Windows 10 but is an optional download on older Operating Systems like Windows 7 and 8.
  • This issue with MsMpEng.exe taking 100% of the hard drive and CPU usually occurs when Windows Defender is scanning the computer for malware. The Windows Defender scan is getting stuck on a few files while checking malware. When that is happening, it should be restricted/disabled to bring it back to normal use.


Back to Top


 

Method I: Ensure that no other Adware, Anti-malware, or anti-virus software is installed or not fully removed

 

MsMpEng.exe - Its role is to scan files for spyware, and quarantine or remove them if they are suspicious. It also scans your computer for known worms, harmful software, viruses, and other such programs.

Note: Best practice is to have only ONE anti-malware, anti-virus, or anti-spyware program on your computer at one time. Do Not have multiple programs running or installed simultaneously. These programs conflict and find each other as files to be quarantined and deleted.
 

Windows Defender comes default installed with Windows 11 and Windows 10.

That means that any additional software is installed after Windows Defender - Windows defender keeps them from installing or running correctly.

  1. Right-click the Start Icon and choose Control Panel from the menu.

  2. Go to Programs and Features and remove any of these types of programs that are listed there.

Windows Defender does not come installed with Windows 8 and Windows 7.

After installing Windows Defender, Windows defender keeps any new software from installing or running correctly.

If Windows Defender was installed after these other types of software - these software programs keep Windows Defender from installing correctly.

  1. Open the Control Panel from the Start menu.

  2. Go to Programs and Features and remove any of these types of programs that are listed there, including Windows Defender.

  3. Install the program that you want to use going forward.


Back to Top


 

Method II: Prevent Windows Defender from scanning a specific folder on your computer

 

One reason for the high load is the MsMpEng.exe file scanning its folder. If you have a known folder on your computer that is causing Windows Defender an issue, you can get Windows Defender to ignore it.

 
  1. Click the Start Icon and type Windows Defender. Double-click the icon when it appears in the search list.

  2. Click Settings and select Add an exclusion from the bottom of the window.

  3. Choose Exclude a folder and enter the path of the wanted directory. In this case: C:\program files\windows defender

msmpeng exclusion windows defender

(Figure.1 Add an Exclusion Settings Window)

  1. Open the Windows Defender utility. Open the Tools and Advanced Options sections.

  2. Open Excluded Files and Locations.

  3. Enter the path of the wanted directory. In this case: C:\program files\windows defender


Back to Top


 

Method III: Slow the scan by lowering the set affinity of Windows Defender on your computer

 

You can set the MsMpEng.exe file to use a specific processor in the computer to avoid high CPU usage. However, it cuts the scan speed of Windows defender and the fan runs slower than usual. Is slow scan speed better for you than having high CPU usage? Apply the following steps to set the affinity in limited mode.

 
  1. Open Task Manager:

    • Right-click the taskbar and select Task Manager.

    • Right-click the Start Icon, select Task Manager.

    • Click the Start Icon and type Task Manager, click the task manager icon from results.

  2. Go to the Details tab.

  3. Right-click the process name msmpeng.exe and select Set affinity.

msmpeng affinities task-manager

(Figure.2 Set Affinity in Task Manager Window)

  1. Choose the CPU limit that you allow the process to use.

  1. Open Task Manager:

    • Right-click the taskbar and select Task Manager.

    • Ctrl/Alt/Del pressed together gives an on-screen menu, select Task Manager.

    • Search for Task Manager, click the icon from the results.

  2. Go to the Processes tab.

  3. Right-click the process msmpeng.exe and select Set affinity.

  4. Choose which cores of the CPU that you allow the process to use.

Note: For normal CPU usage, select 50% for MsMpEng.exe (That is one core of a dual-core CPU, two cores of a quad-core CPU, and so on.)


Back to Top


 

Method IV: Disabling Windows Defender through group policies on your computer

 

Disabling Windows Defender is a severe answer that solves your issue that is related to high CPU usage.

Note: Your computers protection suffers without any anti-virus software installed. If you disable Windows Defender, ensure you have another Anti-malware application to install in its place. This can be either free or paid, but ensure you have something that is installed in Windows Defenders place.
  1. Open a Run Window and type gpedit.msc:

    • Press the Windows and R key together.

    • Open the start menu and select Run.

  2. This opens the Group Policy Editor. (This is only available on Pro and Enterprise editions. There are ways to install it on Home editions, but this article does not cover them.)

msmpeng group-policy windows defender

(Figure.3 The Group Policy Editor)

  1. Scroll down the left-hand side tree structure until you get to Computer Configuration. Open it and go to Administrative Templates, then Windows Components. Look for Windows Defender anti-virus.

  2. In the right-hand side pane, double-click Turn off Windows Defender anti-virus.

  3. A Properties window opens, choose Enabled and click Apply and OK to save the change, then close all the windows.


Back to Top

Propriétés de l’article


Dernière date de publication

24 nov. 2023

Version

5

Type d’article

Solution