NetWorker : Comment utiliser nsrclientfix, erreur « Impossible de trouver l’attribut 'client id' »
Résumé: Utiliser nsrclientfix pour identifier et résoudre les problèmes d’ID client sur un NetWorker Server.
Symptômes
La commande nsrclientfix est utilisée pour analyser la base de données des supports afin de rechercher la corruption de l’ID client.
Il peut également fusionner des clients dans la base de données des ressources et dans la base de données des supports.
98519:save: Unable to setup direct save with server <nw_server>: Cannot find attribute 'client id'..
90018:save: Cannot open a save session with NetWorker server '<nw_server>': Cannot find attribute 'client id'.
<nw_client>:/etc: retried 2 times.
Cause
- Cause générale : un client s’identifie auprès de la base de données des supports lors d’une sauvegarde sous la forme d’un nom que le serveur NetWorker ne réalise pas être un alias.
- Cela peut également être dû à la création d’une ressource client avec un nom différent du nom choisi (nom du client) pour représenter le client.
- Un mauvais aliasing dans le fichier hosts du système peut provoquer ce type de problème. Des corrections doivent être apportées au fichier d’hôtes avant d’entreprendre d’autres actions.
Résolution
Configuration requise
Procédez comme suit avant de modifier les index des fichiers client NetWorker.1. Effectuez une « sauvegarde de protection du serveur » pour sauvegarder les index existants, la base de données des supports (mm) et la base de données de ressources NetWorker (nsrdb)
Collectez les informations du saveset de bootstrap à l’aide de : mminfo -B
2. Arrêtez les processus NetWorker sur le serveur NetWorker :
Windows : net stop nsrexecd /y
Windows :tasklist | findstr nsr
4. En plus de la sauvegarde de protection du serveur, des copies des dossiers mm et nsrdb peuvent être effectuées sur le serveur NetWorker.
B. nsrdb : Linux : /nsr/res/nsrdb Windows : .\Program Files\EMC NetWorker\nsr\res\nsrdb
D. En fonction de la taille de l’index et de l’espace disponible sur le serveur, l’index peut également être copié : Linux : /nsr/index Windows : .\Program Files\EMC NetWorker\nsr\index
Windows : net start nsrd
Exécuter le fichier
1. Identifiez les clients qui rencontrent des problèmes d’ID client. La commande suivante vérifie uniquement les problèmes éventuels, mais n’effectue aucune action corrective.
Syntaxe:
nsrclientfix -a - -p
Exemple:
nsrclientfix -a - -p
4. Passez en revue la liste des clients à fusionner.
Ouvrez le fichier texte créé à l’étape précédente et passez en revue chaque ligne :
nsrclientfix -ufile
Exemple:
Fusion des clients suivants dans 'alenka' : alenka.emc.com
Fusion de la base de données des ressources pour le client 'alenka'.
Fusion de la base de données des médias pour le client 'alenka'.
La fusion est terminée pour le client 'alenka'.
Purge « temporelle » du client.
Purge de la base de données des ressources du client « temporel ».
Purge de la base de données des supports du client « temporel ».
Suppression de toutes les sauvegardes d’index liées au client « temporal » dans la base de données des médias.
Purge réussie du client « temporel ».
Purge du client « localhost ».
Purge de la base de données des ressources du client « localhost ».
Purge de la base de données des supports du client « localhost ».
Suppression de toutes les sauvegardes d’index liées au client « localhost » dans la base de données des médias.
Le client « localhost » a été purgé avec succès.
Purge de l’alenka.emc.com client.
Purge de la base de données des ressources du client « alenka.emc.com ».
Purge de la base de données des supports du client « alenka.emc.com ».
Suppression de toutes les sauvegardes d’index liées au client « alenka.emc.com » dans la base de données des médias.
Purge réussie du client « alenka.emc.com ».