NetWorker : Comment utiliser nsrclientfix, erreur « Impossible de trouver l’attribut 'client id' »

Résumé: Utiliser nsrclientfix pour identifier et résoudre les problèmes d’ID client sur un NetWorker Server.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

La commande nsrclientfix est utilisée pour analyser la base de données des supports afin de rechercher la corruption de l’ID client.
Il peut également fusionner des clients dans la base de données des ressources et dans la base de données des supports.

Un ou plusieurs clients ont plusieurs ID client.
98519:save: Unable to setup direct save with server <nw_server>: Cannot find attribute 'client id'..
90018:save: Cannot open a save session with NetWorker server '<nw_server>': Cannot find attribute 'client id'.
<nw_client>:/etc: retried 2 times.

Cause

  • Cause générale : un client s’identifie auprès de la base de données des supports lors d’une sauvegarde sous la forme d’un nom que le serveur NetWorker ne réalise pas être un alias.
  • Cela peut également être dû à la création d’une ressource client avec un nom différent du nom choisi (nom du client) pour représenter le client.
  • Un mauvais aliasing dans le fichier hosts du système peut provoquer ce type de problème. Des corrections doivent être apportées au fichier d’hôtes avant d’entreprendre d’autres actions. 
 

Résolution

Configuration requise

Procédez comme suit avant de modifier les index des fichiers client NetWorker.

1. Effectuez une « sauvegarde de protection du serveur » pour sauvegarder les index existants, la base de données des supports (mm) et la base de données de ressources NetWorker (nsrdb)
 
Remarque : La commande nsrclientfix modifie à la fois les bases de données de support et de configuration. En cas de problème ou d’erreur, il est recommandé de disposer d’une sauvegarde des deux bases de données.

Collectez les informations du saveset de bootstrap à l’aide de : mminfo -B

2. Arrêtez les processus NetWorker sur le serveur NetWorker :
Linux : systemctl stop networker(or nsr_shutdown)
Windows : net stop nsrexecd /y
 
3. Confirmez que tous les processus NetWorker sont arrêtés :
Linux : ps -ef | grep nsr
Windows :tasklist | findstr nsr

4. En plus de la sauvegarde de protection du serveur, des copies des dossiers mm et nsrdb peuvent être effectuées sur le serveur NetWorker.
A. mm : Linux : /nsr/mm Windows : .\Program Files\EMC NetWorker\nsr\mm
B. nsrdb : Linux : /nsr/res/nsrdb Windows : .\Program Files\EMC NetWorker\nsr\res\nsrdb
C. nsrladb : Linux : /nsr/res/nsrladb Windows : .\Program Files\EMC NetWorker\nsr\res\nsrladb
D. En fonction de la taille de l’index et de l’espace disponible sur le serveur, l’index peut également être copié : Linux : /nsr/index Windows : .\Program Files\EMC NetWorker\nsr\index
 
5. Démarrez les services NetWorker :
Linux : systemctl start networker
Windows : net start nsrd 
 

Exécuter le fichier
 

1. Identifiez les clients qui rencontrent des problèmes d’ID client. La commande suivante vérifie uniquement les problèmes éventuels, mais n’effectue aucune action corrective. 


Syntaxe:
nsrclientfix -a - -p

Exemple:
nsrclientfix -a - -p
alenka, alenka.emc.com <-- Un ou plusieurs clients
temporal <: un client
localhost <-- Un client
 
La lecture et la sortie du fichier sont au même format. Le fichier se compose d’une liste de clients séparés par des virgules, séparés par des sauts de ligne. Le nombre de clients sur la ligne représente les actions effectuées.
 
3. Créez un fichier texte avec la liste des clients à corriger par nsrclientfix
 
Syntaxe :
nsrclientfix -afile-p
Cette commande n’effectue aucune action corrective. Il crée le fichier texte utilisé par nsrclientfix pour corriger les problèmes.
 
Exemple :
nsrclientfix -atext1-p
Alenka, alenka.emc.com
temporel
Hôte local

4. Passez en revue la liste des clients à fusionner.
Ouvrez le fichier texte créé à l’étape précédente et passez en revue chaque ligne :
 
Un seul client
Lorsqu’il n’y a qu’un seul client sur la ligne, cela signifie qu’il est marqué pour être purgé. Cela ne s’affiche pas lors de l’étape d’analyse, sauf si la balise -p est utilisée. Les clients sont généralement signalés pour purge (sur demande) lorsqu’un ancien client existe sans entrées de base de données de ressources ou de supports. Cela est dû soit à d’anciens clients mis hors service, soit à la fusion d’un client avec un autre.
 
Plusieurs clients
Plus d’un client signifie que les clients répertoriés doivent être fusionnés. Le premier nom de la liste est le nom principal dont le nom et l’ID client sont conservés (s’il existe déjà). Les noms suivants (noms secondaires) sont fusionnés avec le nom principal. Toutes les ressources client des noms secondaires sont renommées avec le nom principal, et les listes d’alias de tous les clients sont combinées. Les entrées de la base de données des supports auront également leurs ID client et leurs noms fusionnés dans le nom principal.
 
Remarque : Si les alias que vous souhaitez fusionner, par exemple « ancien nom » et « nouveau nom » n’apparaissent pas sur la même ligne, vous devez ajouter l'« ancien nom » en tant qu’alias NetWorker du « nouveau nom ». Par exemple : Ajoutez nwclientold ou nwclientdummy en tant qu’alias pour nwclient.
 
AVERTISSEMENT : Il est important de confirmer que tous les alias répertoriés sur la même ligne appartiennent au même hôte. S’il existe un alias appartenant à un hôte différent, nsrclientfix fusionne ses savesets avec le premier alias de la liste. Si les savesets doivent être divisés ultérieurement, cela nécessite une solution de contournement compliquée et fastidieuse (en bref, supprimez les savesets de la base de données des médias et analysez-les à nouveau).
.
5. Utilisez nsrclientfix avec le fichier texte pour corriger les problèmes d’ID client sur les clients répertoriés.
 
Syntaxe:
nsrclientfix -ufile

Exemple:
nsrclientfix -utext1

Fusion des clients suivants dans 'alenka' : alenka.emc.com

Fusion de la base de données des ressources pour le client 'alenka'.

Fusion de la base de données des médias pour le client 'alenka'.

La fusion est terminée pour le client 'alenka'.

Purge « temporelle » du client.

Purge de la base de données des ressources du client « temporel ».

Purge de la base de données des supports du client « temporel ».

Suppression de toutes les sauvegardes d’index liées au client « temporal » dans la base de données des médias.

Purge réussie du client « temporel ».

Purge du client « localhost ».

Purge de la base de données des ressources du client « localhost ».

Purge de la base de données des supports du client « localhost ».

Suppression de toutes les sauvegardes d’index liées au client « localhost » dans la base de données des médias.

Le client « localhost » a été purgé avec succès.

Remarque : Les clients fusionnés ne seront pas supprimés. La commande nsrclientfix doit s’exécuter à nouveau pour supprimer les alias qui ont été fusionnés et non supprimés.
 
6. Purger les clients qui ont été fusionnés précédemment et qui n’ont désormais aucun saveset associé.
Les clients fusionnés n’ont pas été supprimés. Pour les supprimer, nsrclientfix doit être exécuté à nouveau :
 
nsrclientfix -atext2-p
alenka.emc.com
 
nsrclientfix -u text2

Purge de l’alenka.emc.com client.

Purge de la base de données des ressources du client « alenka.emc.com ».

Purge de la base de données des supports du client « alenka.emc.com ».

Suppression de toutes les sauvegardes d’index liées au client « alenka.emc.com » dans la base de données des médias.

Purge réussie du client « alenka.emc.com ».

Informations supplémentaires

Pour la page man nsrclientfix, reportez-vous à la pièce jointe « nsrclientfix man page.pdf »

Produits concernés

NetWorker

Produits

NetWorker
Propriétés de l’article
Numéro d’article: 000015252
Type d’article: Solution
Dernière modification: 14 janv. 2026
Version:  5
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