PowerStore : Le contrôle d’intégrité préalable à la mise à niveau détecte les réservations SCSI3 existantes

Résumé: Le bilan de santé préalable à la mise à niveau (PUHC) PowerStore vérifie le système à la recherche de réservations SCSI3 existantes.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Le bilan de santé préalable à la mise à niveau (PUHC) vérifie le système à la recherche de réservations SCSI3 existantes.

Cette vérification PUHC doit réussir après une mise à niveau sans perturbation (NDU) à partir de PowerStoreOS 3.5 ou version ultérieure et après la mise à niveau sans perturbation vers des versions antérieures à 4.0.0.0.

Lorsque cette vérification échoue, c’est-à-dire lorsqu’il existe des réservations SCSI3 lors de la tentative d’une mise à niveau sans perturbation à partir des versions 3.0.x ou 3.2.x à 4.0.x, il doit être au niveau « Avertissement » et ne pas bloquer la mise à niveau sans perturbation.

Exemple de vérification PUHC détectant ce problème :

off_release_scsi3_reservation_check

Ce bilan de santé est inclus dans le package de bilan de santé téléchargé à partir du site Pilotes et téléchargements de Dell.

Cause

Lors de la mise à niveau sans perturbation de PowerStoreOS versions 3.0.x ou 3.2.x vers 4.0.x, si des réservations SCSI (Small Computer System Interface) (SCSI-2, SCSI-3, etc.) sont en attente ou émises, le flux de mise à niveau peut échouer et entraîner une indisponibilité des données sur le cluster concerné. 

Résolution

Ce problème est résolu dans PowerStoreOS version 4.1.0.1 

Les mises à niveau de PowerStoreOS version 3.x vers 4.1.0.1+ ne rencontreront pas ce problème. 

 

Le problème détecté par ce PUHC est résolu avec PowerStoreOS version 4.0.1.3 et 4.1.0 (ou ultérieure).

Solution de contournement :

Si le niveau de code cible d’une mise à niveau en attente est inférieur à la version 4.1.0.1, procédez comme suit :

Demandez au client d’effectuer les deux actions suivantes :

  1. Planifiez une fenêtre de maintenance pour la mise à niveau sans perturbation afin de minimiser le risque de nouvelles réservations pendant la mise à niveau sans perturbation. 
  2. Effectuez une mise à niveau en deux étapes à partir de PowerStoreOS version 3.0.x, ou des versions 3.2.x à 4.0.x en procédant d’abord à la mise à niveau vers la dernière version 3.6.x.

Informations supplémentaires

Produits concernés

PowerStore
Propriétés de l’article
Numéro d’article: 000233544
Type d’article: Solution
Dernière modification: 02 sept. 2025
Version:  5
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