NVP vProxy: I backup di SQL VM (MSVMAPPAGENT) Esito negativo con "Error received from vProxy"-400: Nella richiesta manca il nome utente della VM. ""
Résumé: Un backup di macchine virtuali (VM) Microsoft SQL eseguito utilizzando l'appliance vProxy NetWorker VMware Protection (NVP) ha esito negativo. Il log delle azioni di backup di NetWorker mostra "Error received from vProxy ="-400: Alla richiesta manca il nome utente della VM." ". ...
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
- Un backup di Microsoft SQL Server viene configurato utilizzando l'appliance vProxy NetWorker VMware Protection (NVP).
- L'azione di backup della policy di protezione è configurata con l'opzione "Application Consistency" abilitata per eseguire backup coerenti con le app SQL (MSVMAPPAGENT).
- Il backup ha esito negativo con il seguente errore segnalato nei log delle azioni di backup:
- Il vProxy
/opt/emc/vproxy/runtime/logs/vbackup/vbackupd-engine.logMostra messaggi di errore simili:
vproxy02:~ # tail -n 15 /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-engine.log
YYYY-MM-DDTHH:mm:SSZ NOTICE: f07a24dd-e7c3-48e5-8f89-3053c3249a65:vm-1013:win-sql02: Backup session is exiting
YYYY-MM-DDTHH:mm:SSZ TRACE: Resource Update f07a24dd-e7c3-48e5-8f89-3053c3249a65:externalId=vcsa.amer.lan:vm-1013:state=Success:deletable=true:updatable=true.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4881: Handling action 'GetLog' for 'f07a24dd-e7c3-48e5-8f89-3053c3249a65' ...
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4881: Reply sent successfully for 'GetLog'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Handling action 'DeleteSession' for 'f07a24dd-e7c3-48e5-8f89-3053c3249a65' ...
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleting logfiles of session 'f07a24dd-e7c3-48e5-8f89-3053c3249a65'...
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4882: Deleting log file '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log' of session 'f07a24dd-e7c3-48e5-8f89-3053c3249a65'...
YYYY-MM-DDTHH:mm:SSZ INFO: File '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log' is moved to '/opt/emc/vproxy/runtime/logs/recycle/vbackupd/20240112_1/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleted log file '/opt/emc/vproxy/runtime/logs/vbackupd/BackupVmSessions-f07a24dd-e7c3-48e5-8f89-3053c3249a65.log'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4882: Deleted resource: vcsa.amer.lan:vm-1013 - f07a24dd-e7c3-48e5-8f89-3053c3249a65.
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4882: Reply sent successfully for 'DeleteSession'.
YYYY-MM-DDTHH:mm:SSZ INFO: Request #4884: Handling action 'StartSession' for 'BackupVmSessions' ...
YYYY-MM-DDTHH:mm:SSZ ERROR: Request #4884: Request is missing the VM user name.
YYYY-MM-DDTHH:mm:SSZ ERROR: Request #4884: Failed to create resource: -400: Request is missing the VM user name.
YYYY-MM-DDTHH:mm:SSZ TRACE: Request #4884: Reply sent successfully for 'StartSession'.
- I backup delle immagini della VM che non utilizzano "Application Consistency" vengono completati correttamente.
Cause
Nell'azione di backup nella policy di protezione di NetWorker manca l'accesso utente all'istanza SQL nelle impostazioni "Application Consistency".
Résolution
Aggiornare l'azione di backup in modo da includere un utente con diritti di System Administrator:

L'account utente specificato deve disporre dei diritti sysadmin. Questa operazione può essere confermata in SQL Server Management Studio (SSMS) sulla macchina virtuale SQL:

Informations supplémentaires
MSVMAPPAGENT I registri sono disponibili sulla macchina virtuale SQL in C:\Program Files\DPSAPPS\MSVMAPPAGENT\logs
Produits concernés
NetWorkerProduits
NetWorker Family, NetWorker SeriesPropriétés de l’article
Numéro d’article: 000221097
Type d’article: Solution
Dernière modification: 30 Dec 2025
Version: 4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.