Isilon : La liste des services LWSM ne répond pas

Résumé: Comment répertorier la liste de services LWSM lorsque le client ne répond pas

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

L’absence de base.uzip peut également entraîner des problèmes de démarrage d’autres services tels que les services webui et les services httpd, ce qui affectera l’accès à l’interface graphique sur le nœud concerné.

  • Lorsque le service LWSM rencontre des problèmes, il génère les erreurs suivantes comme ci-dessous lorsque nous utilisons une commande comme celle-ci : -

    /usr/likewise/bin/lwsm list
    Error: ERROR_FILE_NOT_FOUND (2)

 

  • Lors de la vérification de l’état JWT :

/usr/likewise/bin/lwsm status jwt

LW_ERROR_STRING_CONV_FAILED
Failed to convert string format (wide/ansi)

 

  • Ou lorsque nous essayons de démarrer le service à l’aide de la commande ci-dessous 

    /usr/likewise/sbin/lwsmd --syslog --start-as-daemon
    Error: ERROR_GEN_FAILURE (31)
     
Isilon-1# isi auth ads list
		Unable to connect to authentication daemon: ERROR_FILE_NOT_FOUND

 

Isilon-1# /usr/likewise/bin/lwio list
		zsh: no such file or directory: /usr/likewise/bin/lwio



Lorsque nous listons le fichier /base.uzip, nous verrons sur l’un des nœuds /fichier base est manquant 

Isilon-1# isi_for_array -s 'ls -lh /base.uzip'
Isilon-1: ls: /base.uzip: No such file or directory
Isilon-2: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip
Isilon-3: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip

Cause

Cela peut se produire en raison du fait que la partition racine est pleine et peut afficher une sortie similaire à celle ci-dessous si nous exécutons la commande df -h :-

Isilon-1# df -h
Filesystem               Size    Used   Avail Capacity  Mounted on
/dev/mirror/root0        1.9G    1.8G   -126M   107%    /
devfs                    1.0K    1.0K      0B   100%    /dev
/dev/mirror/var0         956M    147M    732M    17%    /var
/dev/mirror/var-crash    2.8G    1.7M    2.6G     0%    /var/crash
/dev/mirror/keystore      60M    4.0K     55M     0%    /keystore
/dev/md0                  60M    1.2M     54M     2%    /tmp/ufp
/dev/md1                 3.5M    422K    2.8M    13%    /tmp/ipmi
OneFS                    130T    3.7T    119T     3%    /ifs

 Assurez-vous donc qu’aucune autre donnée n’est en cours d’écriture sur la partition racine. Seul /ifs doit être utilisé pour les données client.

Résolution

Vérifiez quel nœud a le fichier /base.uzip manquant :

Isilon-1# isi_for_array -s 'ls -lh /base.uzip'
Isilon-1: ls: /base.uzip: No such file or directory
Isilon-2: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip
Isilon-3: -rwxr-xr-x 1 root  wheel    27M Aug  2  2018 /base.uzip

Copiez le fichier base.uzip du bon nœud contenant le fichier ubase.uzip vers le mauvais nœud, puis redémarrez le nœud.

Exemple:

1. Copiez base.uzip à partir d’un nœud existant vers un répertoire global comme Isilon_Support :

isi_for_array -n2 'cp /base.uzip /ifs/data/Isilon_Support/'

 

2. Copiez le fichier base.uzip du répertoire de sauvegarde vers le nœud concerné :

 isi_for_array -n1 'cp /ifs/data/Isilon_Support/base.uzip /'

 

3. Vérifiez que la valeur de hachage md5 correspond à d’autres nœuds et vérifiez les autorisations :

isi_for_array -s 'ls -lh /base.uzip'

isi_for_array -s 'md5 /base.uzip'

REMARQUE : si les autorisations ne correspondent pas et doivent être ajustées, utilisez la commande ci-dessous sur le nœud concerné :

chmod 755 /base.uzip

  • Vérifiez que les autorisations correspondent :

isi_for_array -s 'ls -lh /base.uzip'

Informations supplémentaires

Assurez-vous qu’il y a suffisamment d’espace dans la partition racine lors de la copie du fichier, sinon vous pouvez rencontrer des erreurs comme celles suivantes

Isilon-1 : cp : fastcopy : write() failed : /base.uzip : Plus d’espace disponible sur l’appareil

Produits concernés

PowerScale OneFS
Propriétés de l’article
Numéro d’article: 000182108
Type d’article: Solution
Dernière modification: 08 May 2026
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.