Dell EMC Unity : le graphique des performances n’est pas disponible, car la partition /EMC/backend/metricsluna1 est pleine à 100 %
Résumé: Les utilisateurs ont constaté que le graphique des performances n’est pas disponible dans le code Unity 5.1.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Le graphique des performances n’est pas disponible.
La connexion à la console SSH indique que la partition metricsluna1 est saturée :
La liste de l’utilisation des fichiers dans cette partition confirme qu’elle est remplie de fichiers archivés :
La connexion à la console SSH indique que la partition metricsluna1 est saturée :
root@XXXXXXXXXXXXX spb:/cores/service/user# df -h Filesystem Size Used Avail Use% Mounted on udev 1.3G 8.0K 1.3G 1% /dev /dev/mapper/alteroot 13G 6.1G 6.1G 51% / tmpfs 17G 100M 17G 1% /dev/shm tmpfs 17G 1.6G 15G 10% /run tmpfs 17G 0 17G 0% /sys/fs/cgroup /dev/ram0 59M 2.1M 57M 4% /tmp /dev/sda7 128G 2.1G 120G 2% /cores /dev/sda1 113M 1.9M 105M 2% /mnt/c4lx-cfg_msata /pramfs 122M 43M 80M 35% /pramfs /dev/mirrora5 57G 4.1G 51G 8% /EMC/backend/service /dev/c4nasdba2 3.5G 391M 2.9G 12% /EMC/backend/CEM /dev/c4nasdba1 997M 51M 895M 6% /nbsnas /dev/c4loga1 3.3G 80M 3.1G 3% /EMC/backend/log_shared /dev/c4loga2 4.6G 9.5M 4.3G 1% /EMC/backend/perf_stats /dev/metricsluna1 16G 16G 0 100% /EMC/backend/metricsluna1 /dev/c4fastvpa1 5.9G 855M 4.8G 15% /EMC/fastvp /dev/dm-7 9.8G 455M 8.9G 5% /var/lib/docker/devicemapper/mnt/852c05c74c281546e57fb096cbfe33bc1a50551d4c65ca180c00d78aa8f320e2
La liste de l’utilisation des fichiers dans cette partition confirme qu’elle est remplie de fichiers archivés :
root@XXXXXXXXXXXXX spb:/cores/service/user# du -h /EMC/backend/metricsluna1/ |sort -hr |head -20 16G /EMC/backend/metricsluna1/ 15G /EMC/backend/metricsluna1/archives 1.2G /EMC/backend/metricsluna1/metricsdb/PG_10_201707211/16406 1.2G /EMC/backend/metricsluna1/metricsdb/PG_10_201707211 1.2G /EMC/backend/metricsluna1/metricsdb 16K /EMC/backend/metricsluna1/lost+found 4.0K /EMC/backend/metricsluna1/metricsdb/PG_10_201707211/pgsql_tmp
Cause
Une fois l’environnement d’exploitation mis à niveau vers la version 5.1, si une baie Unity active CloudIQ, un code empêche la suppression des anciens fichiers d’archivage des performances au niveau du back-end. Ce problème finit par entraîner le remplissage de la partition metricsluna1.
Si la baie Unity répond aux deux critères ci-dessous, elle rencontre ce problème de code :
Si la baie Unity répond aux deux critères ci-dessous, elle rencontre ce problème de code :
- La baie Unity s’exécute sur le code 5.1.
- CloudIQ est activé.
Résolution
La solution de contournement consiste à supprimer manuellement les anciens fichiers d’archivage à l’aide de la méthode tar de l’article 191159 de la base de connaissances : Dell EMC Unity : la mise à niveau vers la version de code 5.1 peut échouer en raison d’un manque d’inodes ou d’incohérences dans la base de données des métriques (corrigible par Dell EMC).
Remarque : Ce fichier peut être enregistré afin que le client l’utilise pour les métriques archivées, si nécessaire.
Vérifier que le fichier tarball est valide :
Supprimer les fichiers d’archivage pour libérer de l’espace :
Ce problème devrait être résolu dans une prochaine version de code.
Remarque : Ce fichier peut être enregistré afin que le client l’utilise pour les métriques archivées, si nécessaire.
Pour libérer l’espace disponible, publiez les commandes suivantes en tant qu’utilisateur root :
- Remplacer le répertoire en répertoire de base.
- Envoyer des fichiers d’archivage à un fichier tarball dans le répertoire de base.
root@APM00000000000 spa:~/home/service/user# tar cvfz metrics_archive.tgz /EMC/backend/metricsluna1/archives/
Vérifier que le fichier tarball est valide :
root@APM00000000000 spa:~/home/service/user# tar -tvf metrics_archive.tgz
Supprimer les fichiers d’archivage pour libérer de l’espace :
root@APM00000000000 spa:~/home/service/user# rm /EMC/backend/metricsluna1/archives/_default*
- Vérifier que l’espace disponible est suffisant :
root@APM00000000000 spa:~/home/service/user# df -h
Ce problème devrait être résolu dans une prochaine version de code.
Produits concernés
Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity HybridPropriétés de l’article
Numéro d’article: 000192659
Type d’article: Solution
Dernière modification: 12 May 2026
Version: 7
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.