AppSync: Renaming AppSync server hostname caused 'copymanagement' and 'settings tab' to be unavailable and dashboard information to vanish.
Résumé: Renaming AppSync server caused abnormal functionality behavior, and the AppSync UI did not show the data.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Issues seen:
- AppSync dashboard shows no information.
- CopyManagement and Settings tabs are unavailable.
- Clicking the Alert tab is getting error "http failure response. 500 internal server error."
- Server logs shows below lock box error:
<DATE & TIME> INFO [default task-9] [com.emc.archway.restapi.RestPreprocessorInterceptor] [AppSync_Server] [] HttpRequest [GET] : https://[AppSync Server Name].com:8445/appsync/rest/types/dashboard/copySummary::filesystem <DATE & TIME> INFO [default task-2] [com.emc.archway.cstinterface.CSTInterface] [AppSync_Server] [] 6552cd79-d344-4041-b5db-6718095475c7->>> CSTInterface constructor - exception The system hostname key is missing from the Lockbox. : File : E:\EMC\AppSync\cst\xml/csp.clb <DATE & TIME> ERROR [default task-2] [com.emc.archway.cstinterface.CSTInterface] [AppSync_Server] [] 6552cd79-d344-4041-b5db-6718095475c7->>> Exception Occurred: IOException, Message: The system hostname key is missing from the Lockbox. : File : E:\EMC\AppSync\cst\xml/csp.clb <DATE & TIME> ERROR [default task-4] [com.emc.archway.restapi.exceptionhandler.AppSyncExceptionHandler] [AppSync_Server] [] Exception Occurred: NullPointerException <DATE & TIME> ERROR [default task-15] [com.emc.archway.restapi.exceptionhandler.AppSyncExceptionHandler] [AppSync_Server] [] Exception Occurred: NullPointerException
- Taking backup of AppSync database through appsync-backup.bat tool shows the below error:
The system hostname key is missing from the Lockbox. : File : E:/EMC/AppSync/cst/xml/csp.clb
Cause
The act of changing the name of the AppSync Server host is considered making the host a new Server. The steps in the AppSync Install Guide section entitled: "Migrating the AppSync server" were not followed causing this issue.
Résolution
Follow the below steps to address the issue:
- Rename the server back to the old name.
- Restart the AppSync server.
- Verify AppSync is working fine. Take a backup of the working AppSync database backup and copy of license files from location C\EMC\AppSync\license\ (by default).
- Once done, note current AppSync version and hotfix level if hotfixes are applied, and then uninstall it.
- Rename the server name as per your requirement and reboot.
- Install a new AppSync at the version and hotfix level previously.
- Import the AppSync database that is taken as a backup in earlier step and verify all is working fine.
Informations supplémentaires
The AppSync product must go through its install process on the Server it is used on. See the Install Guide section entitled: "Migrating the AppSync server" for additional reference.
Propriétés de l’article
Numéro d’article: 000191821
Type d’article: Solution
Dernière modification: 28 Oct 2025
Version: 3
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.