AppSync: Restore from AppSync snapshot may fail due to a timeout

Résumé: Restore from AppSync snapshot to the production host failed due to a timeout.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

A restore operation from AppSync GUI will eventually hang and fail due to a timeout error.

The AppSync events will show:
  
<DATE & TIME> ,Restore Copy,fc520a7d-b08d-41ab-9878-70608fdf8ea6,ORCL_000093,<hostyname>,AppSync failed to restore one or all of the following storage filesystems: /my/path/data99,
 
In server logs will see it's timing out:
 
<DATE & TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands.RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> finished restore/refresh volumes on XIO Array 
<DATE & TIME> INFO [EJB default - 8] [com.emc.archway.xio_commands.RestoreXIOSnapshotCommandBean] [AppSync_Server] [] d5f58e3c-43bd-4e2a-998f-4908473c3af0->>> finished restore/refresh volumes on XIO Array 
<DATE & TIME> WARN [EJB default - 8] [com.arjuna.ats.arjuna] [AppSync_Server] [] ARJUNA012077: Abort called on already aborted atomic action 0:ffff0a25bf41:-396b7557:61391564:19b548
<DATE & TIME> ERROR [EJB default - 8] [org.jboss.as.ejb3.invocation] [AppSync_Server] [] WFLYEJB0034: EJB Invocation failed on component RestoreXIOSnapshotCommandBean for method public boolean com.emc.archway.xio_commands.RestoreXIOSnapshotCommandBean.restorePhasePIT(com.emc.archway.context.ExecutionContext,java.util.Set,boolean): javax.ejb.EJBTransactionRolledbackException: javax.transaction.RollbackException: WFLYEJB0447: Transaction 'Local transaction (delegate=TransactionImple < ac, BasicAction: 0:ffff0a25bf41:-396b7557:61391564:19b548 status: ActionStatus.ABORTED >, owner=Local transaction context for provider JBoss JTA transaction provider)' was already rolled back at org.jboss.as.ejb3@17.0.1.Final//org.jboss.as.ejb3.tx.CMTTxInterceptor.endTransaction(CMTTxInterceptor.java:114)

 

Cause

A number of snapshot were involved in the restore operation which caused delay/timeout. Possible cause not determined however this could be a performance/slowness issue on resources like array and host.

Résolution

Adjusting the transaction timeout value will allow AppSync not to timeout during restore operation.
  
  1. Go to C:\EMC\AppSync\jboss\standalone\configuration\standalone.xml.
  2. Change the value from default of 300 to new value 2400 seconds - <coordinator-environment default-timeout=2400
  3. Stop all the Services (EMC AppSync Datastore and EMC AppSync Security service)
  4. Start the services(EMC AppSync Datastore Service, EMC AppSync Security Service, EMC AppSync server service)

Produits concernés

AppSync
Propriétés de l’article
Numéro d’article: 000191827
Type d’article: Solution
Dernière modification: 28 Oct 2025
Version:  4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.