VxRail : Échec des bilans de santé des nœuds avec message d’échec des requêtes iDRAC

Résumé: Les bilans de santé des nœuds VxRail interrogent l’iDRAC à l’aide de vmk1 à l’aide de Redfish ou de Platform Service. Si l’un des services qui gère ce canal de communication est en panne, les requêtes iDRAC peuvent échouer. ...

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Symptômes

VxVerify exécute des tests sur chaque nœud en téléchargeant un programme de contrôle d’intégrité « minion » afin de détecter les problèmes susceptibles d’entraîner l’échec des mises à niveau. Les bilans de santé des nœuds tels que « idc_q », « idc_swi » et « idc_as » interrogent l’iDRAC à l’aide de remotecmd racadm à l’aide de vmk1.
 
Résultat du test
Code de résultat
    Interprétation des résultats
Pass
0
Les commandes iDRAC ont été exécutées correctement.
Warning
1
Consultez chaque bilan de santé iDRAC pour connaître les conditions d’avertissement
Échec 2 Échec des requêtes iDRAC
Critique 3
Ce test n’a pas de résultat critique.

Si les commandes de l’iDRAC expirent ou obtiennent une réponse non valide, les autres tests basés sur l’iDRAC sont également susceptibles d’échouer (idc_xxx).
Vous trouverez ci-dessous un exemple de sortie du bilan de santé lorsque l’iDRAC ne répond pas :
#========================#======#=========#====================================================================#==============#
|  Hostname / Category   |Status  Dell_KB |  Warnings or Failures, unless tests Passed                         ; Product S.N. |
#========================#======#=========#====================================================================#==============#
| Node1                  | Failure  43184 | idc_q: iDRAC queries failed                                                      .|

Cause

Les contrôles d’intégrité émettent des commandes sur ESXi vers iDRAC à l’aide de l’iDRAC vmk (généralement vmk1), avec des commandes telles que les suivantes :
/opt/vxrail/bin/remotecmd -q -i /etc/ssh/ssh_host_rsa_key -l vxpsvc 169.254.0.1 racadm swinventory
 
Pour que la procédure ci-dessus fonctionne, la connexion interne entre ESXi et iDRAC doit être en cours d’exécution, ce qui dépend du service iSM (dcism ou dellism).
Si les tests basés sur l’iDRAC signalent l’échec des requêtes iDRAC, il se peut que ce soit le canal de communication avec l’iDRAC qui ait échoué, et non une défaillance de l’iDRAC.

Résolution

La première étape pour les événements « échec des requêtes iDRAC » consiste à vérifier l’interface utilisateur de l’iDRAC pour vous assurer qu’elle fonctionne correctement.
Si l’interface utilisateur (UI) à l’iDRAC répond correctement, le problème peut provenir de la connexion ESXi à l’iDRAC. Ce canal de communication utilise VMK1 et est géré par le service iDRAC Service Module (ISM).
Une méthode pour corriger cela consiste à forcer un redémarrage des services iDRAC et iSM à l’aide de VxVerify :
./vxverify.sh -a ism_fix=Node1


Reportez-vous à l’article 205179 : bilan de santé « ism_fix » tentant de corriger automatiquement les problèmes de l’iSM Dell

Produits concernés

VxRail, iDRAC Service Module, VxRail Appliance Family, VxRail Appliance Series, VxRail Software

Produits

VxRail, iDRAC Service Module, VxRail Appliance Family
Propriétés de l’article
Numéro d’article: 000205769
Type d’article: Solution
Dernière modification: 25 Aug 2025
Version:  5
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