PowerScale : OneFS : Échec de la mise à jour du mot de passe du compte de l’ordinateur sur le cluster malgré la réussite de la mise à jour dans AD, ce qui entraîne une indisponibilité des données

Résumé: Dans OneFS 9.5, la mise à jour du mot de passe d’un compte d’ordinateur peut réussir dans Active Directory (AD), mais échouer sur le cluster dans le gestionnaire de clés et le magasin pstore. Les journaux LSASS indiquent un échec de mise à jour du mot de passe de la machine pour le cluster avec ERROR_NETNAME_DELETED. ...

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Symptômes

Les clusters sous OneFS 9.5 peuvent rencontrer un scénario rare impliquant une mise à jour du mot de passe du compte de l’ordinateur. Échec de la mise à jour du mot de passe en interne sur le cluster malgré la réussite de la mise à jour dans AD. Cela entraîne une indisponibilité des données à l’échelle du cluster pour tous les utilisateurs AD de ce domaine qui tentent de s’authentifier.

Les journaux LSASS rapportent ERROR_NETNAME_DELETED dans les lignes faisant référence à un échec de mise à jour du mot de passe du compte d’ordinateur.

Cause

En raison d’un défaut de code, le cluster n’est pas en mesure d’analyser correctement une réponse du contrôleur de domaine (DC) qui se produit lors d’une mise à jour du mot de passe du compte de la machine. Les informations mises à jour qui seraient appliquées à la base de données du cluster ne sont pas traitées, ce qui entraîne une disparité entre le cluster et AD.

Résolution

Il est vivement recommandé de contacter immédiatement le support PowerScale pour validation. Une nouvelle connexion AD est nécessaire pour résoudre le problème, car les tentatives de resynchronisation des mots de passe échouent (comme prévu). Lorsque vous effectuez une nouvelle jonction AD, n’oubliez pas de rajouter le fournisseur d’authentification aux zones d’accès appropriées. Les noms principaux de service (SPN) doivent également être validés. Lorsqu’une machine est jointe à AD, un nouveau compte d’ordinateur est créé, sauf si un compte existant est spécifié. Les SPN créés sont basés sur la configuration actuelle du pool SmartConnect au moment de l’opération de jonction AD. S’il manque quelque chose, il faut les ajouter en conséquence.

Ce problème est généralement plus fréquent lorsque l’environnement AD dispose de quelques contrôleurs de domaine. La promotion de contrôleurs de domaine supplémentaires peut réduire la fréquence du problème. Un correctif a été publié dans OneFS versions 9.5.0.7, 9.7.0.1, 9.8 et supérieures.

Propriétés de l’article
Numéro d’article: 000221362
Type d’article: Solution
Dernière modification: 17 Feb 2026
Version:  5
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