CloudLink: Se muestra el error "No se puede recuperar el certificado solicitado"

Résumé: En vCenter, cuando intenta establecer la confianza con CloudLink, recibe el mensaje de error "No se puede recuperar el certificado solicitado".

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Symptômes

En vCenter, no se puede establecer la confianza con CloudLink durante la configuración inicial del proveedor de claves.

Reciba un mensaje de error como el que se muestra a continuación:
Cannot retrieve the requested certificate
 
Captura de pantalla del mensaje de error

Cause

Una causa de este error es que vCenter no puede comunicarse con CloudLink a través del puerto 5696.

Otra posible causa es que el usuario está ejecutando versiones de CloudLink y vCenter que no son compatibles.

Résolution

  1. Acceda mediante SSH al dispositivo vCenter
  2. Ejecute los siguientes comandos:
ping cloudlinkip
curl -v telnet://cloudlinkip:5696
curl -v --local-port 10000 telnet://cloudlinkip:5696
curl -v --local-port 20000 telnet://cloudlinkip:5696
curl -v --local-port 30000 telnet://cloudlinkip:5696
curl -v --local-port 40000 telnet://cloudlinkip:5696
curl -v --local-port 50000 telnet://cloudlinkip:5696
curl -v --local-port 60000 telnet://cloudlinkip:5696
  1. Si los comandos ping o curl fallan, esto puede indicar un problema de firewall o de red. El usuario debe consultar con el equipo de red , asegurarse de que los puertos necesarios estén abiertos y confirmar que las VM de CloudLink estén en la red o VLAN correctas.
  2. Si los comandos curl se ejecutan correctamente, se recibe un mensaje que dice "Conectado a x.x.x.x", como se muestra en esta captura de pantalla:
Captura de pantalla de conexión correcta
  1. Si los comandos ping y curl o telnet se ejecutan correctamente, compruebe que las versiones de CloudLink y vCenter sean compatibles. Es posible que reciba el mensaje de error No se puede recuperar el certificado solicitado si se utiliza vCenter 8.x con CloudLink 7.1.7 o anterior. Consulte la Guía Este hipervínculo lo redirige a un sitio web fuera de Dell Technologies. de compatibilidad de VMware para conocer las versiones compatibles de vCenter y CloudLink
CloudLink 7.0 es compatible con vCenter 6.x y 7.x.
CloudLink 7.1.x es compatible con vCenter 6.x y 7.x.
CloudLink 8.x es compatible con vCenter 7.x y 8.x.

CloudLink 8.x es la versión oficialmente compatible con vCenter 8.x; sin embargo, CloudLink 7.1.8 y 7.1.9 parecen funcionar con vCenter 8.x.
  1. La actualización de CloudLink a 7.1.8, 7.1.9 u 8.x debería abordar el problema y poder establecer confianza.
 
Exención de responsabilidad: Si el usuario ejecuta PowerFlex, es posible que no pueda actualizar a ciertas versiones de CloudLink. Deben permanecer en la versión de CloudLink que se indica en su RCM.

Produits concernés

CloudLink
Propriétés de l’article
Numéro d’article: 000223969
Type d’article: Solution
Dernière modification: 13 Nov 2025
Version:  4
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