ViPR SRM : Erreurs conflictuelles dans DPA lors de la collecte des logs

Résumé: Le client rencontre des conflits Erreurs dans DPA Collecte des logs

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes



Il existe des erreurs dans les journaux de collecte DPA qui indiquent un conflit avec un rapport, un planning, une période ou une période. Cela entraînera la création de tous les rapports requis choisis dans le SolutionPack SRM sur l’interface graphique DPA.

Dans cet exemple, Recoverpoint, Data Domain et NetBackup ont été choisis dans le SolutionPack, mais seul NetBackup apparaît dans la liste des rapports de l’interface graphique DPA.  Vous trouverez ci-dessous des exemples des différentes erreurs observées dans les journaux de collecte :

WARNING -- [2017-03-31 11:20:17 CDT] -- HttpRequestGroup ::handleResponse() : Impossible de se connecter au xxx.xxx.xxx.com de l’hôte (409) pour la demande @{protocol} ://@{host} :@{port}/apollo-api/schedules. Server returned the following message: Conflit
GRAVE -- [2017-03-31 11:20:17 CDT] -- HttpRequestRetriever ::execute() : Impossible de récupérer le flux sur un groupe
de demandes configuré.SEVERE -- [2017-03-31 11:20:17 CDT] -- AbstractJobExecutor ::executeJobRunner() : Erreur lors de l’exécution de la tâche DDSchedules -> HttpRequestRetriever la supprimant de la file d’attente
com.watch4net.apg.concurrent.JobExecutionException : Erreur inattendue lors de l’exécution de l’étape de la tâche DDSchedules -> HttpRequestRetriever
à com.watch4net.apg.ubertext.parsing.concurrent.SimpleStreamHandlerJob.step(SimpleStreamHandlerJob.java :65)
à com.watch4net.apg.concurrent.executor.DefaultScheduledJobExecutor$ScheduledJob.step(DefaultScheduledJobExecutor.java :249)
à com.watch4net.apg.concurrent.executor.AbstractJobExecutor.executeJobRunner(AbstractJobExecutor.java :124)
    à com.watch4net.apg.concurrent.executor.AbstractJobExecutor.access$500(AbstractJobExecutor.java :24)
à com.watch4net.apg.concurrent.executor.AbstractJobExecutor$JobRunnerImpl.run(AbstractJobExecutor.java :276)
à java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java :1142)
à java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java :617)
à java.lang.Thread.run(Thread.java :745)
Caused by : com.watch4net.apg.concurrent.JobExecutionException : SimpleStreamHandlerJob produced a null StreamHandlerStep during execution!
    at com.watch4net.apg.ubertext.parsing.concurrent.SimpleStreamHandlerJob.step(SimpleStreamHandlerJob.java:50)
    ... 7 autres

AVERTISSEMENT -- [2017-03-31 11:20:17 CDT] -- HttpRequestGroup ::handleResponse() : Impossible de se connecter au xxx.xxx.xxx.com de l’hôte (409) pour la demande @{protocol} ://@{host} :@{port}/apollo-api/schedules. Server returned the following message: Conflit
GRAVE -- [2017-03-31 11:20:17 CDT] -- HttpRequestRetriever ::execute() : Impossible de récupérer le flux sur un groupe
de demandes configuré.SEVERE -- [2017-03-31 11:20:17 CDT] -- AbstractJobExecutor ::executeJobRunner() : Erreur lors de l’exécution de la tâche RPSchedules -> HttpRequestRetriever la suppression de la file d’attente
com.watch4net.apg.concurrent.JobExecutionException : Erreur inattendue lors de l’exécution de l’étape dans la tâche RPSchedules -> HttpRequestRetriever
à com.watch4net.apg.ubertext.parsing.concurrent.SimpleStreamHandlerJob.step(SimpleStreamHandlerJob.java :65)
à com.watch4net.apg.concurrent.executor.DefaultScheduledJobExecutor$ScheduledJob.step(DefaultScheduledJobExecutor.java :249)
à com.watch4net.apg.concurrent.executor.AbstractJobExecutor.executeJobRunner(AbstractJobExecutor.java :124)
    à com.watch4net.apg.concurrent.executor.AbstractJobExecutor.access$500(AbstractJobExecutor.java :24)
à com.watch4net.apg.concurrent.executor.AbstractJobExecutor$JobRunnerImpl.run(AbstractJobExecutor.java :276)
à java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java :1142)
à java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java :617)
à java.lang.Thread.run(Thread.java :745)
Caused by : com.watch4net.apg.concurrent.JobExecutionException : SimpleStreamHandlerJob produced a null StreamHandlerStep during execution!

Cause

Lorsque le SolutionPack DPA est reconfiguré ou redémarré, il tente de créer et de planifier des rapports dans l’interface graphique DPA pour les collectes que le client a choisies dans le SP.  Dans ce cas, il existe déjà des rapports, des plannings ou des périodes et des périodes configurées dans l’interface graphique qui entrent en conflit avec les tâches que SRM tente d’effectuer.

Résolution

Les rapports, planifications ou périodes et fenêtres de période SRM (W4N) en conflit doivent être supprimés de l’interface graphique DPA.  (Il est préférable de supprimer tous ces objets W4N.)

La première étape consiste à arrêter SRM DPA Collector.  Cette opération peut être effectuée dans l’interface utilisateur SRM ou via /opt/APG/bin/manage-modules tout en étant connecté au serveur collecteur.

Pour supprimer des rapports W4N :
- Accédez à l’interface graphique DPA -> Rapports -> Tâches de rapport -> Rapport planifié.
- Cliquez sur l’icône Afficher le filtre .. recherchez les rapports W4N.
- Mettez en surbrillance chaque rapport et appuyez sur le bouton Supprimer.
- Vérifiez maintenant l’onglet Contenu programmé du tableau de bord pour les rapports W4N.
- Vérifiez à nouveau qu’il n’y a aucun rapport W4N dans l’un ou l’autre des onglets.

kA2j0000000RImKCAW_2_0

kA2j0000000RImKCAW_2_1


Pour supprimer des rapports
personnalisés SRM- Accédez à DPA GUI-Reports-Report>> Templates-Custom Report Templates.>
- Cliquez sur l’icône Afficher le filtre .. recherchez les rapports W4N.
- Mettez en surbrillance chaque rapport et appuyez sur le bouton Supprimer.
- Vérifiez maintenant l’onglet System Report Templates pour les rapports W4N.
- Vérifiez à nouveau qu’il n’y a aucun rapport W4N dans l’un ou l’autre des onglets.
 

kA2j0000000RImKCAW_2_2



Pour supprimer des planifications SRM :
- Accédez à DPA GUI-Admin-System-Manage>>> Schedules.
- Parcourez ou filtrez la liste des plannings pour W4N pour Avamar, NetBackup, NetWorker ou Tivoli.
- Pour Recoverpoint et Data Domain, recherchez 15MinInterval, 1HourInterval ou 5MinIntervalDPA.
- Supprimez-les.

 

kA2j0000000RImKCAW_2_3

kA2j0000000RImKCAW_2_4
kA2j0000000RImKCAW_2_5


Pour supprimer des périodes et des fenêtres de périodes SRM :
- Accédez à DPA GUI-Admin-System-Manage>>> Time Periods.
- Les noms des périodes de temps et des périodes de temps ne contiennent pas W4N, mais incluent Avamar, Netbackup et NetWorker ... voir la liste ci-dessous
- Parcourez la liste des périodes pour les noms ci-dessus ou utilisez la fonction de filtrage.
- Les périodes ne peuvent pas être supprimées s’il existe une période existante associée à la période. Voir l’exemple d’erreur ci-dessous.
 
kA2j0000000RImKCAW_2_6


- Les périodes de temps sont difficiles à trouver.  Ceux-ci doivent être vérifiés même si vous ne voyez pas l’erreur ci-dessus. Voici notre méthode actuelle :
  1. Dans la fenêtre Manage Time Periods, cliquez sur Create Time Period.
  2.  dans la nouvelle fenêtre Propriétés de Windows, cliquez sur Modifier les heures.
  3. Il devrait maintenant y avoir une liste de périodes.
  4. Supprimez toutes les périodes Avamar, Netbackup et NetWorker incluant « Décalage de la dernière heure de 15 minutes ».
kA2j0000000RImKCAW_2_7
kA2j0000000RImKCAW_2_8
 
- Dans la fenêtre Manage Time Periods, supprimez toutes les références à Avamar, Netbackup et NetWorker qui incluent « il y a 15 minutes » ou « il y a 1 heure et 15 minutes ».
 
kA2j0000000RImKCAW_2_9

 

La dernière étape consiste à redémarrer le collecteur SRM DPA. Là encore, cette opération peut être effectuée dans l’interface utilisateur SRM ou via /opt/APG/bin/manage-modules une fois connecté au serveur du collecteur.  Une fois l’interface graphique redémarrée, revenez à l’interface graphique DPA et procédez à une actualisation.  Tous les rapports pour les options choisies par le client dans le SolutionPack DPA doivent désormais être disponibles.

kA2j0000000RImKCAW_2_10

À titre de référence, vous trouverez ci-dessous une liste des rapports, des plannings et des périodes qui peuvent potentiellement se trouver dans l’interface graphique DPA :
 
Scheduled Reports
Avamar
- W4N-Avamar All Jobs Report
- W4N-Avamar RestoreDetails Configuration Report
- W4N-Avamar Server Configuration Report
- W4N-Avamar Client Configuration Report
- W4N-Avamar Client Configuration Report
 
Data Domain
- W4N-Data Domain Boost File Replication Statistics
- W4N-Data Domain Modes
- W4N-Data Domain Daily Compression Statistics
- W4N-Data Domain Utilization
- W4N-Data Domain Fibre Channel Port Performance
- W4N-Host Configuration
- W4N-Network Interface Performance by Node
- W4N-Replication Source Performance
- W4N-Replication Target Performance
- W4N-Replication Status
- W4N-Data Domain Total Replicated Capacity
- W4N-Data Domain Total Throughput

NetBackup
- W4N-NetBackup All Jobs Report
- W4N-NetBackup Chargeback Details Configuration Report
- W4N-NetBackup Client Configuration Report
- W4N-NetBackup Disk Volume Configuration Report
- W4N-NetBackup Disk Volume Status Report
- W4N-NetBackup Restore Details
- W4N-NetBackup Server Configuration Report
- W4N-NetBackup Storage Unit Configuration Report
 
NetWorker
- W4N-NetWorker All Jobs Report
- W4N-NetWorker Chargeback Details Report
- W4N-NetWorker Client Configuration Report
- W4N-NetWorker RestoreDetails Configuration Report
- W4N-NetWorker Server Configuration Report
 
Tivoli
- W4N-Tivoli All Jobs Report
- W4N-Tivoli Chargeback Details Report
- W4N-Tivoli Client Configuration Report
- W4N-Tivoli RestoreDetails Configuration Report
- W4N-Tivoli RestoreDetails Configuration Report

Recoverpoint
- W4N-RecoverPoint Chargeback Details
- W4N-RecoverPoint Consistency Group Incoming Write Rates
- W4N-RecoverPoint Consistency Group Data Lag
- W4N-RecoverPoint Performance Time Lag Statistics
- W4N-RecoverPoint Change Details
- W4N-Recover Point Consistency Group Details
- W4N-RecoverPoint Consistency Group High Load Ratio
- W4N-RecoverPoint Consistency Group Throughput
- W4N-RecoverPoint Consistency Group Time Lag
- W4N-RecoverPoint Events Overview report
- W4N-RecoverPoint Journal Utilization
- W4N-RecoverPoint RPA Packet Loss
- W4N-RecoverPoint Consistency Group Copy Details
- W4NRecoverPoint Consistency Group Copy Status
- W4N-RecoverPoint RPA Compression
- W4N-RecoverPoint RPA Details
- W4N-RecoverPoint RPA Throughput
- W4N-RecoverPoint RPA Writes
- W4N-RecoverPoint Replication Set Configuration
- W4N-RecoverPoint Splitter Details
- W4N-Recoverability Detailed Exposures
- W4N-Remote Replication RPO for MV/A                
- W4N-Copy of Remote Replication RPO forecast for SRDF/A
- W4N-Replication RPO Compliance
- W4N-Recoverability Unprotected Nodes
 
Report Templates
Avamar
- Avamar W4N Custom Backup All Jobs
- Avamar W4N Custom Backup Restore Details

NetBackup
- NetBackup W4N Custom Backup All Jobs
- NetBackup W4N Custom Backup Restore Details

NetWorker
- NetWorker W4N Custom Backup All Jobs
- NetWorker W4N Custom Backup Restore Details

Tivoli
- Tivoli W4N Custom Backup All Jobs
- Tivoli W4N Custom Backup Restore Details
 
Schedules
Avamar
- W4N-Avamar-1HourInveral
NetBackup
- W4N-NBU-1HourInterval
Data Domain
- 15MinInterval
- 5MinIntervalDPA
NetWorker
- W4N-NetWorker-1HourInterval
Tivoli
- W4N-Tivoli-1HourInterval
Recoverpoint
- 15MinInterval
- 5MinIntervalDPA
 
 
Times
Avamar
- Avamar 15 mins ago
- Avamar 1 hour and 15 mins ago
 NetBackup
- NetBackup 15 mins ago
- NetBackup 1 hour and 15 mins ago
 NetWorker
- NetWorker 15 mins ago
- NetWorker 1 hour and 15 mins ago
 Tivoli
- Tivoli 15 mins ago
- Tivoli 15 mins ago
- Tivoli 1 hour and 15 mins ago
 
Windows
Avamar
- Avamar Last hour offset by 15 mins
 NetBackup
- NetBackup Last hour offset by 15 mins
 NetWorker
- NetWorker Last hour offset by 15 mins
 Tivoli
- Tivoli Last hour offset by 15 mins

 

Produits concernés

Data Backup & Protection Storage, Storage Software, Avamar Client, Avamar Server, NetWorker
Propriétés de l’article
Numéro d’article: 000057127
Type d’article: Solution
Dernière modification: 17 avr. 2026
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.