PowerProtect Data Manager : Une défaillance quotidienne efface les anciennes sauvegardes Oracle du catalogue

Résumé: Les suppressions Oracle échouent lorsque les sauvegardes ne se trouvent pas dans le fichier de contrôle Oracle.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Ce scénario est différent de celui de PowerProtect : Les suppressions Oracle de PPDM échouent avec le message suivant : La suppression des copies a échoué car l’agent a échoué.

Il s’agit d’un problème ponctuel. Une mise à niveau vers la version 19.12 ou en suivant la solution de contournement ci-dessous peut résoudre le problème.

L’échec de suppression se produit tous les jours. Le script suivant peut supprimer la défaillance, mais il continuera d’échouer le deuxième jour à venir.

cd /usr/local/brs/lib/compliance-verification/bin/cli
python3 compliance.py 
checkdeletefail CATALOG_DELETE_FAILED
deletefailremove CATALOG_DELETE_FAILED 


Le message d’erreur est le suivant :

The RMAN process failed.The delete operation failed for the instance 'XXX' with dbid 'xxxxxxxx' due to the following error: RMAN-20260: backup piece not found in the repository\nRMAN-06092: error while looking up backup piece\n\nRecovery Manager complete.'.\n", 'errorCode': 'APO0025', 'errorMessage': "The RMAN process failed.The delete operation failed for the instance 'XXX' with dbid 'xxxxxxxx' due to the following error: RMAN-20260: backup piece not found in the repository\nRMAN-06092: error while looking up backup piece\n\nRecovery Manager complete.' 

Et la vérification de la sauvegarde par Recovery Manager (RMAN) n’aide pas à résoudre le problème.

Exécutez les deux commandes suivantes pour comparer la date de sauvegarde. 

Connectez-vous à sqlplus et exécutez cette requête :

select handle,status,to_Char(start_time,'DD.MM.YYYY HH24:MI:SS'),to_Char(completion_time,'DD.MM.YYYY HH24:MI:SS') from v$backup_piece order by completion_time;

 

Connectez-vous à RMAN et exécutez :

RMAN>list backup;


La date de sortie RMAN pour les copies de sauvegarde doit être plus récente que la requête SQL. Par exemple, dans RMAN, les copies de sortie du 10 janvier sont visibles, mais dans la requête SQL, les copies de sortie du 8 janvier sont visibles.

Cause

L’agent procède comme suit pour supprimer la copie du catalogue :

  • Tout d’abord, l’agent interroge la liste des éléments de sauvegarde à l’aide de la commande SQL (select handle from v$backup_piece).
  • L’agent annule le catalogage des copies obtenues à partir de la requête SQL.

Peu d’éléments de sauvegarde sont disponibles dans le v$backup_piece et sont incapables de trouver ces pièces dans le RMAN.
Par conséquent, l’erreur suivante s’affiche :
"RMAN-20260: backup piece not found in the repository\nRMAN-06092: error while looking up backup piece\n\nRecovery Manager complete

Si la CONTROL_FILE_RECORD_KEEP_TIME RCA est inférieure à la règle de rétention, elle peut écraser les métadonnées RMAN.

Résolution

Veuillez recueillir les informations suivantes :

  1. Fréquence de la sauvegarde complète.
  2. Politique de rétention des médias pour les sauvegardes.
  3. CONTROL_FILE_RECORD_KEEP_TIME paramètre en exécutant la requête SQL suivante :
show parameter CONTROL_FILE_RECORD_KEEP_TIME;

Si CONTROL_FILE_RECORD_KEEP_TIME est inférieur à la règle de rétention, il peut écraser les métadonnées RMAN, empêchant ainsi RMAN de supprimer des sauvegardes.

Suivez la formule ci-dessous :

CONTROL_FILE_RECORD_KEEP_TIME = retention period + level 0 backup interval + 1

 
Pour plus d’informations, reportez-vous au document suivant :
https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=118418608655386&id=397269.1&displayIndex=1&_afrWindowMode=0&_adf.ctrl-state=11hsmm3c3q_158#BODYTEXT

Produits concernés

PowerProtect App Direct, PowerProtect Software
Propriétés de l’article
Numéro d’article: 000208561
Type d’article: Solution
Dernière modification: 07 oct. 2025
Version:  3
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