Connectrix MDS : SYSMGR-2-SERVICE_CRASHED : Service snmpd

Résumé: SYSMGR-2-SERVICE_CRASHED : Service « snmpd »

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Les processus SNMPD se bloquent avec le message syslog suivant et génèrent un fichier mémoire.

show logging log
2023 Dec 7 18:57:57 DellLAb-1 %SYSMGR-2-SERVICE_CRASHED: Service "snmpd" (PID XXXX) hasn't caught signal 11 (core will be saved).
2023 Dec 7 18:57:57 DellLAb-1 %CALLHOME-2-EVENT: CRASH_PROC

show cores
Module  Instance  Process-name     PID       Date(Year-Month-Day Time)
------  --------  ---------------  --------  -------------------------
5       1         snmpd            XXXX        2023-12-07 18:57:57
 

 

Une augmentation de la consommation de mémoire par le processus SNMP est le signe d’un empilement de fuites de mémoire.

Il y a eu des fuites occasionnelles lors de la manipulation de SNMPv3. Au fil du temps, ces fuites peuvent s’accumuler, conduisant potentiellement à un épuisement de la mémoire dans le processus SNMPD.

Cause

Ce problème a été identifié en raison du bug Cisco MDS NXOS CSCvy03206
Ce problème affecte uniquement les commutateurs MDS exécutés avec la version
8.4(1a).Les fuites sont observées dans les opérations SNMP impliquant le niveau de sécurité V3.

Résolution

Solution de contournement :
1. Il est possible d’éviter les fuites au cours du processus en évitant les opérations SNMP externes.
2. Utilisez SNMPv2 au lieu de SNMPv3 pour snmp get/walk/bulkwalk à partir des interrogateurs.
3. Pour éviter les conditions d’épuisement de la mémoire causées par le processus SNMPD, supprimez-le de bash dans le pire des cas.
Le processus SNMPD réapparaît automatiquement une fois que l’instance en cours du processus est arrêtée. L’engagement du support Dell est nécessaire pour cette option.

Résolution:

Effectuez une mise à niveau vers l’une des versions NXOS suivantes : 8.2(11), 8.4(2d), 8.4(9) ou 9.2(1)

Propriétés de l’article
Numéro d’article: 000223922
Type d’article: Solution
Dernière modification: 17 juin 2024
Version:  2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.