Data Domain : Disques signalés comme « étrangers »

Résumé: Cet article explique pourquoi les disques apparaissent dans un état étranger sur les systèmes Data Domain et fournit les étapes nécessaires pour résoudre ce problème sans risquer de perdre des données. ...

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

  • Un ou plusieurs disques affichent un état étranger dans le système.
  • Cette condition peut se produire après :
    • Remplacement du boîtier (unité principale)
    • Mises à niveau du contrôleur
    • Ajout d’un tiroir d’extension qui appartenait auparavant à un autre système

S’applique à :

  • Tous les systèmes Data Domain
  • Toutes les versions de DDOS

Cause

Un disque passe à l’état étranger lorsqu’il contient des données de système de fichiers Data Domain valides provenant d’un autre système.
L’objectif est d’éviter les écrasements accidentels et de s’assurer que les données sont gérées en toute sécurité.

Les scénarios les plus courants sont les suivants :

  • Remplacement du boîtier ou du contrôleur
  • Mises à niveau de l’unité principale
  • Déplacement d’un tiroir d’un système à un autre
  • Ajout d’un tiroir qui n’a pas été correctement retiré de son système d’origine
⚠️Avertissement: Ne PAS exécuter disk unfail sur les disques étrangers. Cela entraîne une perte de données.

Résolution

Confirmez que le ou les disque(s) sont signalés comme Étranger en identifiant l’état du disque à l’aide de la commande CLI : #disk show state (passez en revue les types d’état des disques dans l’article de la base de connaissances : Data Domain : Identification et résolution des états des disques)


  1. Si les disques sont Étranger après un remplacement du châssis ou une mise à niveau du contrôleur
    • La commande Étranger L’état est normal après un remplacement de châssis où le remplacement de la tête a été effectué dans le menu « Erreur de configuration du système ». 
    • Suivez les instructions fournies dans la documentation du guide de mise à niveau du contrôleur ou de remplacement du châssis : 
      • #system headswap La commande peut être nécessaire : elle transmet le numéro de série de la carte principale aux disques, ce qui permet au système de les utiliser.
    • Une fois le headswap terminé, les disques « étrangers » passent à l’état « en cours d’utilisation »

Si des disques sont signalés comme étrangers après l’ajout d’un tiroir d’extension : 

  • Cela se produit lorsqu’un tiroir a été précédemment relié à un autre système DD et n’a pas été retiré proprement.

    Pour ajouter le boîtier en toute sécurité :

  • Pour ajouter le boîtier au nouveau système, les disques du boîtier doivent se trouver dans a Pièce de rechange ou Inconnu État: 
    • Faites correspondre le numéro de série du boîtier au Étranger Lecteurs.
      • Exécutez la commande #enclosure show summary pour localiser le numéro de série du boîtier. 
      • Exécutez ensuite la commande #disk show state Assurez-vous que la création de rapports sur les disques Étranger sont dans le nouveau boîtier avant de continuer.
      • S’ils ne correspondent pas, NE PASSEZ PAS aux étapes suivantes, car cela peut entraîner une perte de données.
    • Unfail (# disk unfail n.n) tous les disques du boîtier ajouté, un par un, pour les définir sur un De remplacement État.
    • Puis, exécutez #disk show state Pour vérifier que les disques sont Rechange.
    • Ajoutez le boîtier au système.

Remarque : Si le problème persiste après avoir suivi les étapes décrites dans cet article, contactez votre fournisseur de support sous contrat, rassemblez un bundle de support (SUB) et créez une demande de service

Informations supplémentaires

Produits concernés

Data Domain

Produits

Data Domain
Propriétés de l’article
Numéro d’article: 000031955
Type d’article: Solution
Dernière modification: 20 janv. 2026
Version:  4
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