ECS: 다이얼 홈 - Ref_ID: BtreeChunkLevelGC - 증상 코드: 1321

Résumé: 이것은 ECS 3.3에 도입된 Dial-Home입니다. 경고.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

ECS 시스템에서 다음 알림과 함께 다이얼 홈을 실행했습니다. 

<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="psnt1">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>psnt1</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>psnt1</SerialNumber>
            <WWN>ECSQE00077</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4352.834410f</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>orem-maize.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.197.3</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1321</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Warning</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>BTREE Chunk GC</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T20:09:07.861Z</FirstTime>
                    <LastTime>2019-01-29T20:09:07.861Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[System metadata garbage collection throughput is too slow to catch up with garbage detection. Please involve ECS engineering.  [Ref_ID : BtreeChunkLevelGC]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

BTREE GC는 청크 재확보 단계에서 느리게 작동합니다. 이 알림은 전체 가비지가 1TB를 초과하고 가비지 탐지 속도와 가비지 청크 재확보 속도 간의 차이가 100GB보다 큰 경우에 생성됩니다. 이 알림은 시스템이 이 상태로 7일 동안 유지되면 전송됩니다.

Résolution

  1. putty 세션을 통해 클러스터의 노드 중 하나에 연결합니다.
  2. 현재 센서 상태를 확인합니다.
명령:
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>BtreeChunkLevelGC</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>Btree Chunk Level GC</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
  1. CurrentState>가<OK로 설정된 경우 error가 활성 상태가 아니며 이는 잘못된 알림일 수 있습니다. 알림을 무시하되 다음 주 내에 다시 트리거되면 기술 지원 부서에 서비스 요청을 개설하십시오.

Produits concernés

ConnectEMC, ECS Appliance
Propriétés de l’article
Numéro d’article: 000038616
Type d’article: Solution
Dernière modification: 17 déc. 2025
Version:  8
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.