ECS: Dial Home - Ref_ID: BtreeChunkLevelGC - Codice sintomo: 1321

Résumé: Si tratta di una dial-home introdotta in ECS 3.3 per rilevare Vigile.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Un sistema ECS ha effettuato una chiamata a casa con il seguente avviso. 

<?xml version="1.0" encoding="UTF-8"?>
<ConnectHome SchemaVersion="1.0.8"
    xsi:schemaLocation="/opt/connectemc/schema/ema_ConnectHome108.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <TransType>10</TransType>
    <TransTypeDesc>EventXML</TransTypeDesc>
    <TransID>0</TransID>
    <Node Status="Unknown" State="Unknown" ID="psnt1">
        <Identifier>
            <DeviceState>1</DeviceState>
            <DeviceStatus>1</DeviceStatus>
            <ClarifyID>psnt1</ClarifyID>
            <SiteName>UNKNOWN</SiteName>
            <Vendor>EMC</Vendor>
            <DeviceType>ElasticCloudStorageApp</DeviceType>
            <Model>ElasticCloudStorage</Model>
            <SerialNumber>psnt1</SerialNumber>
            <WWN>ECSQE00077</WWN>
            <Platform>platform</Platform>
            <OS>SLES</OS>
            <OS_VER>12.3</OS_VER>
            <UcodeVer>3.3.0.0-4352.834410f</UcodeVer>
            <EmbedLevel>2</EmbedLevel>
            <InternalMaxSize>512800</InternalMaxSize>
            <Comment>Object Alert</Comment>
        </Identifier>
        <Connection>
            <ConnectType>ESRS</ConnectType>
            <IPName>orem-maize.ecs.lab.emc.com</IPName>
            <ConnectNum>169.254.197.3</ConnectNum>
            <Port>22</Port>
        </Connection>
        <HeartBeat>
            <HBStatus></HBStatus>
            <HBState></HBState>
        </HeartBeat>
        <InternalData>
            <FileList/>
            <EventList>
                <Event>
                    <SymptomCode>1321</SymptomCode>
                    <Category>Configuration</Category>
                    <Severity>Warning</Severity>
                    <Status>Unknown</Status>
                    <Component>Object</Component>
                    <ComponentID></ComponentID>
                    <SubComponent>BTREE Chunk GC</SubComponent>
                    <SubComponentID></SubComponentID>
                    <CallHome>true</CallHome>
                    <FirstTime>2019-01-29T20:09:07.861Z</FirstTime>
                    <LastTime>2019-01-29T20:09:07.861Z</LastTime>
                    <Count>0</Count>
                    <EventData><![CDATA[]]></EventData>
                    <Description><![CDATA[System metadata garbage collection throughput is too slow to catch up with garbage detection. Please involve ECS engineering.  [Ref_ID : BtreeChunkLevelGC]]]></Description>
                </Event>
            </EventList>
        </InternalData>
        <ExternalFiles/>
    </Node>
</ConnectHome>

Cause

GC BTREE funziona lentamente nella fase di recupero del blocco. Questo avviso viene generato quando sono presenti più di 1 TB di garbage piena e la differenza tra il tasso di rilevamento della garbage e la velocità di recupero del garbage chunk è maggiore di 100 GB. L'avviso viene inviato quando il sistema è in questo stato da 7 giorni.

Résolution

  1. Connettersi a uno dei nodi del cluster in una sessione PuTTY.
  2. Verificare lo stato corrente del sensore.
Comando:
svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
# svc_rest_cmd -i `hostname -i` /vdc/sensor/status/BtreeChunkLevelGC
svc_rest_cmd 1.0.10

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<SensorStatusList>
  <SensorId>BtreeChunkLevelGC</SensorId>
  <ListSensorStatus>
    <SensorStatusRestRep>
      <ContextId>Btree Chunk Level GC</ContextId>
      <CurrentState>OK</CurrentState>
      <NodeId>1f4368c3-37cd-467f-9efc-289264806ea0</NodeId>
      <PreviousState>OK</PreviousState>
      <Time>1551118064264</Time>
    </SensorStatusRestRep>
  </ListSensorStatus>
  1. <Cercare CurrentState>; se è impostato su OK, l'errore non è attivo ed è probabile che si tratti di un falso avviso. Ignorare l'avviso, ma se si attiva di nuovo entro la settimana successiva, aprire una Service Request con il supporto tecnico

Produits concernés

ConnectEMC, ECS Appliance
Propriétés de l’article
Numéro d’article: 000038616
Type d’article: Solution
Dernière modification: 17 déc. 2025
Version:  8
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.