PowerFlex : Écarts observés dans les graphiques CloudIQ
Résumé: Des écarts sont observés dans les graphiques de performances CloudIQ (CIQ).
Symptômes
Scénario
Dans l’onglet Performances de CIQ, les écarts de temps sont visibles entre les compteurs de performances dans les graphiques :
Impact
Bien qu’il n’y ait aucun problème avec le stockage PowerFlex, les données de performances sur CloudIQ sont incomplètes.
Cause
Flux de collecte de données :
- Toutes les 5 s, PowerFlex GW collecte les données de performances des MDM.
- Toutes les 5 minutes, la passerelle PowerFlex envoie un fichier ZIP de performances compressé à CIQ via Secure Connect Gateway (SCG).
Les graphiques de performances dans CIQ consistent en données de performances cumulées collectées à partir des MDM et envoyées par la passerelle PowerFlex (GW).
CIQ s’attend à ce que le fichier de performances arrive dans un délai d’environ 5 minutes (+2 s), et GW envoie le fichier avec un court délai de 15 à 19 s.
Les fichiers de performances arrivent plus tard que prévu par CIQ, et CIQ ne peut pas les faire correspondre pour s’adapter à l’horaire du graphique.
Par exemple:
Le fichier powerflex_1696852800000_<SWID>_performance.zip contient l’heure de création « 1696852800000 » en epoch, ce qui correspond à lundi 9 octobre 2023 12:00:00.000
Le fichier de performances a été créé à 12:00:00 PM et a été reçu dans CIQ avec un horodatage plus tardif que prévu. Le fichier qui est arrivé à CIQ contient l’heure de création « 1696853080389 » en heure epoch, ce qui se traduit par lundi 09 octobre 2023 12:04:40.389 et a été mappé à la base de données CIQ à 12:05.
Cette différence d’heure crée une brèche dans le graphique des données de performances.
Résolution
Pour résoudre le problème, mettez à niveau le système PowerFlex vers la version corrigée mentionnée ci-dessous.
Version concernée
PowerFlex 3.5.x
PowerFlex 3.6.3 et versions inférieures
Problème résolu dans la version
PowerFlex 3.6.4