PowerEdge : Échec normal des opérations d’arrêt ou de redémarrage à l’aide de Redfish pour Windows Server
Résumé: Le lancement d’un redémarrage ou d’un arrêt normal à l’aide des API Redfish peut échouer pour le système d’exploitation Windows Server.
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Le problème est intermittent et se produit rarement lorsque le système d’exploitation a une charge applicative en cours d’exécution ou est dans un état actif.
La fréquence des problèmes est de 100 % lorsque le système d’exploitation est dans un état verrouillé ou a été inactif pendant de nombreuses heures.
Étapes à reproduire :
Python ou toute autre commande de script d’automatisation peut être utilisée.
- Effectuez une opération POST pour effectuer
GracefulRestartouGracefulShutdownde l’ordinateurSystème à l’aide de l’adresse IP de l’iDRAC du serveur. - URI:
redfish/v1/Systems/System.Embedded.1/Actions/ComputerSystem.Reset - Charge:
- {
"ResetType":"GracefulRestart"}: Lorsqu’un redémarrage normal est lancé à partir des API Redfish, la tâche est créée à partir de l’iDRAC et échoue. Les journaux LifeCycle Controller indiquent :Unable to reboot system.
- {
"ResetType":"GracefulShutdown"}: Lorsqu’un arrêt approprié est lancé à partir des API Redfish, les journaux LifeCycle Controller indiquent :Requested system graceful shutdownmais ne s’exécute pas.
Vous trouverez ci-dessous les versions des systèmes d’exploitation concernés.
- Windows Server 2019
- Windows Server 2022
Toutes les plates-formes PowerEdge prises en charge pour ces versions du système d’exploitation Windows sont concernées.
Cause
L’observation, c’est fonctionner comme prévu. Le système d’exploitation n’accepte pas le redémarrage normal ou l’arrêt normal lorsque le système est en mode veille ou veille prolongée.
Le système doit être connecté ou actif pour que le redémarrage normal réussisse. Consultez l’article Microsoft Lors de la tentative de redémarrage normal (à l’aide de Redfish) sur Windows Server 2022 - Microsoft Community
Le système doit être connecté ou actif pour que le redémarrage normal réussisse. Consultez l’article Microsoft Lors de la tentative de redémarrage normal (à l’aide de Redfish) sur Windows Server 2022 - Microsoft Community
Résolution
Cela fonctionne normalement.
Contournement:
Contournement:
- Effectuez un redémarrage à chaud à partir de l’iDRAC ou un redémarrage normal à partir du système d’exploitation.
- Exécutez un cycle d’alimentation à partir de Redfish. Il s’agit d’un redémarrage forcé.
Produits concernés
Microsoft Windows Server 2019, Microsoft Windows Server 2022Produits
PowerEdge XR2, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360
, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, PowerEdge XR11, PowerEdge XR12
...
Propriétés de l’article
Numéro d’article: 000224986
Type d’article: Solution
Dernière modification: 11 mars 2026
Version: 6
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.