PowerFlex 4.X: Zobrazuje zdroj brány PowerFlex Unreachable

Résumé: Zdroj PowerFlex Gateway zobrazí výstrahu, že systém PowerFlex není dostupný.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Backendový systém PowerFlex stále používá software 3.x a byl importován do systému PowerFlex Manager 4.x.

 

Důsledky

Nelze provést úspěšný upgrade brány PowerFlex.

 

Cause

V nástroji PowerFlex Manager jsou k dispozici dva pody brány, které zodpovídají za požadavky na vyrovnávání zatížení. I když je back-endový systém ve verzi 3.x, brána používá token pro ověřování pomocí MDM. Ověřovací token je ale uložený jenom na jedné z bran. Proto při provedení více po sobě jdoucích volání může funkce vyrovnávání zatížení směrovat některá volání na bránu bez přihlašovacího tokenu, což způsobí selhání těchto volání. Toto selhání způsobí, že zdroj brány upozorní, že systém PowerFlex je nedostupný.

 

Résolution

Přetáhněte sadu replik bran PowerFlex na jednu bránu:

  1. Připojte se přes SSH k libovolnému hostiteli platformy PowerFlex Management Platform.

  2. Snižte počet replik na 1:

    kubectl scale sts block-legacy-gateway -n powerflex --replicas=1
  3. Proveďte upgrade brány. Tím dojde k upgradu systému na verzi 4.x, kde se používá MTLS a k tomuto problému nedochází.

  4. Po upgradu backendového systému PowerFlex na verzi 4.x upravte sadu repliky pro bránu zpět na hodnotu 2:

    kubectl scale sts block-legacy-gateway -n powerflex --replicas=2

 

Dotčená verze

PowerFlex Manager 4.x

Opraveno ve verzi

PowerFlex Manager 4.6.1

 

Produits concernés

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
Propriétés de l’article
Numéro d’article: 000226554
Type d’article: Solution
Dernière modification: 01 janv. 2026
Version:  2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.