ECS: Latenza riscontrata durante l'accesso o l'autenticazione a un nodo specifico

Résumé: Latenza o risposta lenta riscontrata durante l'accesso a un sistema tramite ssh o l'esecuzione di comandi che richiedono l'autenticazione per una sessione remota.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Quando si effettua una connessione SSH a un nodo, si esegue sudo o qualsiasi altro comando che richiede l'autenticazione, si verifica un ritardo. Dopo il ritardo, il comando viene eseguito normalmente.  Il nodo non è sottoposto a carichi intensivi e il tempo di attività mostra le medie di carico normali. 

Se il livello di dettaglio è abilitato per una connessione ssh utilizzando -vvv, il ritardo di accesso si verifica dopo "pledge: exec"

Esempio:
admin:~> ssh 169.254.1.2 -vvv
OpenSSH_7.2p2, OpenSSL 1.0.2p-fips  14 Aug 2018
debug1: Reading configuration data /home/admin/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 25: Applying options for *
debug2: resolving "169.254.1.2" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 169.254.1.2 [169.254.1.2] port 22.
debug1: Connection established.
... <truncated debugging>
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug3: send packet: type 90
debug1: Requesting no-more-sessions@openssh.com
debug3: send packet: type 80
debug1: Entering interactive session.
debug1: pledge: exec

Dopo una pausa di 20+ secondi, l'accesso procederà normalmente.


Sul nodo che presenta il problema se lo stato del servizio dbus è controllato, segnala timeout:
admin:~> sudo systemctl status dbus
● dbus.service - D-Bus System Message Bus
   Loaded: loaded (/usr/lib/systemd/system/dbus.service; static; vendor preset: disabled)
   Active: active (running) since Fri 2024-01-23 04:56:00 UTC; 1 months 2 days ago
     Docs: man:dbus-daemon(1)
 Main PID: 3060 (dbus-daemon)
    Tasks: 1 (limit: 512)
   Memory: 5.8M
      CPU: 10h 45min 897ms
   CGroup: /system.slice/dbus.service
           └─3060 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation

Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:28:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:29:22 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30009ms)
Mar 22 18:29:24 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30002ms)
Mar 22 18:29:54 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)
Mar 22 18:30:01 <ecs-node-fqdn> dbus[3060]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 30000ms)

Messaggi di timeout simili sono stati trovati in /var/log/messages




Cause

Viene raggiunto un limite di connessione per il servizio dbus che causa un ritardo per l'accesso e/o l'autenticazione

Résolution

Questo problema può essere risolto riavviando il servizio dbus e anche, per i nodi primari, il servizio dnsmasq. Non vi è alcun impatto previsto, tuttavia ottenere l'approvazione del cliente, se necessario. 

Dal nodo in cui si è verificato il problema, riavviare dbus utilizzando il comando:  
 
sudo systemctl restart dbus
admin:~> sudo systemctl restart dbus
Questo comando non prevede alcun output. 

Al termine del comando, controllare lo stato del servizio dbus per assicurarsi che sia "active (running)" eseguendo il comando seguente:
 
sudo systemctl status dbus
admin ~> sudo systemctl status dbus
● dbus.service - D-Bus System Message Bus
   Loaded: loaded (/usr/lib/systemd/system/dbus.service; static; vendor preset: disabled)
   Active: active (running) since Fri 2024-07-19 18:07:00 UTC; 5s ago
     Docs: man:dbus-daemon(1)
 Main PID: 19340 (dbus-daemon)
    Tasks: 1 (limit: 512)
   Memory: 884.0K
      CPU: 22ms
   CGroup: /system.slice/dbus.service
           └─19340 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation

Se il nodo è un nodo primario (in genere il nodo 1) è anche necessario riavviare dnsmasq con il comando: 
 
sudo systemctl restart dnsmasq
admin:~> sudo systemctl restart dnsmasq
Questo comando non prevede alcun output. 

Dopo aver riavviato dnsmasq, verificare che il servizio sia "active (running)" utilizzando il comando:
 
sudo systemctl status dnsmasq
admin~> sudo systemctl status dnsmasq
● dnsmasq.service - DNS caching server.
   Loaded: loaded (/usr/lib/systemd/system/dnsmasq.service; disabled; vendor preset: disabled)
  Drop-In: /run/systemd/generator/dnsmasq.service.d
           └─50-insserv.conf-$named.conf
   Active: active (running) since Fri 2024-07-19 18:14:47 UTC; 2s ago
  Process: 61272 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCCESS)
 Main PID: 61297 (dnsmasq)
    Tasks: 1 (limit: 512)
   Memory: 2.1M
      CPU: 8ms
   CGroup: /system.slice/dnsmasq.service
           └─61297 /usr/sbin/dnsmasq --log-async --enable-dbus --keep-in-foreground

Una volta riavviati i servizi, testare l'accesso al nodo utilizzando ssh o eseguendo un comando sudo per verificare che il ritardo sia stato risolto. 

Produits concernés

ECS, ECS Appliance, ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Hardware Gen1 C-Series, ECS Appliance Hardware Gen2 C-Series, ECS Appliance Hardware Gen2 D-Series , ECS Appliance Hardware Gen2 U-Series ...

Produits

ECS Appliance Hardware Gen3 EX5000, ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Gen3 EXF900, ECS Appliance Hardware Series, ECS Appliance Software with Encryption , ECS Appliance Software without Encryption, ECS Software ...
Propriétés de l’article
Numéro d’article: 000227096
Type d’article: Solution
Dernière modification: 02 août 2024
Version:  1
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.