PowerEdge: DFSR-fel 4004-kod 9003 på Windows-server

Résumé: I den här artikeln beskrivs stegen för att återställa från DFSR-fel 4004 om felbeskrivningen innehåller kod 9003: "Replikgruppen är ogiltig." Andra koder tas inte upp här.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

  • DFSR (Distributed File System Replication) misslyckas.
  • DFS Replication-händelseloggen visar fel 4004, med felkoden 9003, "Replikgruppen är ogiltig" i beskrivningen. Det finns andra möjliga felkoder för den här händelsen. Den här artikeln kanske inte är tillämplig på något annat än felkod 9003.

Cause

Det här problemet kan orsakas av felaktig information i DFSR-databasen.

Résolution

Problemet kan lösas genom att ta bort DFSR-databasen och låta systemet bygga om den. Det gör du genom att utföra följande steg på den berörda servern:

  1. Stoppa DFS Replication-tjänsten.
  2. Leta upp DFSR-databasen, som ska finnas i X:\System Volume Information\DFSR\database_<string> mapp. (Ersätt X: Med bokstaven i den volym där DFSR-innehållet lagras.)
    • Som standard har endast SYSTEM-kontot åtkomst till mappen System Volume Information. Det är nödvändigt att ändra behörigheterna för den här mappen för att få åtkomst, och det kan också vara nödvändigt att bli ägare till mappen.
  3. Kopiera mappen till en säker plats om något skulle gå fel.
  4. Ta bort allt i mappen. Det är inte nödvändigt att ta bort själva mappen.
    • Även om du har fullständig behörighet för den här mappen kan du få felmeddelandet "Åtkomst nekad" när du försöker ta bort dess innehåll. Om detta inträffar kan du förmodligen ta bort filerna från en upphöjd kommandotolk.
  5. Starta tjänsten DFS Replication. En ny databas skapas automatiskt, och detta bör lösa problemet.

Produits concernés

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows 2012 Server, Microsoft Windows 2012 Server R2, OEMR R240, OEMR R250, OEMR R260, OEMR R340, OEMR R350, OEMR R360, OEMR R440, OEMR R450 , OEMR R540, OEMR R550, OEMR R640, OEMR R6415, OEMR R650, OEMR R6515, OEMR R6525, OEMR R660, OEMR R6615, OEMR R6625, OEMR R740, OEMR XL R740, OEMR R740xd, OEMR XL R740xd, OEMR R740xd2, OEMR R7415, OEMR R7425, OEMR R750, OEMR R7515, OEMR R7525, OEMR R760, OEMR R760XD2, OEMR R7615, OEMR R7625, OEMR R840, OEMR R860, OEMR R940, OEMR R940xa, OEMR R960, OEMR XR5610, PowerEdge R240, PowerEdge R250, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R7515, PowerEdge R7525, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge XR5610, PowerEdge XR8620t ...
Propriétés de l’article
Numéro d’article: 000201706
Type d’article: Solution
Dernière modification: 02 Sep 2025
Version:  4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.