Uživatel root se nemůže přihlásit do WebUI/CLI verze 8.x, když je nastavena výchozí doména

Résumé: Duplicitní uživatel root v doméně způsobuje problémy s přihlášením do clusteru přes rozhraní WebUI a CLI.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Při přihlašování do clusteru prostřednictvím webového rozhraní nebo rozhraní příkazového řádku selže s chybou hesla.

To platí pro systém OneFS 8.x, pokud je v doméně duplicitní uživatel (například root).

Stále se můžete přihlásit pomocí unix_users domény:

UNIX_USERS\root

Ověřte, zda je daná doména nastavena na výchozí doménu:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Cause

Pokud je nastavena výchozí doména, systém OneFS se nejprve spojí s doménou a ověří příslušného místního uživatele. V tomto případě používáme uživatele root. Pokud uživatel v doméně existuje, systém OneFS se pokusí ověřit uživatele prostřednictvím domény.

Pokud je účet zakázán, při pokusu o přihlášení se zobrazí chyba.

 

Résolution

Ve verzi 8.x můžete pomocí následujícího příkazu přidat uživatele, které nelze najít, do libovolného řadiče domény:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

Abyste se ujistili, že byla nastavení provedena, spusťte znovu zobrazení ověřování:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

Aby cluster mohl odfiltrovat uživatele, kteří nelze najít, musí být zapnuto omezení zjistitelných uživatelů.

 

Propriétés de l’article
Numéro d’article: 000050102
Type d’article: Solution
Dernière modification: 17 Apr 2026
Version:  5
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.